質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.13%

Ruby on Rails windowsからmacへの移行

受付中

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 1,405

ask_man

score 11

windowsでRailsを使い、開発をしていたのですが、つい先日macを買いました。

macでの開発環境を整え、早速開発を再開しようと
以前windowで開発していたRailsのファイルをmacに移したのですが、エラーがでてローカルサーバーが立ち上がりません。

mac上で新しく生成した場合は、正常に作動します。
Railsのファイルにはmacとwindowsの間に何か違いがあるのでしょうか。

回答のほど、宜しくお願い致します。

〜追記〜
windowsではwindows10、macではos Macです。
Homebrewを使いRubyをインストールしました。
Rubyのバージョンは2.2.3です。
Railsは特に指定しなかったので、最新版かと思われます。
以下がエラー文です。
Bundler could not find compatible versions for gem "nokogiri":

In snapshot (Gemfile.lock):

nokogiri (= 1.7.0.1) x64-mingw32

In Gemfile:

jquery-rails was resolved to 4.2.2, which depends on

rails-dom-testing (< 3, >= 1) was resolved to 2.0.2, which depends on

nokogiri (~> 1.6)

Running bundle update will rebuild your snapshot from scratch, using only

the gems in your Gemfile, which may resolve the conflict.

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • raccy

    2017/04/26 05:59

    立ち上げるときのコマンドとエラー内容(なるべく全て)、WindowsとMacそれぞれについての、OSバージョン、Rubyをインストールした方法、Rubyのバージョン、そのたRubyについて実施したと事を追記して下さい。OSの違いというよりも、bundle installをしていないとかやり方そのものが間違っている可能性がありますが、今の情報だけでは何もわかりません。

    キャンセル

  • ask_man

    2017/04/26 10:14

    ご指摘ありがとうございます。追記します。

    キャンセル

回答 1

+1

Windowsで作られたGemfile.lockにWindows環境を指定する情報が記載されているようです。MacはWindowsではありませんので、bundle installしてもGemfile.lockにある内容でパッケージを入れることができません。

エラーメッセージにあるとおり、bundle updateを実行して、Macにあわせたパッケージ構成を再作成して下さい。Gemfile.lockがMacの環境に合わせて作り直されます。

もし、bundle updateに問題が発生する場合は、Gemfile内にWindowsのみ使えるパッケージが記載されているなど、問題がありますので、その内容を詳しく(メッセージとGemfileの中身全て)出して、再度質問して下さい。

なお、bundle updateで意図せぬバージョンにアップデートされてしまう場合は、Gemfileを見直し、想定しているバージョンになるよう、調整してください。

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.13%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る