質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.55%

ローカルから移行したファイルを実行できない問題について

受付中

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 737

firefox636

score 26

最近ローカル(iMac)からさくらvpsにディレクトリを移行したのですが、

実行すると必ずエラーが起きて困っています。

どのようにすればいいのか助言をお願いします。

・環境
Ruby 2.2.3
Ruby on Rails 4.2.6
postgresql 9.5.5
さくらvps
Apache+passenger

・エラー内容

/home/****/rails_app/vendor/bundle/ruby/2.2.0/gems/pg-0.19.0/lib/pg.rb:4:in `require': cannot load such file -- pg_ext (LoadError)
    from /home/****/rails_app/vendor/bundle/ruby/2.2.0/gems/pg-0.19.0/lib/pg.rb:4:in `<top (required)>'
    from /home/****/.rbenv/versions/2.2.3/lib/ruby/gems/2.2.0/gems/bundler-1.13.6/lib/bundler/runtime.rb:91:in `require'
    from /home/*****/.rbenv/versions/2.2.3/lib/ruby/gems/2.2.0/gems/bundler-1.13.6/lib/bundler/runtime.rb:91:in `block (2 levels) in require'
    from /home/*****/.rbenv/versions/2.2.3/lib/ruby/gems/2.2.0/gems/bundler-1.13.6/lib/bundler/runtime.rb:86:in `each'
    from /home/******/.rbenv/versions/2.2.3/lib/ruby/gems/2.2.0/gems/bundler-1.13.6/lib/bundler/runtime.rb:86:in `block in require'
    from /home/******/.rbenv/versions/2.2.3/lib/ruby/gems/2.2.0/gems/bundler-1.13.6/lib/bundler/runtime.rb:75:in `each'
    from /home/******/.rbenv/versions/2.2.3/lib/ruby/gems/2.2.0/gems/bundler-1.13.6/lib/bundler/runtime.rb:75:in `require'
    from /home/******/.rbenv/versions/2.2.3/lib/ruby/gems/2.2.0/gems/bundler-1.13.6/lib/bundler.rb:106:in `require'
    from /home/******/rails_app/config/application.rb:16:in `<top (required)>'
    from /home/******/rails_app/vendor/bundle/ruby/2.2.0/gems/railties-4.2.6/lib/rails/commands/commands_tasks.rb:78:in `require'
    from /home/******/rails_app/vendor/bundle/ruby/2.2.0/gems/railties-4.2.6/lib/rails/commands/commands_tasks.rb:78:in `block in server'
    from /home/******/rails_app/vendor/bundle/ruby/2.2.0/gems/railties-4.2.6/lib/rails/commands/commands_tasks.rb:75:in `tap'
    from /home/******/rails_app/vendor/bundle/ruby/2.2.0/gems/railties-4.2.6/lib/rails/commands/commands_tasks.rb:75:in `server'
    from /home/******/rails_app/vendor/bundle/ruby/2.2.0/gems/railties-4.2.6/lib/rails/commands/commands_tasks.rb:39:in `run_command!'
    from /home/******/rails_app/vendor/bundle/ruby/2.2.0/gems/railties-4.2.6/lib/rails/commands.rb:17:in `<top (required)>'
    from /home/******/rails_app/bin/rails:9:in `require'
    from /home/******/rails_app/bin/rails:9:in `<top (required)>'
    from /home/******/rails_app/vendor/bundle/ruby/2.2.0/gems/spring-1.7.2/lib/spring/client/rails.rb:28:in `load'
    from /home/******/rails_app/vendor/bundle/ruby/2.2.0/gems/spring-1.7.2/lib/spring/client/rails.rb:28:in `call'
    from /home/******/rails_app/vendor/bundle/ruby/2.2.0/gems/spring-1.7.2/lib/spring/client/command.rb:7:in `call'
    from /home/******/rails_app/vendor/bundle/ruby/2.2.0/gems/spring-1.7.2/lib/spring/client.rb:30:in `run'
    from /home/******/rails_app/vendor/bundle/ruby/2.2.0/gems/spring-1.7.2/bin/spring:49:in `<top (required)>'
    from /home/******/rails_app/vendor/bundle/ruby/2.2.0/gems/spring-1.7.2/lib/spring/binstub.rb:11:in `load'
    from /home/firefox636/rails_app/vendor/bundle/ruby/2.2.0/gems/spring-1.7.2/lib/spring/binstub.rb:11:in `<top (required)>'
    from /home/******/.rbenv/versions/2.2.3/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:55:in `require'
    from /home/******/.rbenv/versions/2.2.3/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:55:in `require'
    from /home/******/rails_app/bin/spring:13:in `<top (required)>'
    from bin/rails:3:in `load'
    from bin/rails:3:in `<main>'
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

+2

cannot load such file -- pg_ext (LoadError)」あたりで検索してヒットした情報を読むよ良いと思います。
検索した情報を読んで、自分の状況に合っている解決策を試してみて、それでもうまくいかない場合は以下の情報を質問に追記すればよいでしょう。

  • 参考にした情報のURL
  • 入力したコマンド
  • コマンドの実行結果

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.55%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る