質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.49%

Wordpressの固定ページと静的htmlを共存させたい

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 5,188

score 14

静的htmlで構築していたサイトをWordpressで再構築しています。

パーマリンク名と同じファイル名のhtmlがある場合404エラーになる

静的htmlの http://examples.jp/contact.html がある状態で、
パーマリンクを http://examples.jp/contact/ にした固定ページが404エラーになります。

  • http://examples.jp/contact/ → 404エラー
  • http://examples.jp/contact.html → htmlが表示
  • http://examples.jp/contact → htmlが表示

ちなみに、同名の静的htmlがない場合は正しく表示されます。

  • http://examples.jp/contact2/ → Wordpressの内容が表示

解決方法はありますでしょうか?

環境

  • Wordpressバージョン4.6.1
  • ロリポップ!レンタルサーバー使用

※下記、修正前でも状況は同じでしたので今回の問題とは関係ないようでした。

同じサーバーの同じ階層にindex.htmlindex.phpが共存しています。
Wordpressと静的htmlを同時表示させたいため、canonical.phpの一行をコメントアウトする方法でindexの共存は成功しました。

#コメントアウトした一行
$redirect['path'] = preg_replace('|/' . preg_quote( $wp_rewrite->index, '|' ) . '/*?$|', '/', $redirect['path']);
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • MasahikoHirata

    2016/11/16 19:39

    エラーの部分を拝見いたしますと階層は同一ではない。(エラーのものは下位の'/contanct/'以下の階層ですよね?

    キャンセル

  • deletekey

    2016/11/16 21:07

    たしかにURLでは同一階層ではありません。ただ、同名の静的htmlがないパーマリンク名に変えると表示できるのですが、これは階層の問題なんでしょうか?と、いうそこそこ重要な状況を書いておりませんでしたので修正いたしました。ご指摘ありがとうございます。

    キャンセル

回答 1

checkベストアンサー

0

ApacheのMultiViews機能が有効になっているのではないでしょうか。
MultiViewsが有効の場合、Apacheは拡張子を自動で補おうとします。

MultiViewsを無効にするには、ロリポップの管理画面からhttpd.confの設定を変更するか(確かそういうページがあった気がします..)、またはWordPressをインストールしたディレクトリの.htaccessに以下の記述を加えてみてください。

Options -MultiViews

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/11/25 13:33

    ご回答ありがとうございます。
    htaccessに記述する形で、思い通りの挙動になりました。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.49%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る