質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
87.20%
npm

npmは、Node Packaged Modulesの略。Node.jsのライブラリ・パッケージを管理できるツールです。様々なモジュールを簡単にインストールでき、自分でモジュールを作成し公開する際にも使用できます。

Node.js

Node.jsとはGoogleのV8 JavaScriptエンジンを使用しているサーバーサイドのイベント駆動型プログラムです。

gulp

gulpは、Node.jsをベースとしたタスク自動化ツールの一つ。ストリームでファイルを処理することが特徴です。CSSプリプロセッサの使用時のコンパイルや、CSS・JavaScriptファイルの圧縮・結合などを自動的に行うことができます。

受付中

Gulpでの開発環境エラー

daisuke-yoshi
daiyoshi

総合スコア4

npm

npmは、Node Packaged Modulesの略。Node.jsのライブラリ・パッケージを管理できるツールです。様々なモジュールを簡単にインストールでき、自分でモジュールを作成し公開する際にも使用できます。

Node.js

Node.jsとはGoogleのV8 JavaScriptエンジンを使用しているサーバーサイドのイベント駆動型プログラムです。

gulp

gulpは、Node.jsをベースとしたタスク自動化ツールの一つ。ストリームでファイルを処理することが特徴です。CSSプリプロセッサの使用時のコンパイルや、CSS・JavaScriptファイルの圧縮・結合などを自動的に行うことができます。

0回答

0評価

0クリップ

374閲覧

投稿2022/03/22 11:33

Gulpでの開発環境構築ができないため、エラーから解決方法が分かる方がいましたら、アドバイスお願いできますでしょうか。

Gulpでビルドしようと思ったのですが、コマンドからbuildコマンドを入力したところ下記エラーメッセージが表示されました。


▼エラーメッセージ

npm ERR! A complete log of this run can be found in:
npm ERR! C:\Users\XX\AppData\Roaming\npm-cache_logs\XXXX-debug.log

ログを確認したところ、次のようなメッセージが表示されてました。


▼エラーログ

18139 verbose stack Error: exited with error code: 128
18139 verbose stack at ChildProcess.<anonymous> (C:\Program Files (x86)\Nodist\npmv\6.14.12\node_modules\pacote\lib\util\finished.js:12:19)
18139 verbose stack at ChildProcess.emit (events.js:315:20)
18139 verbose stack at maybeClose (internal/child_process.js:1048:16)
18139 verbose stack at Socket.<anonymous> (internal/child_process.js:439:11)
18139 verbose stack at Socket.emit (events.js:315:20)
18139 verbose stack at Pipe.<anonymous> (net.js:673:12)
18140 verbose cwd C:\xampp\htdocs\works\【tasks】※
18141 verbose Windows_NT 10.0.22000
18142 verbose argv "C:\Program Files (x86)\Nodist\v-x64\14.16.1\node.exe" "C:\Program Files (x86)\Nodist\npmv\6.14.12\bin\npm-cli.js" "i"
18143 verbose node v14.16.1
18144 verbose npm v6.14.12
18145 error Error while executing:
18145 error C:\Program Files\Git\cmd\git.EXE ls-remote -h -t git://github.com/colynb/commonjs-html-prettyprinter.git
18145 error
18145 error fatal: remote error:
18145 error The unauthenticated git protocol on port 9418 is no longer supported.
18145 error Please see https://github.blog/2021-09-01-improving-git-protocol-security-github/ for more information.
18145 error
18145 error exited with error code: 128
18146 verbose exit [ 1, true ]

※【tasks】には実際の作業フォルダ内のパスが入ってます

なんだか良く分からなかったのですが、上記で分かる方いましたらアドバイスお願いできますでしょうか。

package.json > devDependencies の中身は次のようになってます。


▼devDependencies

"@babel/core": "^7.14.0", "@babel/plugin-proposal-class-properties": "^7.13.0", "@babel/plugin-transform-modules-commonjs": "^7.14.0", "@babel/preset-env": "^7.14.1", "@babel/register": "^7.13.16", "autoprefixer": "^10.2.5", "babel-eslint": "^10.1.0", "babel-loader": "^8.2.2", "browser-sync": "^2.26.14", "core-js": "^3.11.3", "css-loader": "^5.2.4", "css-mqpacker": "^7.0.0", "cssnano": "^5.0.2", "del": "^6.0.0", "eslint": "^7.25.0", "eslint-friendly-formatter": "^4.0.1", "eslint-loader": "^4.0.2", "gulp": "^4.0.2", "gulp-cached": "^1.1.1", "gulp-data": "^1.3.1", "gulp-debug": "^4.0.0", "gulp-filter": "^7.0.0", "gulp-html-beautify": "^1.0.1", "gulp-html-prettify": "0.0.1", "gulp-htmlmin": "^5.0.1", "gulp-if": "^3.0.0", "gulp-ignore": "^3.0.0", "gulp-notify": "^4.0.0", "gulp-plumber": "^1.2.1", "gulp-postcss": "^9.0.0", "gulp-progeny": "^0.4.1", "gulp-pug": "^4.0.1", "gulp-remember": "^1.0.1", "gulp-rename": "^2.0.0", "gulp-sass": "^4.1.0", "jquery": "^3.6.0", "jquery.easing": "^1.4.1", "lazypipe": "^1.0.2", "locomotive-scroll": "^4.1.1", "mobile-detect": "^1.4.5", "node-sass": "^5.0.0", "path": "^0.12.7", "pug": "^3.0.2", "pug-loader": "^2.4.0", "sass-loader": "^11.0.1", "style-loader": "^2.0.0", "swiper": "^6.5.9", "vinyl-named": "^1.1.0", "webpack": "^5.36.2", "webpack-stream": "^6.1.2"

良い質問の評価を上げる

以下のような質問は評価を上げましょう

  • 質問内容が明確
  • 自分も答えを知りたい
  • 質問者以外のユーザにも役立つ

評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

気になる質問をクリップする

クリップした質問は、後からいつでもマイページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

  • プログラミングに関係のない質問
  • やってほしいことだけを記載した丸投げの質問
  • 問題・課題が含まれていない質問
  • 意図的に内容が抹消された質問
  • 過去に投稿した質問と同じ内容の質問
  • 広告と受け取られるような投稿

評価を下げると、トップページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

まだ回答がついていません

会員登録して回答してみよう

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
87.20%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問

同じタグがついた質問を見る

npm

npmは、Node Packaged Modulesの略。Node.jsのライブラリ・パッケージを管理できるツールです。様々なモジュールを簡単にインストールでき、自分でモジュールを作成し公開する際にも使用できます。

Node.js

Node.jsとはGoogleのV8 JavaScriptエンジンを使用しているサーバーサイドのイベント駆動型プログラムです。

gulp

gulpは、Node.jsをベースとしたタスク自動化ツールの一つ。ストリームでファイルを処理することが特徴です。CSSプリプロセッサの使用時のコンパイルや、CSS・JavaScriptファイルの圧縮・結合などを自動的に行うことができます。