質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.34%

mysqlnd_msを有効化することでエラーが発生する

受付中

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 680

web-webap-db構成のシステムが既にあります。
構成は下記のとおりです
・webサーバ CentOS7.2 nginxでproxy
・webapサーバ CentOS7.2 php5.6.24 apache2.4.6
・dbサーバ 2台 CentOS7.2 mysql5.6.32 レプリケーション構成

上記構成でwebapにmysqlnd_msを導入し、dbへのアクセスをwriteはmaster、readはslaveサーバへ振り分けを考えています。

上記実現のため下記を実施しました。

・mysqlndのインストール

yum install php-pecl-mysqlnd-ms.x86_64 php-pecl-mysqlnd-ms-devel.x86_64

・/etc/php.d/50-mysqlnd_ms.iniの編集

extension=mysqlnd_ms.so
mysqlnd_ms.enable = 1
mysqlnd_ms.force_config_usage = 1
mysqlnd_ms.config_file = "/etc/mysqlnd_ms.json"
ll be ignored.
mysqlnd_ms.disable_rw_split = 1

・/etc/mysqlnd_ms.jsonの作成

{
  "primary": {
    "master": {
      "master_1": {
        "host": "master-db",
        "port": "3306"
      }
    },
    "slave": {
     }
  },
  "standby": {
    "master": {
      "master_1": {
        "host": "slave-db",
        "port": "3306"
      }
    },
    "slave": {
    }
  }
}

上記のとおり設定し、画面を表示させると下記のエラーが表示されます。
※一部ファイル名を変換しています

httpd: PHP Warning:  mysqli_connect(): (mysqlnd_ms) Exclusive usage of configuration enforced but did not find the correct INI file section (master-db) in /var/www/html/XXXX.php on line 200
httpd: PHP Warning:  mysqli_connect(): (HY000/2000): (mysqlnd_ms) Exclusive usage of configuration enforced but did not find the correct INI file section in /var/www/html/XXXX.php on line 200
httpd: PHP Warning:  mysqli_query() expects parameter 1 to be mysqli, boolean given in /var/www/html/XXXX.php on line 120

/var/www/html/XXXX.phpの200行目と120行目は下記のとおりです。

200行目
$this->database = mysqli_connect($dbhost,$configOptions['db_user_name'],$configOptions['db_password'],isset($configOptions['db_name'])?$configOptions['db_name']:'',$dbport);

120行目
$result = $suppress?@mysqli_query($this->database,$sql):mysqli_query($this->database,$sql);

XXXX.phpファイル内でパラメータが設定しているのでそれが/etc/mysqlnd_ms.jsonに足りないと考え/etc/mysqlnd_ms.jsonを下記のように修正しました。
・/etc/mysqlnd_ms.json

{
  "primary": {
    "master": {
      "master_1": {
        "host": "master-db",
        "db": "dbname",
        "password": "pass",
        "user": "dbuser",
        "port": "3306"
      }
    },
    "slave": {
     }
  },
  "standby": {
    "master": {
      "master_1": {
        "host": "slave-db",
        "db": "dbname",
        "password": "pass",
        "user": "dbuser",
        "port": "3306"
      }
    },
    "slave": {
    }
  }
}

しかし、エラーメッセージは変わらずです。
なるべく現在のアプリケーションXXXX.phpは変更したくないのですが、上記エラーの解消方法をご教示ください。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

0

手元に環境が無いうえに mysqlnd_ms を使ったことがないため、マニュアルを見ただけの推測による回答となりますが、、

エラーメッセージを見るに、おそらく /var/www/html/XXXX.php 内の変数$dbhostの値に誤りがあります。
http://php.net/manual/en/mysqlnd-ms.plugin-ini-json.php#example-2058

で、以下のページのサンプルコードから類推すると、mysqli_connect関数の第1引数に指定する値は"master-db"ではなく"primary"でなければならないようです。
http://php.net/manual/ja/mysqlnd-ms.plugin-ini-json.php#mysqlnd-ms.plugin-ini-json.using-section


ところで、ご質問のエラーとは直接 関係ないと思いますが、ご提示の設定では

dbへのアクセスをwriteはmaster、readはslaveサーバへ振り分け

できないはずです。

なぜなら、/etc/php.d/50-mysqlnd_ms.ini 内で

mysqlnd_ms.disable_rw_split = 1


を指定しているためです。
http://php.net/manual/ja/mysqlnd-ms.configuration.php#ini.mysqlnd-ms.disable-rw-split

名前の頭が(enable ではなく)disable であることから、値を 1 にすることでこの機能が OFF になると思われます。

おそらく、HA構成のサンプルコードをを参考にされていませんか?

READ/WRITE スプリットの設定方法については、以下を参考にしてみてはいかがでしょうか?
https://blog.engineyard.com/2014/easy-read-write-splitting-php-mysqlnd#read-write-splitting

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/10/04 18:08

    回答いただきありがとうございます。
    返信遅くなりました。すみません。

    変数に誤りがある可能性が高いのはなんとなく認識しております。環境問題のようなのでもう少し検証してみます。
    mysqlnd_ms.disable_rw_split = 1
    についてはご指摘のとおりですね。ありがとうございます。
    少し遅くなるかもしれませんが、解決できたらコメント追記します

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.34%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る