質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.52%

Railsの開発環境に関して

解決済

回答 2

投稿

  • 評価
  • クリップ 0
  • VIEW 1,652

s.k

score 394

こんにちは!
s.kです。

表題の件に関して質問です。
railsをインストール後、コマンドプロンプトでRailsアプリケーションの初期画面をしたいのですが、表示されません。なぜか教えていただきたいです。

私がコマンドプロンプトに入力したのは、
ruby bin/rails sです。
出力されるのは、
=> Booting WEBrick
・・・・
・・・
・・

のはずなのですが・・・・。
実際に出力されたのは以下のものです。
原因がわからないのでご質問させていただきました。

ぜひ、教えていただきたいです。
よろしくお願いします!

C:\rails\asagao>ruby bin/rails s
C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/bundler-1.12.4/lib/bundler/runtime.rb:89:in rescue in block (2 levels) in require': There was an error while trying to load the gem 'uglifier'. (Bundler::GemRequireError) Gem Load Error is: Could not find a JavaScript runtime. See https://github.com/rails/execjs for a list of available runtimes. Backtrace for gem load error is: C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/execjs-2.7.0/lib/execjs/runtimes.rb:58:in autodetect'
C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/execjs-2.7.0/lib/execjs.rb:5:in <module:ExecJS>' C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/execjs-2.7.0/lib/execjs.rb:4:in <top (required)>'
C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/uglifier-3.0.0/lib/uglifier.rb:5:in require' C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/uglifier-3.0.0/lib/uglifier.rb:5:in <top (required)>'
C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/bundler-1.12.4/lib/bundler/runtime.rb:86:in require' C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/bundler-1.12.4/lib/bundler/runtime.rb:86:in block (2 levels) in require'
C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/bundler-1.12.4/lib/bundler/runtime.rb:81:in each' C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/bundler-1.12.4/lib/bundler/runtime.rb:81:in block in require'
C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/bundler-1.12.4/lib/bundler/runtime.rb:70:in each' C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/bundler-1.12.4/lib/bundler/runtime.rb:70:in require'
C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/bundler-1.12.4/lib/bundler.rb:102:in require' C:/rails/asagao/config/application.rb:7:in <top (required)>'
C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/railties-4.2.6/lib/rails/commands/commands_tasks.rb:78:in require' C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/railties-4.2.6/lib/rails/commands/commands_tasks.rb:78:in block in server'
C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/railties-4.2.6/lib/rails/commands/commands_tasks.rb:75:in tap' C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/railties-4.2.6/lib/rails/commands/commands_tasks.rb:75:in server'
C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/railties-4.2.6/lib/rails/commands/commands_tasks.rb:39:in run_command!' C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/railties-4.2.6/lib/rails/commands.rb:17:in <top (required)>'
bin/rails:4:in require' bin/rails:4:in <main>'
Bundler Error Backtrace:
        from C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/bundler-1.12.4/lib/bundler/runtime.rb:85:in block (2 levels) in require'         from C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/bundler-1.12.4/lib/bundler/runtime.rb:81:in each'
        from C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/bundler-1.12.4/lib/bundler/runtime.rb:81:in block in require'         from C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/bundler-1.12.4/lib/bundler/runtime.rb:70:in each'
        from C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/bundler-1.12.4/lib/bundler/runtime.rb:70:in require'         from C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/bundler-1.12.4/lib/bundler.rb:102:in require'
        from C:/rails/asagao/config/application.rb:7:in <top (required)>'         from C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/railties-4.2.6/lib/rails/commands/commands_tasks.rb:78:in require'
        from C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/railties-4.2.6/lib/rails/commands/commands_tasks.rb:78:in block in server'         from C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/railties-4.2.6/lib/rails/commands/commands_tasks.rb:75:in tap'
        from C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/railties-4.2.6/lib/rails/commands/commands_tasks.rb:75:in server'         from C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/railties-4.2.6/lib/rails/commands/commands_tasks.rb:39:in run_command!'
        from C:/Ruby21-x64/lib/ruby/gems/2.1.0/gems/railties-4.2.6/lib/rails/commands.rb:17:in <top (required)>'         from bin/rails:4:in require'
        from bin/rails:4:in `<main>'

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

checkベストアンサー

+1

rails new の後に、どんな操作をしたかを提示してください。
gem の設定、DB の設定などのしわすれがないかを知りたいです。

エラーメッセージには、

There was an error while trying to load the gem 'uglifier'. (Bundler::GemRequireError)

とあるので、gem の設定 (bundle install の未実施とか Gefile の内容が不適切なことが予想されます。
Rails に入門者や Web 上のページを参考に1ステップづつ進めていけば、rails server はうまく動作するはずです。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/05/25 21:22


    返信ありがとうございます!
    ひとつ気になったことがありますので書かせていただきます。

    devkitに関してです。
    DevKit-mingw64-32-4.7.2-20130224-1151-sfx.exeを
    C:\DevKitにダウンロードしました。

    コマンドプロンプトで動作確認をしたところ以下の結果になりました。
    何か関係あるでしょうか?
    gemの設定に関してもご説明します!


    C:\Users\keiga>C:\DevKit\devkitvars.bat
    Adding the DevKit to PATH...
    指定されたファイルが見つかりません。

    キャンセル

0

見当はずれかもしれませんが、2行目に
”Gem Load Error is: Could not find a JavaScript runtime.”
と出ています。
JDKがインストールされていないのではありませんか?

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/05/26 21:55


    Chikaemonさん
    お返事ありがとうございます!

    この質問とは別に同じ内容を質問しました。
    その時、教えてもらったのがnode.js(java scriptの機能がうまく作用していないので)をインストールすれば解決できると教えていただきました。

    node.jsをインストールしたところ、問題を解決できました(^^)
    chikaemonさんのおっしゃるとおりでした。

    ありがとうございます!
    今後共よろしくお願いします。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.52%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る