質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
86.02%
CentOS

CentOSは、主にRed Hat Enterprise Linux(RHEL)をベースにした、フリーのソフトウェアオペレーティングシステムです。

OpenDKIM

OpenDKIMは、送信したメールを受信メールサーバが迷惑メールとして処理することを防ぐためのオープンソースのソフトウェア。特殊なヘッダ情報をメールに付け、DNSの追加情報を設定することで迷惑メールでないことをある程度証明できます。

Q&A

解決済

opendkimのインストールに失敗する(Centos6.8)

shiro_00002
shiro_00002

総合スコア1

CentOS

CentOSは、主にRed Hat Enterprise Linux(RHEL)をベースにした、フリーのソフトウェアオペレーティングシステムです。

OpenDKIM

OpenDKIMは、送信したメールを受信メールサーバが迷惑メールとして処理することを防ぐためのオープンソースのソフトウェア。特殊なヘッダ情報をメールに付け、DNSの追加情報を設定することで迷惑メールでないことをある程度証明できます。

1回答

0グッド

0クリップ

1642閲覧

投稿2021/06/29 13:35

編集2021/06/29 13:48

Centos6.8にopendkimをインストールしたいのですが、失敗します。
パッケージが無いと表示されてしまうのですが、どの様に対応すればよろしいでしょうか。よろしくお願いいたします。

こちらで実施したコマンドは次の通りです。
[root@vmailsv01 ~]# uname -a
Linux vmailsv01 2.6.32-642.1.1.el6.x86_64 #1 SMP Tue May 31 21:57:07 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
[root@vmailsv01 ~]# cat /etc/redhat-release
CentOS release 6.8 (Final)
[root@vmailsv01 ~]#
[root@vmailsv01 ~]# yum install epel-release (リポジトリ確認)
Loaded plugins: fastestmirror, security
Setting up Install Process
Loading mirror speeds from cached hostfile

  • epel: ftp.iij.ad.jp

Package epel-release-7-13.noarch already installed and latest version
Nothing to do
[root@vmailsv01 ~]#
[root@vmailsv01 ~]# yum install opendkim (ここでOpendkimをインストールします)
Loaded plugins: fastestmirror, security
Setting up Install Process
Loading mirror speeds from cached hostfile

  • epel: ftp.iij.ad.jp

Resolving Dependencies
--> Running transaction check
---> Package opendkim.x86_64 0:2.11.0-0.1.el7 will be installed
--> Processing Dependency: libopendkim(x86-64) = 2.11.0-0.1.el7 for package: opendkim-2.11.0-0.1.el7.x86_64
--> Processing Dependency: libbsd.so.0(LIBBSD_0.0)(64bit) for package: opendkim-2.11.0-0.1.el7.x86_64
--> Processing Dependency: systemd for package: opendkim-2.11.0-0.1.el7.x86_64
--> Processing Dependency: systemd for package: opendkim-2.11.0-0.1.el7.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: opendkim-2.11.0-0.1.el7.x86_64
--> Processing Dependency: libbsd.so.0()(64bit) for package: opendkim-2.11.0-0.1.el7.x86_64
--> Processing Dependency: libdb-5.3.so()(64bit) for package: opendkim-2.11.0-0.1.el7.x86_64
--> Processing Dependency: libmemcached.so.11()(64bit) for package: opendkim-2.11.0-0.1.el7.x86_64
--> Processing Dependency: libmemcachedutil.so.2()(64bit) for package: opendkim-2.11.0-0.1.el7.x86_64
--> Processing Dependency: libmilter.so.1.0()(64bit) for package: opendkim-2.11.0-0.1.el7.x86_64
--> Processing Dependency: libopendbx.so.1()(64bit) for package: opendkim-2.11.0-0.1.el7.x86_64
--> Processing Dependency: libopendkim.so.11()(64bit) for package: opendkim-2.11.0-0.1.el7.x86_64
--> Running transaction check
---> Package libbsd.x86_64 0:0.8.3-1.el7 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.16)(64bit) for package: libbsd-0.8.3-1.el7.x86_64
---> Package libopendkim.x86_64 0:2.11.0-0.1.el7 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: libopendkim-2.11.0-0.1.el7.x86_64
--> Processing Dependency: libdb-5.3.so()(64bit) for package: libopendkim-2.11.0-0.1.el7.x86_64
---> Package opendbx.x86_64 0:1.4.6-6.el7 will be installed
---> Package opendkim.x86_64 0:2.11.0-0.1.el7 will be installed
--> Processing Dependency: systemd for package: opendkim-2.11.0-0.1.el7.x86_64
--> Processing Dependency: systemd for package: opendkim-2.11.0-0.1.el7.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: opendkim-2.11.0-0.1.el7.x86_64
--> Processing Dependency: libdb-5.3.so()(64bit) for package: opendkim-2.11.0-0.1.el7.x86_64
--> Processing Dependency: libmemcached.so.11()(64bit) for package: opendkim-2.11.0-0.1.el7.x86_64
--> Processing Dependency: libmemcachedutil.so.2()(64bit) for package: opendkim-2.11.0-0.1.el7.x86_64
---> Package sendmail-milter.x86_64 0:8.14.4-9.el6_8.1 will be installed
--> Finished Dependency Resolution
Error: Package: opendkim-2.11.0-0.1.el7.x86_64 (epel)
Requires: libmemcached.so.11()(64bit)
Error: Package: opendkim-2.11.0-0.1.el7.x86_64 (epel)
Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: libopendkim-2.11.0-0.1.el7.x86_64 (epel)
Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: libopendkim-2.11.0-0.1.el7.x86_64 (epel)
Requires: libdb-5.3.so()(64bit)
Error: Package: opendkim-2.11.0-0.1.el7.x86_64 (epel)
Requires: libdb-5.3.so()(64bit)
Error: Package: opendkim-2.11.0-0.1.el7.x86_64 (epel)
Requires: libmemcachedutil.so.2()(64bit)
Error: Package: libbsd-0.8.3-1.el7.x86_64 (epel)
Requires: libc.so.6(GLIBC_2.16)(64bit)
Error: Package: opendkim-2.11.0-0.1.el7.x86_64 (epel)
Requires: systemd
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
[root@vmailsv01 ~]#

Requiresいくつか出ますが、どの様に対応すればよいのでしょうか??
なお、最後の方にトライと書いてある--skip-brokenを試したら、errorの部分だけ全部skipして終了しました、その後dkimのコマンドは起動しなかったので失敗したようです。
次のトライのrpm -Va --nofiles --nodigestも試しましたが、なにも表示されず終了しました。その後再度dkimのインストールを行いましたが、同じ結果で失敗となりました。

気になる質問をクリップする

クリップした質問は、後からいつでもマイページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

下記のような質問は推奨されていません。

  • 質問になっていない投稿
  • スパムや攻撃的な表現を用いた投稿

適切な質問に修正を依頼しましょう。

回答1

0

ベストアンサー

まず環境の問題点としてCentOS6.xに7.x系パッケージをインストールしようとしてしまっています。

例) opendkim-2.11.0-0.1.el7.x86_64

CentOS6.xはサポートが終了しているためパッケージのアップデートがありません。今まで参考にできていた手順も現在は利用できないことが多いです。

どうしてもCentOS6.xを使用したいのでなければCentOS7.xでやり直してみましょう。

投稿2021/06/29 14:25

yukky1201

総合スコア2732

下記のような回答は推奨されていません。

  • 質問の回答になっていない投稿
  • スパムや攻撃的な表現を用いた投稿

このような回答には修正を依頼しましょう。

回答へのコメント

shiro_00002

2021/06/29 14:49

ありがとうございます。やはり前提の問題だったんですね。 頂いたヒントで、ある程度古いバージョンのパッケージなら入るかもと、Yum で --showduplicates というオプション(初めて使った)で、 el6版が無いかなと探したのですが、なかったです(これが「今まで参考にできていた手順も現在は利用できないことが多いです」の部分でしょうか・・)ありそうな気もするのですが。 こうなると、Centos7に上げるかのどちらかですね。運用中のシステムなのであんまりしたくはないのと、Linuxの知識もそんなに無いので躊躇してますが、踏ん切りつけてアップデートするかですね。
yukky1201

2021/06/29 14:54

el6パッケージはOS含め諸々削除されていますね。 epelの6用リポジトリ(https://dl.fedoraproject.org/pub/epel/6/)はすでに何もありません。 CentOS6を運用中とのことですが、CentOS7になるとコマンドや設定が色々と変わりましたので仮想環境などでCentOS7の検証をされてからがよいと思います。
shiro_00002

2021/06/29 15:16

すばやいご回答、重ねてありがとうございます。 el6リポジトリはすでに何にもないとは!! ・・・サポート切れOSの恐ろしさか。 こうなると、これ以上Centos6にこだわるのは時間がかかるだけかもしれないですね。 フルバックアップ取ってCentos7に上げてみたいと思います。 基礎コマンドも変わっているようなので、勉強しなおしてきます。

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
86.02%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問

同じタグがついた質問を見る

CentOS

CentOSは、主にRed Hat Enterprise Linux(RHEL)をベースにした、フリーのソフトウェアオペレーティングシステムです。

OpenDKIM

OpenDKIMは、送信したメールを受信メールサーバが迷惑メールとして処理することを防ぐためのオープンソースのソフトウェア。特殊なヘッダ情報をメールに付け、DNSの追加情報を設定することで迷惑メールでないことをある程度証明できます。