質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.50%

PhpSpreadsheetのインストールに必要なzip関連モジュールがインストールできない。Clund9(Linux2)

解決済

回答 2

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 1,590

score 83

EC2(cloud9) Linux2を使用しています。
php7.4

PhpSpreadsheetをインストールしようと、
$ composer require phpoffice/phpspreadsheet
をやっているのですが、

it is missing from your system. Install or enable PHP's zip extension.


というエラーが出てしまうので、zip関連の拡張モジュールが足りないのだなと思い、
以下を実行しました。

$ sudo yum install --enablerepo remi -y php74-php-pecl-zip


しかし、以下のようなエラー(?)が出て、zipが入りません・・・

Loaded plugins: extras_suggestions, langpacks, priorities, update-motd
amzn2-core                                                                                                                  | 3.7 kB  00:00:00     
371 packages excluded due to repository priority protections
Resolving Dependencies
--> Running transaction check
---> Package php74-php-pecl-zip.x86_64 0:1.19.2-1.el7.remi will be installed
--> Processing Dependency: libzip5(x86-64) >= 1.7.3 for package: php74-php-pecl-zip-1.19.2-1.el7.remi.x86_64
--> Running transaction check
---> Package libzip5.x86_64 0:1.7.3-1.el7.remi will be installed
--> Finished Dependency Resolution

Dependencies Resolved

===================================================================================================================================================
 Package                                  Arch                         Version                                    Repository                  Size
===================================================================================================================================================
Installing:
 php74-php-pecl-zip                       x86_64                       1.19.2-1.el7.remi                          remi                        53 k
Installing for dependencies:
 libzip5                                  x86_64                       1.7.3-1.el7.remi                           remi                        61 k

Transaction Summary
===================================================================================================================================================
Install  1 Package (+1 Dependent package)

Total size: 113 k
Installed size: 249 k
Downloading packages:
Running transaction check
Running transaction test


Transaction check error:
  file /usr/lib64/libzip.so.5 from install of libzip5-1.7.3-1.el7.remi.x86_64 conflicts with file from package libzip-1.3.2-1.amzn2.0.1.x86_64

Error Summary
-------------

完全に行き詰まってしまってまして・・・
アドバイスいただけますと幸いです・・・


【追記 試したこと】

yum list php*


をすると、

php74-php-pecl-zip.x86_64                   1.19.2-1.el7.remi                   remi-safe    


と出ましたので、remi?と思い、こちらのページにたどり着きました。
remiを使用してインストールしなければいけない、ということで、

$ sudo yum install --enablerepo=remi,remi-php74-php-pecl-zip.x86_64


を打ちましたが、以下のようなエラーが出てしまいました・・・

Loaded plugins: extras_suggestions, langpacks, priorities, update-motd
Error: Need to pass a list of pkgs to install
 Mini usage:

install PACKAGE...

Install a package or packages on your system

aliases: install-n, install-na, install-nevra

【追記 試したこと2】
上記の「こちら」のページに従い、

sudo yum install –enablerepo=remi-php74 php-pecl-zip


を打つと、

Loaded plugins: extras_suggestions, langpacks, priorities, update-motd
amzn2-core                                                                                                                     | 3.7 kB  00:00:00     
271 packages excluded due to repository priority protections
Package php-pecl-zip-1.15.2-3.amzn2.0.1.x86_64 already installed and latest version
Nothing to do


と出ました。

しかし、$ yum list installed | grep php
で、インストールされているモジュールを確認すると、pecl-zipは入っていません・・・

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

check解決した方法

0

解決しました。
cloud9に入っていたmariaDBをアンインストールして、mysqlを入れたのですが、pecl_zipがmariaDBに入っていましたので、removeとか色々やりインストールできました。

以下、試したこと。
①$ yum list | grep pecl-zip
をすると、以下、

php-pecl-zip.x86_64                    1.15.2-3.amzn2.0.1            @amzn2extra-lamp-mariadb10.2-php7.2
php54-php-pecl-zip.x86_64              1.19.2-1.el7.remi             remi-safe  
php55-php-pecl-zip.x86_64              1.19.2-1.el7.remi             remi-safe  
php56-php-pecl-zip.x86_64              1.19.2-1.el7.remi             remi-safe  
php70-php-pecl-zip.x86_64              1.19.2-1.el7.remi             remi-safe  
php71-php-pecl-zip.x86_64              1.19.2-1.el7.remi             remi-safe  
php72-php-pecl-zip.x86_64              1.19.2-1.el7.remi             remi-safe  
php73-php-pecl-zip.x86_64              1.19.2-1.el7.remi             remi-safe  
php74-php-pecl-zip.x86_64              1.19.2-1.el7.remi             remi-safe  
php80-php-pecl-zip.x86_64              1.19.2-1.el7.remi             remi-safe 

②php-pecl-zip.x86_64が@amzn2extra-lamp-mariadb10.2-php7.2に入っているので、リムーブ
$ sudo yum remove php-pecl-zip.x86_64

③再び、$ sudo yum install –enablerepo=remi-php74 php-pecl-zip.x86_64
しかし、エラー:
Loaded plugins: extras_suggestions, langpacks, priorities, update-motd
Error: Need to pass a list of pkgs to install
Mini usage:

install PACKAGE...

Install a package or packages on your system

aliases: install-n, install-na, install-nevra

④remi-safeを指定しないといけないんだと思い、以下で再び
$ sudo yum install –enablerepo=remi-safe php74-php-pecl-zip.x86_64
しかし、エラー:
Transaction check error:
file /usr/lib64/libzip.so.5 from install of libzip5-1.7.3-1.el7.remi.x86_64 conflicts with file from package libzip-1.3.2-1.amzn2.0.1.x86_64

⑤競合しているやつをremoveしないといけないんだと思い以下
$ sudo yum remove libzip-1.3.2-1.amzn2.0.1.x86_64

⑥再びインストール
$ sudo yum install –enablerepo=remi-safe php74-php-pecl-zip.x86_64

⑦PhpSpreadsheetをインストール
$ composer require phpoffice/phpspreadsheet

できました!

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

0

Composer使うということは考えてませんか?
依存パッケージも全部持ってこれるはずですが。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2021/02/02 07:58

    ありがとうございます。
    記載がもれましたが、PhpSpreadsheetをインストールする際は、
    $ composer require phpoffice/phpspreadsheet
    をやっておりますが、
    it is missing from your system. Install or enable PHP's zip extension.
    というエラーが出てしまいます…

    それ以降のzipインストールの部分は、composerは使っておらず…
    ここでもcomposer使えるのでしょうか・・?

    キャンセル

  • 2021/02/02 08:47

    それは非常に大きな抜けですね。
    本文に記載しておいてください。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.50%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • トップ
  • PHPに関する質問
  • PhpSpreadsheetのインストールに必要なzip関連モジュールがインストールできない。Clund9(Linux2)