質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.80%

Amazonlinuxで動いているサーバ上でOracle Database Expressをインストールしたいです

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 506

score 1

AWS EC2インスタンス(amazonlinux)にOracle Database 18c Express Edition for Linux x64をインストールできない

お力をお借りしたく質問させていただきます。
以下のドキュメントを参照してamazonlinuxのインスタンスにOracle Database 18c Express Edition(無償版)をインストールしたいのですが以下のエラーが表示されてしまいます。
https://docs.oracle.com/cd/E36055_01/install.112/b66469/toc.htm#BABCEAHD

こちらのサービスを利用するのに必要な「oracle-database-preinstall-18c」というパッケージがインストールできずません。

以下の別サイトからOracle Database XE RPMのインストールを試したのですが、Red Hat Enterprise Linux6,7だとインストールエラーがでてだめのようでして。。
https://docs.oracle.com/cd/E96517_01/xeinl/procedure-installing-oracle-database-xe.html

発生している問題・エラーメッセージ

# rpm -ivh oracle-database-xe-18c-1.0-1.x86_64.rpm
warning: oracle-database-xe-18c-1.0-1.x86_64.rpm: Header V3 RSA/SHA256 Signature, key ID XXXXXX: NOKEY
error: Failed dependencies:
        oracle-database-preinstall-18c is needed by oracle-database-xe-18c-1.0-1.x86_64

OS:Amazon Linux

# cat /etc/system-release
Amazon Linux AMI release 2018.03

こちらamazonlinuxのサーバ上にOracle Database 18c Express Editionをインストールすることは可能でしょうか?
ご教示いただければ幸いです。

よろしくお願いします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • Orlofsky

    2021/01/28 02:14

    ここの掲示板では Markdown の使い方を覚えてください。
    URLは https://teratail.com/help/question-tips#questionTips3-7 の [リンク] で [リンク先の説明](http...) に修正してください。

    キャンセル

  • abcba

    2021/01/31 21:33

    ご指摘ありがとうございます。
    修正しました。以後気を付けます。

    キャンセル

回答 1

checkベストアンサー

+2

Oracle Database system-requirement/db-matrix にAmazon Linuxは載っていないのでサポート外では?

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2021/01/31 21:33

    サポート外のようでした。
    ありがとうございました!

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.80%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る