質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.60%

RailsでWebpackerを使おうとすると、font-awesomeやCSSが反映されない

受付中

回答 0

投稿

  • 評価
  • クリップ 0
  • VIEW 57

kumamin

score 12

実現したいこと・エラーメッセージ

今Ruby on Railsでアプリを作成しており、SprocketsからWebpackerに移行しようとしています。
しかし、コンソールに以下のようなエラー文が出てしまい、fontawesomeやCSSが反映されないので、解決法を教えていただけますと幸いです。

▼fontawesomeのエラー文

Uncaught Error: Module build failed (from ./node_modules/sass-loader/dist/cjs.js):

@import "~@fortawesome/fontawesome-free/scss/fontawesome";
^
      File to import not found or unreadable: ~@fortawesome/fontawesome-free/scss/fontawesome.
      in /Users/kuma/blog/app/javascript/packs/application.scss (line 1, column 1)
    at Object../node_modules/css-loader/dist/cjs.js?!./node_modules/postcss-loader/src/index.js?!./node_modules/sass-loader/dist/cjs.js?!./app/javascript/packs/application.scss (application.scss:19)
    at __webpack_require__ (bootstrap:19)
    at Object../app/javascript/packs/application.scss (application.scss:2)
    at __webpack_require__ (bootstrap:19)
    at bootstrap:83
    at bootstrap:83

▼CSSのエラー文

Uncaught Error: Module build failed (from ./node_modules/sass-loader/dist/cjs.js):

@import "../src/stylesheets/*";
^
      File to import not found or unreadable: ../src/stylesheets/*.
      in /Users/kuma/blog/app/javascript/packs/application.scss (line 1, column 1)
    at Object../node_modules/css-loader/dist/cjs.js?!./node_modules/postcss-loader/src/index.js?!./node_modules/sass-loader/dist/cjs.js?!./app/javascript/packs/application.scss (application.scss:19)
    at __webpack_require__ (bootstrap:19)
    at Object../app/javascript/packs/application.scss (application.scss:2)
    at __webpack_require__ (bootstrap:19)
    at bootstrap:83
    at bootstrap:83

該当のソースコード

▼app/javascript/packs/application.js

require("@rails/ujs").start()
require("turbolinks").start()
require("@rails/activestorage").start()
require("channels")

import '../src/js/application.js'
import "@fortawesome/fontawesome-free/js/all"
import './application.scss'
const images = require.context('../images', true)

▼app/javascript/packs/application.scss

@import "~@fortawesome/fontawesome-free/scss/fontawesome";
@import "../src/stylesheets/*";

▼app/views/layouts/application.html.haml

!!!
%html
  %head
    %meta{:content => "text/html; charset=UTF-8", "http-equiv" => "Content-Type"}/
    %title Blog
    = csrf_meta_tags
    = csp_meta_tag
    = stylesheet_pack_tag 'application', media: 'all', 'data-turbolinks-track': 'reload'
    = javascript_pack_tag 'application', 'data-turbolinks-track': 'reload'
  %body
    = render 'layouts/header'
    = render 'layouts/notifications'
    = yield

▼ディレクトリ構成
イメージ説明

試したこと

恐らくimportの仕方が間違っているのだと思いますが、コードを見直したり調べたりしてみても解決できませんでした。

補足情報(FW/ツールのバージョンなど)

ruby 2.7.2
Rails 6.0.3.4
font-awesome-sass

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

まだ回答がついていません

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.60%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る