質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.33%

ドットインストールの『Ruby on Rails 5入門 » #02 動作確認をしてみよう』にて、エラーが出て先に進めない。

解決済

回答 3

投稿

  • 評価
  • クリップ 1
  • VIEW 203

yoseei

score -3

ドットインストール『Ruby on Rails 5入門 » #02 動作確認をしてみよう』の学習中にて、Railsが用意しているWebサーバーを立ち上げて動作確認をする際、

rails server -b 192.168.33.10 -d

と入力したのですが、

Could not find gem 'sqlite3 (~> 1.4)' in any of the gem sources listed in your Gemfile.
Run `bundle install` to install missing gems.

このようなメッセージが出てきて、先に進めません。

bundle install

を入力してみたのですが、

An error occurred while installing sassc (2.4.0), and Bundler cannot continue.
Make sure that `gem install sassc -v '2.4.0' --source 'https://rubygems.org/'` succeeds before bundling.

In Gemfile:
  sass-rails was resolved to 6.0.0, which depends on
    sassc-rails was resolved to 2.1.2, which depends on
      sassc

このようになり、やはりrails server -b 192.168.33.10 -d は実行できません。

解決策が分かる方がいましたら、ご教授願えますと幸いです。

よろしくお願いいたします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 3

checkベストアンサー

+1

RubyGemのsqlite3によると1.4↑はありそうですね。
ただ、自身の環境が「必要Rubyバージョン」「必要Gemバージョン」を満たしているか確認してください。
上げられないのでしたら取ってくるsqlite3のバージョンを下げてみるなどする必要がありそうです。

追記。
次のエラーに次やるべきアクションが書かれています。

An error occurred while installing sassc (2.4.0), and Bundler cannot continue.
Make sure that `gem install sassc -v '2.4.0' --source 'https://rubygems.org/'` succeeds before bundling.

sassc -v '2.4.0'をインストールしてと言うことではないかなと。

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2020/11/04 15:23

    あいや、sassc入れろって書いてあるから進んでるのか。

    キャンセル

  • 2020/11/04 15:28

    あと「rails5入門」と書いてあるけど、rails6入れてないかとかは気になる。

    キャンセル

  • 2020/11/05 13:15

    とりあえず、色々と試してrails6で起動は出来ました。
    Rails6でもエラーは出たのですが、WebpackerとYarnをインストールしたら解決しました。
    丁寧にアドバイスをして頂き、ありがとうございました。

    キャンセル

-1

とりあえずRails6で起動することにしました。

その際’Webpacker configuration file not found’というエラーが出たのですが、WebpackerとYarnをインストールすることで、Railsを起動できました。

https://qiita.com/hasegawa-naoto/items/a2c2900c3f4f05ee3bcb#

この方の記事を参考にして解決することが出来ました。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

-1

とりあえずRails6で起動することにしました。

その際、Webpacker configuration file not foundというエラーが発生したのですが、WebpackerとYarnをインストールすることで解決できました。

https://qiita.com/hasegawa-naoto/items/a2c2900c3f4f05ee3bcb#

こちらの方の記事を参考にさせて頂きました。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.33%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る