質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.59%

XAMPPのphpMyAdminでインポートができない

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 5,383

score 32

phpMyAdminで「create_tables.sql」をインポートをしたいのですが、エラーが出てしまいうまくできません。

開発環境は
OS X Yosemite バージョン10.10.5
XAMPP 5.6.14-4
phpMyAdmin 4.5.1

以下、エラー内容です。
エラー

SELECT MAX(version) FROM phpmyadmin.pma__tracking WHERE db_name = 'phpmyadmin'  AND table_name = ''  AND FIND_IN_SET('CREATE DATABASE',tracking) > 0

MySQL のメッセージ
#1932 - Table 'phpmyadmin.pmatracking' doesn't exist in engine

こんな質問の仕方で良いのか分かりませんがよろしくお願いします。

unauさん、ご回答ありがとうございます。
アップグレードはしていません。
というよりXAMPPをダウンロードしてから半年ほどlocalサーバー?でPHPを打ち込んで勉強していましたので、つい最近になって初めてphpMyAdminを開きました。
aql/create_tables.sqlするといい、とのことですが何をどのようにすれば良いのでしょうか?
他の方はあまり出ないのか#1932のエラーの情報が少なくてどのようにすれば良いのかわかりません。
よろしくお願いします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • unau

    2016/03/18 09:13

    xampp のアップグレードをした、など、何かのタイミングで出るようになったかと思いますが、どうなのでしょう。
    エラーメッセージでググると aql/create_tables.sql するといい、とかの情報もありますが、試されましたか。

    キャンセル

回答 1

checkベストアンサー

+2

config.inc.php を開いて、phpmyadmin.pmatrackingを探す。

phpmyadmin.pmatracking を phpmyadmin.pma__tracking に修正する。

あとは、このバージョンを使うのやめて、バージョンダウンする。

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/03/18 23:12

    ご回答ありがとうございます。
    phpmyadmin.pmatrackingを探してみましたが見つかりませんでした。
    バージョンダウンというのはXAMPPのでしょうか?
    phpMyAdminでしょうか?
    また、バージョンダウンというとバージョンいくつなんでしょうか?
    すみません。よろしくお願いします。

    キャンセル

  • 2016/03/19 12:09

    パッケージされた phpMyAdmin 4.5.1 ←のバージョンが運悪く バグがあったということです。修正方法を書きましたが、おそらく、似た修正を行う必要があるかと、
    phpmyadmin.pmatracking が 見つからないのであれば、修正を諦めて下さい。
    探す手間暇がもったいない。
    素直に、どちらバージョンダウンでも phpMyAdmin 4.5.1 の使用が回避できます。
    最後の1桁が奇数バージョンは、開発バージョンとして知られていて
    phpMyAdmin 4.5.0 or 4.5.2 だと リリースバージョンとなんとなく
    昔から知られています。

    キャンセル

  • 2016/03/19 16:51

    ありがとうございます。
    バージョン変更することで無事にインポートすることができました。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.59%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る