質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.98%

rails 起動エラー

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 1,447

KouImanaka

score 9

前提・実現したいこと

ruby on railsにおいてgem redis-railsをインストールした途端に起動しようとしてもエラーで返されるので何とか起動したいです。

発生している問題・エラーメッセージ

[vagrant@localhost base_app]$ rails s
Array values in the parameter are deprecated. Please use a String or nil.
An Array was passed in from bin/rails:3:in load' => Booting WEBrick => Rails 4.1.6 application starting in development on http://0.0.0.0:3000 => Run rails server -h for more startup options => Notice: server is listening on all interfaces (0.0.0.0). Consider using 127.0.0.1 (--binding option) => Ctrl-C to shutdown server Exiting /home/vagrant/.rbenv/versions/2.1.3/lib/ruby/2.1.0/uri/common.rb:176:in split': bad URI(is not URI?):  (URI::InvalidURIError)
    from /home/vagrant/.rbenv/versions/2.1.3/lib/ruby/2.1.0/uri/common.rb:211:in parse'     from /home/vagrant/.rbenv/versions/2.1.3/lib/ruby/2.1.0/uri/common.rb:747:in parse'
    from /vagrant/documents/base_app/config/initializers/redis.rb:3:in <top (required)>'     from /home/vagrant/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:241:in load'
    from /home/vagrant/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:241:in block in load'     from /home/vagrant/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:232:in load_dependency'
    from /home/vagrant/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:241:in load'     from /home/vagrant/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/railties-4.1.6/lib/rails/engine.rb:648:in block in load_config_initializer'
    from /home/vagrant/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/activesupport-4.1.6/lib/active_support/notifications.rb:161:in instrument'     from /home/vagrant/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/railties-4.1.6/lib/rails/engine.rb:647:in load_config_initializer'
    from /home/vagrant/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/railties-4.1.6/lib/rails/engine.rb:612:in block (2 levels) in <class:Engine>'     from /home/vagrant/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/railties-4.1.6/lib/rails/engine.rb:611:in each'
    from /home/vagrant/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/railties-4.1.6/lib/rails/engine.rb:611:in block in <class:Engine>'     from /home/vagrant/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/railties-4.1.6/lib/rails/initializable.rb:30:in instance_exec'
    from /home/vagrant/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/railties-4.1.6/lib/rails/initializable.rb:30:in run'     from /home/vagrant/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/railties-4.1.6/lib/rails/initializable.rb:55:in block in run_initializers'
    from /home/vagrant/.rbenv/versions/2.1.3/lib/ruby/2.1.0/tsort.rb:226:in block in tsort_each'     from /home/vagrant/.rbenv/versions/2.1.3/lib/ruby/2.1.0/tsort.rb:348:in block (2 levels) in each_strongly_connected_component'
    from /home/vagrant/.rbenv/versions/2.1.3/lib/ruby/2.1.0/tsort.rb:418:in block (2 levels) in each_strongly_connected_component_from'     from /home/vagrant/.rbenv/versions/2.1.3/lib/ruby/2.1.0/tsort.rb:427:in each_strongly_connected_component_from'
    from /home/vagrant/.rbenv/versions/2.1.3/lib/ruby/2.1.0/tsort.rb:417:in block in each_strongly_connected_component_from'     from /home/vagrant/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/railties-4.1.6/lib/rails/initializable.rb:44:in each'
    from /home/vagrant/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/railties-4.1.6/lib/rails/initializable.rb:44:in tsort_each_child'     from /home/vagrant/.rbenv/versions/2.1.3/lib/ruby/2.1.0/tsort.rb:411:in call'
    from /home/vagrant/.rbenv/versions/2.1.3/lib/ruby/2.1.0/tsort.rb:411:in each_strongly_connected_component_from'     from /home/vagrant/.rbenv/versions/2.1.3/lib/ruby/2.1.0/tsort.rb:347:in block in each_strongly_connected_component'
    from /home/vagrant/.rbenv/versions/2.1.3/lib/ruby/2.1.0/tsort.rb:345:in each'     from /home/vagrant/.rbenv/versions/2.1.3/lib/ruby/2.1.0/tsort.rb:345:in call'
    from /home/vagrant/.rbenv/versions/2.1.3/lib/ruby/2.1.0/tsort.rb:345:in each_strongly_connected_component'     from /home/vagrant/.rbenv/versions/2.1.3/lib/ruby/2.1.0/tsort.rb:224:in tsort_each'
    from /home/vagrant/.rbenv/versions/2.1.3/lib/ruby/2.1.0/tsort.rb:205:in tsort_each'     from /home/vagrant/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/railties-4.1.6/lib/rails/initializable.rb:54:in run_initializers'
    from /home/vagrant/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/railties-4.1.6/lib/rails/application.rb:300:in initialize!'     from /vagrant/documents/base_app/config/environment.rb:6:in <top (required)>'
    from /home/vagrant/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:247:in require'     from /home/vagrant/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:247:in block in require'
    from /home/vagrant/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:232:in load_dependency'     from /home/vagrant/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/activesupport-4.1.6/lib/active_support/dependencies.rb:247:in require'
    from /vagrant/documents/base_app/config.ru:3:in block in <main>'     from /home/vagrant/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/rack-1.5.5/lib/rack/builder.rb:55:in instance_eval'
    from /home/vagrant/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/rack-1.5.5/lib/rack/builder.rb:55:in initialize'     from /vagrant/documents/base_app/config.ru:in new'
    from /vagrant/documents/base_app/config.ru:in <main>'     from /home/vagrant/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/rack-1.5.5/lib/rack/builder.rb:49:in eval'
    from /home/vagrant/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/rack-1.5.5/lib/rack/builder.rb:49:in new_from_string'     from /home/vagrant/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/rack-1.5.5/lib/rack/builder.rb:40:in parse_file'
    from /home/vagrant/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/rack-1.5.5/lib/rack/server.rb:277:in build_app_and_options_from_config'     from /home/vagrant/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/rack-1.5.5/lib/rack/server.rb:199:in app'
    from /home/vagrant/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/railties-4.1.6/lib/rails/commands/server.rb:50:in app'     from /home/vagrant/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/rack-1.5.5/lib/rack/server.rb:314:in wrapped_app'
    from /home/vagrant/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/railties-4.1.6/lib/rails/commands/server.rb:130:in log_to_stdout'     from /home/vagrant/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/railties-4.1.6/lib/rails/commands/server.rb:67:in start'
    from /home/vagrant/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/railties-4.1.6/lib/rails/commands/commands_tasks.rb:81:in block in server'     from /home/vagrant/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/railties-4.1.6/lib/rails/commands/commands_tasks.rb:76:in tap'
    from /home/vagrant/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/railties-4.1.6/lib/rails/commands/commands_tasks.rb:76:in server'     from /home/vagrant/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/railties-4.1.6/lib/rails/commands/commands_tasks.rb:40:in run_command!'
    from /home/vagrant/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/railties-4.1.6/lib/rails/commands.rb:17:in <top (required)>'     from /vagrant/documents/base_app/bin/rails:8:in require'
    from /vagrant/documents/base_app/bin/rails:8:in <top (required)>'     from /home/vagrant/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/spring-1.6.4/lib/spring/client/rails.rb:28:in load'
    from /home/vagrant/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/spring-1.6.4/lib/spring/client/rails.rb:28:in call'     from /home/vagrant/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/spring-1.6.4/lib/spring/client/command.rb:7:in call'
    from /home/vagrant/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/spring-1.6.4/lib/spring/client.rb:28:in run'     from /home/vagrant/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/spring-1.6.4/bin/spring:49:in <top (required)>'
    from /home/vagrant/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/spring-1.6.4/lib/spring/binstub.rb:11:in load'     from /home/vagrant/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/spring-1.6.4/lib/spring/binstub.rb:11:in <top (required)>'
    from /home/vagrant/.rbenv/versions/2.1.3/lib/ruby/site_ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in require'     from /home/vagrant/.rbenv/versions/2.1.3/lib/ruby/site_ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in require'
    from /vagrant/documents/base_app/bin/spring:13:in <top (required)>'     from bin/rails:3:in load'
    from bin/rails:3:in `<main>'

補足情報(言語/FW/ツール等のバージョンなど)

一応下記URLは試したのですがダメでした。
http://chen-katze.blogspot.jp/2015/05/rails-server.html

よろしくお願いいたします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

ひょっとして

'redis'というgemと'redis-rails'というgemをインストールしていたりしませんか?

Gemfileを確認して、どちらかを消しましょう。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/03/08 19:55

    serinuntiusさん
    ありがとうございます!無事解決できました。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.98%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る