質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.13%

Amazon Linux 1でnginxのバージョンを1.18.0にあげたい

解決済

回答 1

投稿

  • 評価
  • クリップ 1
  • VIEW 603

score 12

Amazon Linux 1でnginxのバージョンを1.16.1から1.18.0にあげたいのですが、
エラーが発生しあげれません。

解決策教えていただきたいです。

現バージョン: 1:nginx-1.16.1-1.37.amzn1.x86_64    
上げたいバージョン:nginx-1.18.0-1.el6.ngx.x86_64

(バージョンアップ手順)
・リポジトリ作成後以下コマンド実施

sudo yum --disablerepo=amzn-updates --enablerepo=nginx-stable install nginx-1.18.0-1.el6.ngx.x86_64

(エラー内容)

読み込んだプラグイン:priorities, update-motd, upgrade-helper
1 packages excluded due to repository priority protections
パッケージ nginx は nginx-all-modules によって不要になりました。代わりに 1:nginx-all-modules-1.12.1-1.33.amzn1.x86_64 のインストールを試みています。
依存性の解決をしています
--> トランザクションの確認を実行しています。
---> パッケージ nginx-all-modules.x86_64 1:1.12.1-1.33.amzn1 を インストール
--> 依存性の処理をしています: nginx-mod-stream(x86-64) = 1:1.12.1-1.33.amzn1 のパッケージ: 1:nginx-all-modules-1.12.1-1.33.amzn1.x86_64
--> 依存性の処理をしています: nginx-mod-mail(x86-64) = 1:1.12.1-1.33.amzn1 のパッケージ: 1:nginx-all-modules-1.12.1-1.33.amzn1.x86_64
--> 依存性の処理をしています: nginx-mod-http-xslt-filter(x86-64) = 1:1.12.1-1.33.amzn1 のパッケージ: 1:nginx-all-modules-1.12.1-1.33.amzn1.x86_64
--> 依存性の処理をしています: nginx-mod-http-perl(x86-64) = 1:1.12.1-1.33.amzn1 のパッケージ: 1:nginx-all-modules-1.12.1-1.33.amzn1.x86_64
--> 依存性の処理をしています: nginx-mod-http-image-filter(x86-64) = 1:1.12.1-1.33.amzn1 のパッケージ: 1:nginx-all-modules-1.12.1-1.33.amzn1.x86_64
--> 依存性の処理をしています: nginx-mod-http-geoip(x86-64) = 1:1.12.1-1.33.amzn1 のパッケージ: 1:nginx-all-modules-1.12.1-1.33.amzn1.x86_64
--> トランザクションの確認を実行しています。
---> パッケージ nginx-mod-http-geoip.x86_64 1:1.12.1-1.33.amzn1 を インストール
--> 依存性の処理をしています: nginx(x86-64) = 1:1.12.1-1.33.amzn1 のパッケージ: 1:nginx-mod-http-geoip-1.12.1-1.33.amzn1.x86_64
--> 依存性の処理をしています: GeoIP のパッケージ: 1:nginx-mod-http-geoip-1.12.1-1.33.amzn1.x86_64
--> 依存性の処理をしています: libGeoIP.so.1()(64bit) のパッケージ: 1:nginx-mod-http-geoip-1.12.1-1.33.amzn1.x86_64
---> パッケージ nginx-mod-http-image-filter.x86_64 1:1.12.1-1.33.amzn1 を インストール
--> 依存性の処理をしています: nginx(x86-64) = 1:1.12.1-1.33.amzn1 のパッケージ: 1:nginx-mod-http-image-filter-1.12.1-1.33.amzn1.x86_64
--> 依存性の処理をしています: gd のパッケージ: 1:nginx-mod-http-image-filter-1.12.1-1.33.amzn1.x86_64
--> 依存性の処理をしています: libgd.so.2()(64bit) のパッケージ: 1:nginx-mod-http-image-filter-1.12.1-1.33.amzn1.x86_64
---> パッケージ nginx-mod-http-perl.x86_64 1:1.12.1-1.33.amzn1 を インストール
--> 依存性の処理をしています: nginx(x86-64) = 1:1.12.1-1.33.amzn1 のパッケージ: 1:nginx-mod-http-perl-1.12.1-1.33.amzn1.x86_64
---> パッケージ nginx-mod-http-xslt-filter.x86_64 1:1.12.1-1.33.amzn1 を インストール
--> 依存性の処理をしています: nginx(x86-64) = 1:1.12.1-1.33.amzn1 のパッケージ: 1:nginx-mod-http-xslt-filter-1.12.1-1.33.amzn1.x86_64
---> パッケージ nginx-mod-mail.x86_64 1:1.12.1-1.33.amzn1 を インストール
--> 依存性の処理をしています: nginx(x86-64) = 1:1.12.1-1.33.amzn1 のパッケージ: 1:nginx-mod-mail-1.12.1-1.33.amzn1.x86_64
---> パッケージ nginx-mod-stream.x86_64 1:1.12.1-1.33.amzn1 を インストール
--> 依存性の処理をしています: nginx(x86-64) = 1:1.12.1-1.33.amzn1 のパッケージ: 1:nginx-mod-stream-1.12.1-1.33.amzn1.x86_64
--> トランザクションの確認を実行しています。
---> パッケージ GeoIP.x86_64 0:1.4.8-1.5.amzn1 を インストール
---> パッケージ gd.x86_64 0:2.0.35-11.10.amzn1 を インストール
--> 依存性の処理をしています: libXpm.so.4()(64bit) のパッケージ: gd-2.0.35-11.10.amzn1.x86_64
---> パッケージ nginx-mod-http-geoip.x86_64 1:1.12.1-1.33.amzn1 を インストール
--> 依存性の処理をしています: nginx(x86-64) = 1:1.12.1-1.33.amzn1 のパッケージ: 1:nginx-mod-http-geoip-1.12.1-1.33.amzn1.x86_64
---> パッケージ nginx-mod-http-image-filter.x86_64 1:1.12.1-1.33.amzn1 を インストール
--> 依存性の処理をしています: nginx(x86-64) = 1:1.12.1-1.33.amzn1 のパッケージ: 1:nginx-mod-http-image-filter-1.12.1-1.33.amzn1.x86_64
---> パッケージ nginx-mod-http-perl.x86_64 1:1.12.1-1.33.amzn1 を インストール
--> 依存性の処理をしています: nginx(x86-64) = 1:1.12.1-1.33.amzn1 のパッケージ: 1:nginx-mod-http-perl-1.12.1-1.33.amzn1.x86_64
---> パッケージ nginx-mod-http-xslt-filter.x86_64 1:1.12.1-1.33.amzn1 を インストール
--> 依存性の処理をしています: nginx(x86-64) = 1:1.12.1-1.33.amzn1 のパッケージ: 1:nginx-mod-http-xslt-filter-1.12.1-1.33.amzn1.x86_64
---> パッケージ nginx-mod-mail.x86_64 1:1.12.1-1.33.amzn1 を インストール
--> 依存性の処理をしています: nginx(x86-64) = 1:1.12.1-1.33.amzn1 のパッケージ: 1:nginx-mod-mail-1.12.1-1.33.amzn1.x86_64
---> パッケージ nginx-mod-stream.x86_64 1:1.12.1-1.33.amzn1 を インストール
--> 依存性の処理をしています: nginx(x86-64) = 1:1.12.1-1.33.amzn1 のパッケージ: 1:nginx-mod-stream-1.12.1-1.33.amzn1.x86_64
--> トランザクションの確認を実行しています。
---> パッケージ libXpm.x86_64 0:3.5.10-2.9.amzn1 を インストール
---> パッケージ nginx-mod-http-geoip.x86_64 1:1.12.1-1.33.amzn1 を インストール
--> 依存性の処理をしています: nginx(x86-64) = 1:1.12.1-1.33.amzn1 のパッケージ: 1:nginx-mod-http-geoip-1.12.1-1.33.amzn1.x86_64
---> パッケージ nginx-mod-http-image-filter.x86_64 1:1.12.1-1.33.amzn1 を インストール
--> 依存性の処理をしています: nginx(x86-64) = 1:1.12.1-1.33.amzn1 のパッケージ: 1:nginx-mod-http-image-filter-1.12.1-1.33.amzn1.x86_64
---> パッケージ nginx-mod-http-perl.x86_64 1:1.12.1-1.33.amzn1 を インストール
--> 依存性の処理をしています: nginx(x86-64) = 1:1.12.1-1.33.amzn1 のパッケージ: 1:nginx-mod-http-perl-1.12.1-1.33.amzn1.x86_64
---> パッケージ nginx-mod-http-xslt-filter.x86_64 1:1.12.1-1.33.amzn1 を インストール
--> 依存性の処理をしています: nginx(x86-64) = 1:1.12.1-1.33.amzn1 のパッケージ: 1:nginx-mod-http-xslt-filter-1.12.1-1.33.amzn1.x86_64
---> パッケージ nginx-mod-mail.x86_64 1:1.12.1-1.33.amzn1 を インストール
--> 依存性の処理をしています: nginx(x86-64) = 1:1.12.1-1.33.amzn1 のパッケージ: 1:nginx-mod-mail-1.12.1-1.33.amzn1.x86_64
---> パッケージ nginx-mod-stream.x86_64 1:1.12.1-1.33.amzn1 を インストール
--> 依存性の処理をしています: nginx(x86-64) = 1:1.12.1-1.33.amzn1 のパッケージ: 1:nginx-mod-stream-1.12.1-1.33.amzn1.x86_64
--> 依存性解決を終了しました。
エラー: パッケージ: 1:nginx-mod-http-geoip-1.12.1-1.33.amzn1.x86_64 (amzn-main)
要求: nginx(x86-64) = 1:1.12.1-1.33.amzn1
利用可能: nginx-1.8.0-1.el6.ngx.x86_64 (nginx-stable)
nginx(x86-64) = 1.8.0-1.el6.ngx
利用可能: nginx-1.8.1-1.el6.ngx.x86_64 (nginx-stable)
nginx(x86-64) = 1.8.1-1.el6.ngx
利用可能: nginx-1.10.0-1.el6.ngx.x86_64 (nginx-stable)
nginx(x86-64) = 1.10.0-1.el6.ngx
利用可能: nginx-1.10.1-1.el6.ngx.x86_64 (nginx-stable)
nginx(x86-64) = 1.10.1-1.el6.ngx
利用可能: nginx-1.10.2-1.el6.ngx.x86_64 (nginx-stable)
nginx(x86-64) = 1.10.2-1.el6.ngx
利用可能: nginx-1.10.3-1.el6.ngx.x86_64 (nginx-stable)
nginx(x86-64) = 1.10.3-1.el6.ngx
利用可能: nginx-1.12.0-1.el6.ngx.x86_64 (nginx-stable)
nginx(x86-64) = 1.12.0-1.el6.ngx
利用可能: nginx-1.12.1-1.el6.ngx.x86_64 (nginx-stable)
nginx(x86-64) = 1.12.1-1.el6.ngx
利用可能: nginx-1.12.2-1.el6.ngx.x86_64 (nginx-stable)
nginx(x86-64) = 1.12.2-1.el6.ngx
利用可能: nginx-1.14.0-1.el6.ngx.x86_64 (nginx-stable)
nginx(x86-64) = 1.14.0-1.el6.ngx
利用可能: nginx-1.14.1-1.el6.ngx.x86_64 (nginx-stable)
nginx(x86-64) = 1.14.1-1.el6.ngx
利用可能: nginx-1.14.2-1.el6.ngx.x86_64 (nginx-stable)
nginx(x86-64) = 1.14.2-1.el6.ngx
利用可能: nginx-1.16.0-1.el6.ngx.x86_64 (nginx-stable)
nginx(x86-64) = 1.16.0-1.el6.ngx
利用可能: nginx-1.16.1-1.el6.ngx.x86_64 (nginx-stable)
nginx(x86-64) = 1.16.1-1.el6.ngx
利用可能: nginx-1.18.0-1.el6.ngx.x86_64 (nginx-stable)
nginx(x86-64) = 1.18.0-1.el6.ngx
エラー: パッケージ: 1:nginx-mod-http-xslt-filter-1.12.1-1.33.amzn1.x86_64 (amzn-main)
要求: nginx(x86-64) = 1:1.12.1-1.33.amzn1
利用可能: nginx-1.8.0-1.el6.ngx.x86_64 (nginx-stable)
nginx(x86-64) = 1.8.0-1.el6.ngx
利用可能: nginx-1.8.1-1.el6.ngx.x86_64 (nginx-stable)
nginx(x86-64) = 1.8.1-1.el6.ngx
利用可能: nginx-1.10.0-1.el6.ngx.x86_64 (nginx-stable)
nginx(x86-64) = 1.10.0-1.el6.ngx
利用可能: nginx-1.10.1-1.el6.ngx.x86_64 (nginx-stable)
nginx(x86-64) = 1.10.1-1.el6.ngx
利用可能: nginx-1.10.2-1.el6.ngx.x86_64 (nginx-stable)
nginx(x86-64) = 1.10.2-1.el6.ngx
利用可能: nginx-1.10.3-1.el6.ngx.x86_64 (nginx-stable)
nginx(x86-64) = 1.10.3-1.el6.ngx
利用可能: nginx-1.12.0-1.el6.ngx.x86_64 (nginx-stable)
nginx(x86-64) = 1.12.0-1.el6.ngx
利用可能: nginx-1.12.1-1.el6.ngx.x86_64 (nginx-stable)
nginx(x86-64) = 1.12.1-1.el6.ngx
利用可能: nginx-1.12.2-1.el6.ngx.x86_64 (nginx-stable)
nginx(x86-64) = 1.12.2-1.el6.ngx
利用可能: nginx-1.14.0-1.el6.ngx.x86_64 (nginx-stable)
nginx(x86-64) = 1.14.0-1.el6.ngx
利用可能: nginx-1.14.1-1.el6.ngx.x86_64 (nginx-stable)
nginx(x86-64) = 1.14.1-1.el6.ngx
利用可能: nginx-1.14.2-1.el6.ngx.x86_64 (nginx-stable)
・・・・・・・・・・・

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

パッケージ nginx は nginx-all-modules によって不要になりました。代わりに 1:nginx-all-modules-1.12.1-1.33.amzn1.x86_64 のインストールを試みています。

というメッセージであれば、 nginx-all-modules-1.12.1-1.33.amzn1.x86_64 が新しいパッケージと判断していますね。

試していないのですが、yum で install の代わりに downgrade を指定したらインストールできたりしないでしょうか。(自己責任で試してくださいね。)

man yum

downgrade
Will try and downgrade a package from the version currently installed to the previously highest version (or the specified version). The depsolver will not necessarily work, but if you specify all the packages it should work (and thus. all the simple cases will work). Also this does not work for "installonly" packages, like Kernels. downgrade operates on groups, files, provides, filelists and rpm files just like the "install" command.

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2020/09/03 19:37

    解決できました!!
    ありがとうございます!

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.13%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る