質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.35%

Vue CLI: npm run serve でエラー

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 2,014

前提・実現したいこと

はじめまして。現在Vue.jsを学習しているものです。
表題のとおり本日、run serveでローカルサーバを立ち上げようとしたところ下記の様なエラーが出現してしまい、対応に困っております。
いままでVueCliのプロジェクトは2つほど作成しており、これまでは問題なくローカルサーバの立ち上げまで、行えておりました。
こちらのエラーの原因がわかる方がいらっしゃいましたら、
ご教示いただけますと幸いです。
宜しくお願い致します。

やったこと

下記の手順でプロジェクトを作成し、ローカルサーバを立ち上げました。

①ターミナルを開きVueCLIをインストール(成功)
npm install -g @vue/cli
②vuerという名前でプロジェクトを作成(成功)
vue create vuer
③ローカルサーバを立ち上げる(失敗)
npm run serve

発生している問題・エラーメッセージ

ターミナルに下記メッセージが出力され、ローカルサーバを立ち上げることができておりません。

 INFO  Starting development server...
 ERROR  Error: Package exports for '/Users/nanashi/Desktop/study/Udemy/Vuejs2/vuer/node_modules/kleur' do not define a valid './colors' target
Error: Package exports for '/Users/nanashi/Desktop/study/Udemy/Vuejs2/vuer/node_modules/kleur' do not define a valid './colors' target
    at resolveExportsTarget (internal/modules/cjs/loader.js:460:13)
    at resolveExports (internal/modules/cjs/loader.js:393:16)
    at Function.Module._findPath (internal/modules/cjs/loader.js:492:20)
    at Function.Module._resolveFilename (internal/modules/cjs/loader.js:787:27)
    at Function.Module._load (internal/modules/cjs/loader.js:693:27)
    at Module.require (internal/modules/cjs/loader.js:864:19)
    at require (internal/modules/cjs/helpers.js:74:18)
    at Object.<anonymous> (/Users/nanashi/Desktop/study/Udemy/Vuejs2/vuer/node_modules/autoprefixer/lib/autoprefixer.js:9:13)
    at Module._compile (internal/modules/cjs/loader.js:971:30)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:1011:10)
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! vuer@0.1.0 serve: `vue-cli-service serve`
npm ERR! Exit status 1
npm ERR! 
npm ERR! Failed at the vuer@0.1.0 serve script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     /Users/nanashi/.npm/_logs/2020-06-21T09_11_09_438Z-debug.log

試したこと

バージョンの最新化

各バージョンは現在下記の通りになっております。

vue --version
@vue/cli 4.4.4
npm --version
6.14.5
node --version
v13.0.1
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

おそらくこちらのリンク先と同じ問題なので
npm install autoprefixer@9.8.0 で
インストールすれば直りそうです。
https://github.com/postcss/autoprefixer/issues/1328

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2020/06/22 19:27

    ご回答ありがとうございます!
    こちらの問題、Node.jsのバージョンを最新にすることで解決いたしました!

    キャンセル

  • 2020/06/22 20:05

    解決できて良かったです。
    私の環境では動作していたのですが
    Node.jsのバージョンの問題だったのですね。

    参考までに私のバージョンも貼っておきます。
    $ vue --version
    @vue/cli 4.3.1
    $ npm --version
    6.14.5
    $ node --version
    v13.13.0
    $ npm list vue
    vuer@0.1.0 /Users/vuer
    └── vue@2.6.11

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.35%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る