質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.12%

CentOS6.6でMySQL5.6が起動しない

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 1,831

Buakaw

score 235

さくらの専用サーバへ、MySQLのセットアップをしています。
デフォルトでは、MySQL5.3が入っており、それを5.6へバージョンアップするような作業です。

現在の状況は以下です。

> [root@localhost /]# mysqld --version
> mysqld  Ver 5.6.28 for Linux on x86_64 (MySQL Community Server (GPL))
> [root@localhost /]# /etc/init.d/mysqld start
> MySQL Daemon failed to start.
> mysqld を起動中:                                           [失敗]
[root@localhost /]#  cat /var/log/mysql/mysqld.log | grep ERROR
2016-02-03 21:27:13 8851 [ERROR] InnoDB: Creation of SYS_TABLESPACES and SYS_DATAFILES has failed with error 18.  Tablespace is full. Dropping incompletely created tables.
AFILES has failed with error 18.  Tablespace is full. Dropping incompletely created tables.

起動時にエラーが発生し起動ができない状況です。

/*========実施した作業手順========*/

//mysqldを停止確認
[root@localhost tmp]# service mysqld stop
//リポジトリ追加
[root@localhost tmp]# rpm -ivh http://dev.mysql.com/get/mysql-community-release-el6-5.noarch.rpm
//インストール
[root@localhost tmp]# yum install mysql-community-server
//バージョン確認
[root@localhost tmp]# mysql --version
mysql  Ver 14.14 Distrib 5.6.28, for Linux (x86_64) using  EditLine wrapper
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

現在の 5.6 は mysql.com の mysql-community-server-5.6.28 でしょうか。
CentOS 6 に入っているバージョンは mysql-server-5.1.x ですが、元々の 5.3 はどのようにインストールしましたか?

エラーメッセージについてはわかりませんが、何かしらバージョン間で互換性がないのかもしれません。
5.3 環境で mysqldump したものを 5.6 にリストアして、起動後 mysql_upgrade するといいと思います。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.12%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る