質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.50%

vscodeでorg.springframework.bootが見つからない」

受付中

回答 0

投稿

  • 評価
  • クリップ 0
  • VIEW 1,182

score 1

macからvscodeでspring bootを使用しようとしたらプロジェクトを作成したディレクトリ のsrc/main/java/com/example/practice/DemoApplication.javaのimport部分で以下のようなエラーが出ました。

パッケージorg.springframework.bootは存在しません


プロジェクトを作る際に

  1. spring initializr : generate gradle project
  2. java
  3. spring boot2.2.7
  4. lombok, Spring Web, Spring Boot DevTools, Thymeleaf

を選択しディレクトリ を作成しました。

build.gradleの部分でうまく読み取れていないのかと思ったのですがそれも見た限りではそんなことはなさそうです。

plugins {
    id 'org.springframework.boot' version '2.2.7.RELEASE'
    id 'io.spring.dependency-management' version '1.0.9.RELEASE'
    id 'java'
}

group = 'com.example'
version = '0.0.1-SNAPSHOT'
sourceCompatibility = '1.8'

configurations {
    developmentOnly
    runtimeClasspath {
        extendsFrom developmentOnly
    }
    compileOnly {
        extendsFrom annotationProcessor
    }
}

repositories {
    mavenCentral()
}

dependencies {
    implementation 'org.springframework.boot:spring-boot-starter-thymeleaf'
    implementation 'org.springframework.boot:spring-boot-starter-web'
    compileOnly 'org.projectlombok:lombok'
    developmentOnly 'org.springframework.boot:spring-boot-devtools'
    annotationProcessor 'org.projectlombok:lombok'
    testImplementation('org.springframework.boot:spring-boot-starter-test') {
        exclude group: 'org.junit.vintage', module: 'junit-vintage-engine'
    }
}

test {
    useJUnitPlatform()
}

また、vscodeで入れた拡張はspring boot extension packです。
windowsでやった際にはこのエラーはでなかったのですが、他pcのmacではこのようなエラーが出てしまい、自力では解決できなさそうなので何か解決法等あればご教授願いたいです。

version

  • Mac OS X 10.15.4 x86_64
  • vscode 1.45.0
  • java 13.0.2 2020-01-14
  • gradle 6.4
  • spring boot 2.2.7
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正の依頼

  • m.ts10806

    2020/05/10 10:06

    gradle って何もコマンド実行しなくてもプラグインインストールしてくれましたっけ

    キャンセル

  • asahina1979

    2020/05/10 14:03

    エクリプスでいえばプロジェクトのリフレッシュが必要だから コマンドが必須のはず

    キャンセル

  • ts4222

    2020/05/10 14:58

    ありがとうございます

    ./gradlew build --refresh-dependencies

    とコマンドを実行して見たのですがエラーは解消されませんでした....

    キャンセル

まだ回答がついていません

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.50%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る