質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.22%

新規で作成したデータベースにphpMyAdminからアクセスできない。

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 2,743

p-craft

score 201

お名前サーバーで運用しているWordPressの表示がおかしくなってしまった為、次のような手順で再インストールを行いました。

1.WordPressのフォルダ名を変更(バックアップの為)

2.phpMyAdminをインストールし、データをエクスポート。(お名前サーバーでphpmyadminを使うには、自分でインストールしなければならない為)

3.新規にデータベース作成

3.元々WordPressの入っていたフォルダに、新たにWordPressをインストール(この時、接続差のデータベースは新規に作成したデータベースにした。

と、ここまではいいのですが、新たに作成したデータベースに、phpMyAdminでログインすると、なぜか、

データベースが存在しません


と表示されてしまい、古いデータベースのデータをインポート出来ません。

見ると、サーバーの表示が、なぜか古いデータベースの表示になってしまっています。

もちろん、ユーザーIDとパスワードが間違っているなんてことはありません。

古いデータベースにはもちろんアクセスできます。

新規にインストールしたWordPressは、きちんと表示されており、記事も投稿できますので、データベースが無いなんてことはありません。

けれども、そのデータベースをphpmyadminで表示することが出来ないのです。

つまり、新規に作成したデータベースにアクセスする事が出来ないのですが、どう対処したらいいのかわからず困惑しております。

なんとかして、新規に作成したデータベースにアクセスしたいのですが、何かいい方法といますか、対処法や、またはphpMyAdmin以外でデータベースにアクセスする方法など、ご存知の方いらっしゃいましたら、ご教授いただけないでしょうか?

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

お名前サーバーのコントロールパネルで、「データベース設定 > MySQL」を開いて、データベース接続設定を再度確認してみてください。

たとえば、お名前サーバーでは、MySQLのホストが複数ありますが、古いデータベースと新しいデータベースで、ホスト名が異なることはないでしょうか?

データベースホスト名が、異なるようであれば、 phpMyAdmin の設定で、下記のホスト名の部分をコピーして、もう1台分増やしてください。

$i++;
/* Authentication type */
$cfg['Servers'][$i]['auth_type'] = 'cookie';
/* Server parameters */
$cfg['Servers'][$i]['host'] = 'localhost';
$cfg['Servers'][$i]['connect_type'] = 'tcp';
$cfg['Servers'][$i]['compress'] = false;
$cfg['Servers'][$i]['AllowNoPassword'] = false;

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/01/30 17:49

    あぁ、そういう事だったんですね!
    はい、確かにホスト名が違っておりました。
    上記の設定でうまくいきました!
    ありがとうございました~。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.22%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る