質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.33%

railsでサーバーが立ち上がらない

受付中

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 428

Tomato_leaf

score 14

Rails でターミナルにてサーバーを立ち上げようとするのですが
エラがー下記のように出て立ち上げることができません。

Could not find gem 'sqlite3 (~> 1.3.6)' in any of the gem sources listed in your Gemfile.
Run bundle install to install missing gems.

不思議なのが上記の操作をしても

continue.
Make sure that gem install sassc -v '2.3.0' --source 'https://rubygems.org/'
succeeds before bundling.

と出て

gem install sassc -v '2.3.0' --source 'https://rubygems.org/

を実行し、そのあとbundle install しても

An error occurred while installing sassc (2.3.0), and Bundler cannot
continue.
Make sure that gem install sassc -v '2.3.0' --source 'https://rubygems.org/'
succeeds before bundling.

と出て堂々巡りしています。

これは一体何が足りないのでしょうか?

(sqlite3 (~> 1.3.6)がgemファイルに足りないと記載があるかと思いますが
写真の通り,存在しているように思います。)
イメージ説明

写真追加
イメージ説明

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

0

sqlite3 (~> 1.3.6)がgemファイルに足りないと記載
これは足りないというより、こんなバージョンないよ、みたいなエラーだと思います。

gem 'sqlite3', '~> 1.4.0'


に変えてみたらできますかね?
参考のQiita

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2020/04/22 13:39

    試しに2通りやってみましたが
    gem 'sqlite3’は続きを入力してくれと出てしまいました。
    [vagrant@localhost myapp]$ gem 'sqlite3', '~> 1.4.0'
    ERROR: While executing gem ... (Gem::CommandLineError)
    Unknown command sqlite3,
    [vagrant@localhost myapp]$ gem 'sqlite3’
    >

    キャンセル

  • 2020/04/22 15:56

    なかなか答えが出なくて申し訳ないのですが、bundle updateしてみてください。

    キャンセル

  • 2020/04/22 17:37

    いいえ、こちらこそ何度もありがとうございます。ですがやはり同じエラーが出ますね。。

    An error occurred while installing sassc (2.3.0), and Bundler cannot
    continue.
    Make sure that `gem install sassc -v '2.3.0' --source 'https://rubygems.org/'`
    succeeds before bundling.

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.33%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る