質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.80%

Ruby on Railsがインストールできない。

解決済

回答 2

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 617

moritsuo

score 4

前提・実現したいこと

railsの環境構築をprogateのサイト(https://prog-8.com/docs/rails-env-win)を見て行っている者です。
項目4まで進んで  gem install rails -v "5.2.3"  というコードをコマンドプロントで入力したところエラーが起きてインストールできません。
原因または解決方法を教えてもらいたいです。

発生している問題・エラーメッセージ

ERROR:  SSL verification error at depth 0: unable to get local issuer certificate (20)
ERROR:  You must add /C=JP/ST=Tokyo/O=ALPS SYSTEM INTEGRATION CO.,LTD./CN=ALPS SYSTEM INTEGRATION CO.,LTD. CA 2 to your local trusted store
ERROR:  Could not find a valid gem 'rails' (= 5.2.3), here is why:
          Unable to download data from https://rubygems.org/ - SSL_connect returned=1 errno=0 state=error: certificate verify failed (unable to get local issuer certificate) (https://rubygems.org/specs.4.8.gz)

該当のソースコード

gem install rails -v "5.2.3"

試したこと

どうやらパソコンの中に入っていたセキュリティソフトがssl証明書の取得を邪魔していたようです回答してくれた方ありがとうございました。

補足情報(FW/ツールのバージョンなど)

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • kazuyakazuya

    2020/03/25 22:26 編集

    ruby -ropen-uri -e 'eval open("https://git.io/vQhWq").read'

    これ実行してみてください。
    結果も見せてください

    キャンセル

  • キャンセル

  • kazuyakazuya

    2020/03/25 22:31

    https://bundler.io/v1.16/guides/rubygems_tls_ssl_troubleshooting_guide.html
    >出力に「証明書がないため、Rubyはrubygems.orgに接続できません」と表示された場合は、証明書の検証エラーがあり、証明書を更新する必要があります。

    代わりに「OpenSSLのバージョンが古すぎるため、Rubyがrubygems.orgに接続できない」と表示された場合、OpenSSLのバージョンは古く、TLSv1.2と互換性がなく、OpenSSLをアップグレードするか、Rubyを再コンパイルして使用する必要があります。 SSLの新しいバージョン。

    キャンセル

回答 2

check解決した方法

0

パソコン内のダウンロードを邪魔していたセキュリティソフトを消しました。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

0

勘違いだったらすみません、
バージョン指定の場合、コメントアウトは必要でしたか。
gem install -v 4.2.1 rails
このような形かと、、、

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2020/03/25 17:26

    やってみましたが同じエラーコードが出るだけでした。

    キャンセル

  • 2020/03/26 21:51

    エディター等、実行環境を明示していただけると、他のかたも回答しやすいと思いますよ!

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.80%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る