質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.35%

bundleのバージョン設定ができない

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 1,968

mbkk

score 12

bundleのバージョン設定についてお聞きしたいです。

目的:vendor/bundle にgemをインストール

$ bundle install --path vendor/bundle --jobs=4


を試みる。
以下のエラー発生。

[DEPRECATED] The `--path` flag is deprecated because it relies on being remembered across bundler invocations, which bundler will no longer do in future versions. Instead please use `bundle config set path 'vendor/bundle'`, and stop using this flag
Fetching gem metadata from https://rubygems.org/.............
Fetching gem metadata from https://rubygems.org/.
Resolving dependencies...
Bundler could not find compatible versions for gem "bundler":
  In Gemfile:
    rails (= 5.0.1) was resolved to 5.0.1, which depends on
      bundler (< 2.0, >= 1.3.0)

  Current Bundler version:
    bundler (2.1.2)
This Gemfile requires a different version of Bundler.
Perhaps you need to update Bundler by running `gem install bundler`?

Could not find gem 'bundler (< 2.0, >= 1.3.0)', which is required by gem 'rails (= 5.0.1)', in any
of the sources.


エラー文にあるコマンドを使ったが結果は同じ。

$ bundle config set path 'vendor/bundle'
Your application has set path to "vendor/bundle". This will override the global value you are currently setting
$ bundle install
(以下、同じエラー)


bundlerのバージョンを確認。2.1.2と1.14.3があったので、デフォルト変更を試みたが変更されず。

$ gem list bundler
*** LOCAL GEMS ***
bundler (default: 2.1.2, 1.14.3)

$ bundler config default -v 1.14.3
You are replacing the current global value of default, which is currently "1.14.3"
$ bundler -v
Bundler version 2.1.4
$ gem list bundler
*** LOCAL GEMS ***
bundler (default: 2.1.2, 1.14.3)


何か別ファイルの設定が邪魔しているのでしょうか、、、
Gemfileなどでbundlerを変更してはいません。

Gemfile.lockファイルのBUNDLED WITHで「bundle install したときのbundlerのバージョンが記憶される」らしいので、それを書き換えれば、と思いましたが、肝心のGemfile.lockが見つかりません(エラーなので作成されていないのかもしれません)
Gemfile.lock内にはbundlerのバージョンをトラッキングする記述がある

手詰まりで先に進めません。
お手数ではございますが、ご意見よろしくお願いします。

追記:
仕方ないのでアンインストールして、1.14.3を指定してインストールし直しました。
すると下記の状況になりました。

$ bundler -v
Bundler version 1.14.3
$ gem list bundler
*** LOCAL GEMS ***
bundler (default: 2.1.2, 1.14.3)


Bundlerのバージョンは1.14.3にも関わらず、指定インストールしていないのにデフォルトは2.2.2とは...??
相変わらず上記のエラー(Current Bundler version: bundler (2.1.2))が出るので、デフォルトを変更する方法を探しています。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

check解決した方法

0

gem(rails)を普通にインストールして解決
(Bundlerのバージョンデフォルト設定については未解決)

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.35%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る