質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.06%

Railsアプリをherokuにpushしたいが、エラーがでる。

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 1
  • VIEW 318

score 51

railsアプリをHerokuにPushしようとしたら、エラーがでました。
ちなみにプランは無料でやっています。

git push heroku master実行後のエラー⇃

...
remote:        NoMethodError: undefined method `defalut_url_options' for #<ActionDispatch::Routing::RouteSet:0x00000000030c88b8>
remote:        /tmp/build_3040c0acb25fa2b672d876629a029ebf/config/environments/production.rb:96:in `block in <main>'
remote:        /tmp/build_3040c0acb25fa2b672d876629a029ebf/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.1/lib/rails/railtie.rb:216:in `instance_eval'
remote:        /tmp/build_3040c0acb25fa2b672d876629a029ebf/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.1/lib/rails/railtie.rb:216:in `configure'
remote:        /tmp/build_3040c0acb25fa2b672d876629a029ebf/config/environments/production.rb:1:in `<main>'
remote:        /tmp/build_3040c0acb25fa2b672d876629a029ebf/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.4.5/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:22:in `require'
remote:        /tmp/build_3040c0acb25fa2b672d876629a029ebf/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.4.5/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:22:in `block in require_with_bootsnap_lfi'
remote:        /tmp/build_3040c0acb25fa2b672d876629a029ebf/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.4.5/lib/bootsnap/load_path_cache/loaded_features_index.rb:92:in `register'
remote:        /tmp/build_3040c0acb25fa2b672d876629a029ebf/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.4.5/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:21:in `require_with_bootsnap_lfi'
remote:        /tmp/build_3040c0acb25fa2b672d876629a029ebf/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.4.5/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:30:in `require'
remote:        /tmp/build_3040c0acb25fa2b672d876629a029ebf/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.1/lib/active_support/dependencies.rb:291:in `block in require'
remote:        /tmp/build_3040c0acb25fa2b672d876629a029ebf/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.1/lib/active_support/dependencies.rb:257:in `load_dependency'
remote:        /tmp/build_3040c0acb25fa2b672d876629a029ebf/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.1/lib/active_support/dependencies.rb:291:in `require'
remote:        /tmp/build_3040c0acb25fa2b672d876629a029ebf/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.1/lib/rails/engine.rb:608:in `block (2 levels) in <class:Engine>'
remote:        /tmp/build_3040c0acb25fa2b672d876629a029ebf/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.1/lib/rails/engine.rb:607:in `each'
remote:        /tmp/build_3040c0acb25fa2b672d876629a029ebf/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.1/lib/rails/engine.rb:607:in `block in <class:Engine>'
remote:        /tmp/build_3040c0acb25fa2b672d876629a029ebf/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.1/lib/rails/initializable.rb:32:in `instance_exec'
remote:        /tmp/build_3040c0acb25fa2b672d876629a029ebf/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.1/lib/rails/initializable.rb:32:in `run'
remote:        /tmp/build_3040c0acb25fa2b672d876629a029ebf/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.1/lib/rails/initializable.rb:61:in `block in run_initializers'
remote:        /tmp/build_3040c0acb25fa2b672d876629a029ebf/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.1/lib/rails/initializable.rb:50:in `each'
remote:        /tmp/build_3040c0acb25fa2b672d876629a029ebf/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.1/lib/rails/initializable.rb:50:in `tsort_each_child'
remote:        /tmp/build_3040c0acb25fa2b672d876629a029ebf/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.1/lib/rails/initializable.rb:60:in `run_initializers'
remote:        /tmp/build_3040c0acb25fa2b672d876629a029ebf/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.1/lib/rails/application.rb:361:in `initialize!'
remote:        /tmp/build_3040c0acb25fa2b672d876629a029ebf/config/environment.rb:5:in `<main>'
remote:        /tmp/build_3040c0acb25fa2b672d876629a029ebf/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.4.5/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:22:in `require'
remote:        /tmp/build_3040c0acb25fa2b672d876629a029ebf/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.4.5/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:22:in `block in require_with_bootsnap_lfi'
remote:        /tmp/build_3040c0acb25fa2b672d876629a029ebf/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.4.5/lib/bootsnap/load_path_cache/loaded_features_index.rb:92:in `register'
remote:        /tmp/build_3040c0acb25fa2b672d876629a029ebf/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.4.5/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:21:in `require_with_bootsnap_lfi'
remote:        /tmp/build_3040c0acb25fa2b672d876629a029ebf/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.4.5/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:30:in `require'
remote:        /tmp/build_3040c0acb25fa2b672d876629a029ebf/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.1/lib/active_support/dependencies.rb:291:in `block in require'
remote:        /tmp/build_3040c0acb25fa2b672d876629a029ebf/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.1/lib/active_support/dependencies.rb:257:in `load_dependency'
remote:        /tmp/build_3040c0acb25fa2b672d876629a029ebf/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.1/lib/active_support/dependencies.rb:291:in `require'
remote:        /tmp/build_3040c0acb25fa2b672d876629a029ebf/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.1/lib/rails/application.rb:337:in `require_environment!'
remote:        /tmp/build_3040c0acb25fa2b672d876629a029ebf/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.1/lib/rails/application.rb:520:in `block in run_tasks_blocks'
remote:        /tmp/build_3040c0acb25fa2b672d876629a029ebf/vendor/bundle/ruby/2.6.0/gems/sprockets-rails-3.2.1/lib/sprockets/rails/task.rb:62:in `block (2 levels) in define'
remote:        /tmp/build_3040c0acb25fa2b672d876629a029ebf/vendor/bundle/ruby/2.6.0/gems/rake-13.0.1/exe/rake:27:in `<top (required)>'
remote:        Tasks: TOP => environment
remote:        (See full trace by running task with --trace)
remote:
remote:  !
remote:  !     Precompiling assets failed.
remote:  !
remote:  !     Push rejected, failed to compile Ruby app.
remote:
remote:  !     Push failed
remote: Verifying deploy...
remote:
remote: !       Push rejected to asobisarch.
remote:


とエラーが出てしまいます。。。

コメントアウトの行は消しています。(はいらないので)

Rails.application.configure do

  config.cache_classes = true

  config.eager_load = true
  config.consider_all_requests_local       = false

  config.action_controller.perform_caching = true
  config.public_file_server.enabled = ENV['RAILS_SERVE_STATIC_FILES'].present?

  config.assets.js_compressor = :uglifier
  config.assets.css_compressor = :sass
  config.assets.compile = true

  config.active_storage.service = :local


  config.log_level = :debug

  config.log_tags = [ :request_id ]



  config.action_mailer.perform_caching = false

  config.i18n.fallbacks = true
config.assets.enabled = false

  config.active_support.deprecation = :notify

  config.log_formatter = ::Logger::Formatter.new

  config.assets.digest = true


  if ENV["RAILS_LOG_TO_STDOUT"].present?
    logger           = ActiveSupport::Logger.new(STDOUT)
    logger.formatter = config.log_formatter
    config.logger    = ActiveSupport::TaggedLogging.new(logger)
  end

  # Do not dump schema after migrations.
  config.active_record.dump_schema_after_migration = false

  Rails.application.routes.defalut_url_options[:host] = host
end

ちなみにherokuではpg(posgresql)しか無料版では使えないので。pgを利用しております。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

check解決した方法

+1

production.rb
Rails.application.routes.defalut_url_options[:host] = host

ここの  host  というところを 自分のサイトのURLを書くことで、無事pushできました。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.06%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る