質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.61%

php-zipをインストールしたい

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 8,438

score 4

Laravelのインストールでエラーが発生してしまいます。
解決方法を教えていただきたいです。

前提・実現したいこと

CentOSにLaravelをインストールしたいです。

現在の環境状態

//PHPのバージョン
php -v
PHP 7.3.12 (cli) (built: Nov 19 2019 12:37:39) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.3.12, Copyright (c) 1998-2018 Zend Technologies

//phpのパッケージ
# rpm -qa | grep php
php56-php-pecl-zip-1.15.5-1.el6.remi.x86_64
php71-php-cli-7.1.33-1.el6.remi.x86_64
php-7.3.12-1.el6.remi.x86_64
php-mbstring-7.3.12-1.el6.remi.x86_64
php71-runtime-2.0-1.el6.remi.x86_64
php71-2.0-1.el6.remi.x86_64
php56-php-pecl-jsonc-1.3.10-1.el6.remi.x86_64
php56-php-common-5.6.40-14.el6.remi.x86_64
php71-php-mbstring-7.1.33-1.el6.remi.x86_64
php-cli-7.3.12-1.el6.remi.x86_64
php-pecl-mcrypt-1.0.3-1.el6.remi.7.3.x86_64
php-xml-7.3.12-1.el6.remi.x86_64
php56-runtime-3.0-1.el6.remi.x86_64
php71-php-common-7.1.33-1.el6.remi.x86_64
php56-php-pdo-5.6.40-14.el6.remi.x86_64
php71-php-xml-7.1.33-1.el6.remi.x86_64
php-common-7.3.12-1.el6.remi.x86_64
php-devel-7.3.12-1.el6.remi.x86_64
php-gd-7.3.12-1.el6.remi.x86_64
php71-php-json-7.1.33-1.el6.remi.x86_64
php71-php-pdo-7.1.33-1.el6.remi.x86_64
php-json-7.3.12-1.el6.remi.x86_64
php-pdo-7.3.12-1.el6.remi.x86_64

発生している問題・エラーメッセージ

Laravelをインストールしようとすると以下のエラーが発生します。

#composer global require "laravel/installer"

Changed current directory to /home/vagrant/.composer
Using version ^3.0 for laravel/installer
./composer.json has been created
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - laravel/installer v3.0.1 requires ext-zip * -> the requested PHP extension zip is missing from your system.
    - laravel/installer v3.0.0 requires ext-zip * -> the requested PHP extension zip is missing from your system.
    - Installation request for laravel/installer ^3.0 -> satisfiable by laravel/installer[v3.0.0, v3.0.1].

  To enable extensions, verify that they are enabled in your .ini files:
    - /etc/php.ini
    - /etc/php.d/20-bz2.ini
    - /etc/php.d/20-calendar.ini
    - /etc/php.d/20-ctype.ini
    - /etc/php.d/20-curl.ini
    - /etc/php.d/20-exif.ini
    - /etc/php.d/20-fileinfo.ini
    - /etc/php.d/20-ftp.ini
    - /etc/php.d/20-gettext.ini
    - /etc/php.d/20-iconv.ini
    - /etc/php.d/20-json.ini
    - /etc/php.d/20-mbstring.ini
    - /etc/php.d/20-mysqlnd.ini
    - /etc/php.d/20-pdo.ini
    - /etc/php.d/20-phar.ini
    - /etc/php.d/20-sockets.ini
    - /etc/php.d/20-sqlite3.ini
    - /etc/php.d/20-tokenizer.ini
    - /etc/php.d/30-mysqli.ini
    - /etc/php.d/30-pdo_mysql.ini
    - /etc/php.d/30-pdo_sqlite.ini
  You can also run `php --ini` inside terminal to see which files are used by PHP in CLI mode.

Installation failed, deleting ./composer.json.

試したこと

調べると下のサイトと同じエラーが発生していそうと思いました。下のエラーを参考に設定をしていました。
Laravelのインストールでエラー(the requested PHP extension zip is missing from your system.)

自分のサイトにもPHP-ZIPがインストールされていないのではと思いインストールしてみました

# yum -y install php-zip
読み込んだプラグイン:fastestmirror
インストール処理の設定をしています
Loading mirror speeds from cached hostfile
 * base: ftp.riken.jp
 * epel: www.ftp.ne.jp
 * extras: ftp.riken.jp
 * remi-safe: ftp.riken.jp
 * updates: ftp.riken.jp
一致したパッケージ php-common-5.3.3-50.el6_10.x86_64 はすでにインストールされています。更新を確認しています。
何もしません

やはりされているので、解決案に書いていたようにphp-zipのダウンロードに失敗しているのかと思う

# yum install --enablerepo=remi-php72 php-zip
読み込んだプラグイン:fastestmirror
インストール処理の設定をしています
Loading mirror speeds from cached hostfile
 * base: ftp.riken.jp
 * epel: www.ftp.ne.jp
 * extras: ftp.riken.jp
 * remi-php72: ftp.riken.jp
 * remi-safe: ftp.riken.jp
 * updates: ftp.riken.jp
remi-php72                                               | 3.0 kB     00:00     
remi-php72/primary_db                                    | 206 kB     00:00     
依存性の解決をしています
--> トランザクションの確認を実行しています。
---> Package php-pecl-zip.x86_64 0:1.15.5-1.el6.remi.7.2 will be インストール
--> 依存性の処理をしています: php(zend-abi) = 20170718-64 のパッケージ: php-pecl-zip-1.15.5-1.el6.remi.7.2.x86_64
--> 依存性の処理をしています: php(api) = 20170718-64 のパッケージ: php-pecl-zip-1.15.5-1.el6.remi.7.2.x86_64
--> 依存性解決を終了しました。
エラー: パッケージ: php-pecl-zip-1.15.5-1.el6.remi.7.2.x86_64 (remi-php72)
             要求: php(api) = 20170718-64
            インストール: php-common-7.3.8-1.el6.remi.x86_64 (@remi-php73)
                php(api) = 20180731-64
            利用可能: php-common-5.3.3-49.el6.x86_64 (base)
                php(api) = 20090626
            利用可能: php-common-5.3.3-50.el6_10.x86_64 (updates)
                php(api) = 20090626
            利用可能: php-common-7.2.24-1.el6.remi.x86_64 (remi-php72)
                php(api) = 20170718-64
            利用可能: php-common-7.2.25-1.el6.remi.x86_64 (remi-php72)
                php(api) = 20170718-64
エラー: パッケージ: php-pecl-zip-1.15.5-1.el6.remi.7.2.x86_64 (remi-php72)
             要求: php(zend-abi) = 20170718-64
            インストール: php-common-7.3.8-1.el6.remi.x86_64 (@remi-php73)
                php(zend-abi) = 20180731-64
            利用可能: php-common-5.3.3-49.el6.x86_64 (base)
                php(zend-abi) = 20090626
            利用可能: php-common-5.3.3-50.el6_10.x86_64 (updates)
                php(zend-abi) = 20090626
            利用可能: php-common-7.2.24-1.el6.remi.x86_64 (remi-php72)
                php(zend-abi) = 20170718-64
            利用可能: php-common-7.2.25-1.el6.remi.x86_64 (remi-php72)
                php(zend-abi) = 20170718-64
 問題を回避するために --skip-broken を用いることができません
 これらを試行できます: rpm -Va --nofiles --nodigest


これでもダウンロードができません。

その後、「yum install --enablerepo=remi-php72 php-zip エラー」で検索をかけたりしましたが、解決できそうなものはなくどうすればいいのかわからなくなりました。

お時間をお取りして申し訳ありません。よろしくお願いします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • 退会済みユーザー

    退会済みユーザー

    2019/12/13 14:30

    現在インストールされているPHPのバージョンを
    php -v
    で調べて下さい。

    キャンセル

  • musinbaru

    2019/12/13 15:50

    バージョンとパッケージを上に載せます

    キャンセル

回答 1

check解決した方法

0

解決できました。
自分のPHPのバージョンが7.3なのに7.2でダウンロードしていたのが間違いだったと思います。
Kosuke_Shibuyaさんのメッセージから、php -vで確認し、7.3であることを確認
その後 以下のコードに変更しました

yum install --enablerepo=remi-php73 php-zip


そしたら無事ダウンロードできました。

しかし、自分自身のパソコンではphp5.5とphp7.3がごっちゃになっており、上記コードを入力すると別のエラーが発生してしまいました。
なので、PHP自体を一度削除し、もう一度入れてみました。

もしバージョンを設定してもできない人は一度PHPの整理をした方がいいかと思います。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.61%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る