質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.12%

MySqlを8.0にバージョンアップしたらmysqlが起動できなくなりました。

解決済

回答 2

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 754

ryo12su29kel

score 26

MyCentOSを使っています。操作はputtyでしております。
MySqlを5.6から8.0に次の手順でバージョンアップしたら起動ができなくなりました。

1, リポジトリの追加

$ sudo rpm -e mysql-community-release

$ sudo rpm -ivh https://dev.mysql.com/get/mysql80-community-release-el6-1.noarch.rpm

2, MySqlの停止

$ sudo /etc/init.d/mysqld stop

3, MySqlのバックアップ

$ sudo cp -aR /var/lib/mysql/ /var/lib/mysql_bk/

4, MySqlのアップグレード

$ sudo yum update mysql-server

5, MySQLの起動

$ sudo /etc/init.d/mysqld start

最後の5の手順で

$ sudo /etc/init.d/mysqld start
MySQL Daemon failed to start.
mysqld を起動中:                                           [失敗]

となってしまいます。
試しに$ service mysqld restartも試してみたのですが

$ service mysqld restart
mysqld を停止中:                                           [  OK  ]
chown: `/var/lib/mysql' の所有権を変更中: 許可されていない操作です
chmod: changing permissions of `/var/lib/mysql': 許可されていない操作です
/usr/bin/mysqld_safe: line 144: /var/log/mysqld.log: 許可がありません
/usr/bin/mysqld_safe: line 144: /var/log/mysqld.log: 許可がありません
/usr/bin/mysqld_safe: line 199: /var/log/mysqld.log: 許可がありません
/usr/bin/mysqld_safe: line 144: /var/log/mysqld.log: 許可がありません
MySQL Daemon failed to start.
mysqld を起動中:                                           [失敗]

と出てきます。

$ sudo less /var/log/mysqld.log


としてみたところ

2019-11-15T21:33:53.865985Z 1 [ERROR] [MY-013090] [InnoDB] Unsupported redo log format (0). The redo log was created before MySQL 5.7.9
2019-11-15T21:33:53.866297Z 1 [ERROR] [MY-012930] [InnoDB] Plugin initialization aborted with error Generic error.
2019-11-15T21:33:54.285345Z 1 [ERROR] [MY-011013] [Server] Failed to initialize DD Storage Engine.
2019-11-15T21:33:54.285833Z 0 [ERROR] [MY-010020] [Server] Data Dictionary initialization failed.
2019-11-15T21:33:54.286356Z 0 [ERROR] [MY-010119] [Server] Aborting


というエラーログが出たので調べてみた結果、 /var/lib/mysql/ファイルのib_logfile0 と ib_logfile1がRedo logsなので消去しろとのことだったので実行しました。
その後にまた sudo service mysqld start を実行したら次のようなエラーログが出ました。

2019-11-15T22:28:51.776034Z 1 [ERROR] [MY-013168] [InnoDB] Cannot upgrade server earlier than 5.7 to 8.0
2019-11-15T22:28:56.780697Z 1 [ERROR] [MY-011013] [Server] Failed to initialize DD Storage Engine.
2019-11-15T22:28:56.781401Z 0 [ERROR] [MY-010020] [Server] Data Dictionary initialization failed.
2019-11-15T22:28:56.782225Z 0 [ERROR] [MY-010119] [Server] Aborting


このようになってしまった際の解決法をどなたかご存じでしたら宜しくお願いします。
バージョン自体はしっかりとアップグレードされているようです。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • ryo12su29kel

    2019/12/07 21:26 編集

    ありがとうございます。
    すみません、やり方を間違えていたようです。
    質問の中身を編集してログを追加しました。

    キャンセル

  • XNXSXMXR

    2019/12/07 23:20

    このエラーを経験していないので解決策をもっていないのですが、

    > [InnoDB] Unsupported redo log format (0). The redo log was created before MySQL 5.7.9

    なんかここらへんの文章をGoogleで検索してみてはいかがでしょうか?

    キャンセル

  • ryo12su29kel

    2019/12/08 00:11

    ありがとうございます。
    見つけた解決方法を試してみたらまた違ったエラーログが現れたので編集しました。

    キャンセル

回答 2

checkベストアンサー

0

Unsupported redo log format (0). The redo log was created before MySQL 5.7.9
Cannot upgrade server earlier than 5.7 to 8.0

ログからの推測にはなりますが、5.6→8.0のアップグレードはNGで、5.6→5.7→8.0の順にアップグレードするのが正しい手順なのではないでしょうか。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

0

2019-11-15T22:28:51.776034Z 1 [ERROR] [MY-013168] [InnoDB] Cannot upgrade server earlier than 5.7 to 8.0

この文章で検索すると、前バージョンのMySQLのファイルを消す方法がでてきますが、なかなか怖いですね。
また、エラーが発生するごとに対処法を調べることしかわかりません。

いったんダウングレードを行って必要なデータベースをバックアップをとり、再インストールを行うのはいかがでしょうか。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.12%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる