質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.92%

Windows上でRuby 2.4にRails 4.2が導入できない

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 463

ambiguous

score 8

初めての質問なので、不足がありましたらご容赦を。

現在、Windows上でRuby 2.4.5(Devkit) + Rails 4.2.11にて開発をしています。新たに同様の開発環境を構築しようとしたら下記メッセージが表示され、Rails4のインストールが完了しません。しかしながら、既に前述のバーションで動作しているプロダクトに対する機能追加であり、複数人で継続開発している関係上、RubyもRailsも現時点ではバージョンアップは出来ません。

何分初めてのRuby開発でして、以前は何のトラブルも無く構築できたものが何故今回はエラー(複数のVM等で確認しましたが、いずれも同様)になるのかや、Ruby + DevkitでインストールされたMSYS2とgemの関係などが良く判っておらず、ゆっくり調べる時間もスキルもなく困窮しています。

Ruby自体はrubyinstaller-devkit-2.4.5-1-x86を利用してインストールしています。


ERROR: Error installing rails:

sprockets requires Ruby version >= 2.5.0.

そこで...

(1)上記エラーが発生している理由
(2)バージョンはそのままで上記エラーを解消できる方法
(3)上記エラーを解決しなくても、他の開発環境にあるgem等を新たに構築した環境にコピーして利用可能にする方法

等、何かしら解決・回避に繋がる情報をお持ちの方がおられましたら教示いただけないでしょうか。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

+1

最新版のSprocketsはRuby 2.5以上の対応となっています。

Gemfileにgem 'sprockets', '~> 3.7'のように書き足して(あるいはすでにsprocketsのバージョン指定があるなら書き換えて)、Sprocketsを3系列で止めるようにしてみましょう。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/11/17 16:25

    度々ありがとうございます。仰るように先にsprocketsをインストールすることで、rails4のインストールまで辿り着けました。これで先に進めそうです。助かりました。

    今回の事象から、RubyInstaller内部にGemfileなり何かしらダウンロード対象のgemを指定する定義体があり、その一部にバージョンを明示していないgemの指定があることで、インストーラを実行する時期によりダウンロードされてくるgemのバージョンが異なると考えましたが『大凡』このような考えで合っていますでしょうか?

    だとしたら定点におけるgemのバージョンを定義/規定する場合、静的にダウンロード(もしくはその情報を保持)しそれを配布/利用する必要があると思うのですが、gemファイルはファイルシステムでコピーして持ってくれば済む話なのでしょうか?それともRubygemsのパッケージ管理データベースのようなものとの整合性がとれなくなるためGemfileを作成し、bundle install --path hogehogeする必要があるのでしょうか?

    キャンセル

  • 2019/11/17 16:31

    > だとしたら定点におけるgemのバージョンを定義/規定する場合

    なかなか難しい問題で、Bundler自体が2系列に上がってしまって動かない、という場合にはBundlerで事態を解決することができなくなってしまいます。手動でどうにかするほかない場面もありそうです。

    https://medium.com/ruffnote/bundler-2%E7%B3%BB%E3%81%97%E3%81%8B%E5%85%A5%E3%81%A3%E3%81%A6%E3%81%84%E3%81%AA%E3%81%8F%E3%81%A6%E6%97%A2%E5%AD%98%E3%82%A2%E3%83%97%E3%83%AA%E3%81%8Cbundle-install%E3%81%A7%E3%81%8D%E3%81%AA%E3%81%8B%E3%81%A3%E3%81%9F-dd03737d3866

    キャンセル

  • 2019/11/17 22:03

    URLありがとうござました。Bundler自身のバージョンにも左右されるのですね。
    来年度にはRuby 2.5に上げる必要がありそうなので、色々と勉強になりました。
    重ね重ねありがとうございました。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.92%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る