質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.97%

DockerfileでPHPの各種モジュールをインストールする時の警告表示を消したい

受付中

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 345

kurisan1623

score 16

問題

DockerfileでPHPの各種モジュールをインストールする時の警告表示を消したいです。
あまり気にすべきでないのかとは思いますが、気になるのでできれば警告を消したいです。
また、問題があれば指摘してくださると嬉しいです。

環境

Windows10 pro 1903
Docker Desktop for Windows

ソースと警告

FROM php:7.3-apache

COPY php.ini /usr/local/etc/php/

ENV DEBCONF_NOWARNINGS yes

RUN apt-get update && apt-get install -y --no-install-recommends \
        # mysql
        default-mysql-client \
        # intl
        libicu-dev \
        # gd
        libfreetype6-dev \
        libjpeg62-turbo-dev \
        libpng-dev \
        libwebp-dev \
        libxpm-dev \
        # zip
        libzip-dev \
        zlib1g-dev \
        # imagick
        libmagickwand-dev \
    # mysql
    && docker-php-ext-install pdo_mysql \
    # intl
    && docker-php-ext-install intl \
    # gd
    && docker-php-ext-install -j$(nproc) iconv \
    && docker-php-ext-configure gd --with-freetype-dir=/usr/include/ --with-jpeg-dir=/usr/include/ \
    && docker-php-ext-install -j$(nproc) gd \
    # zip
    && docker-php-ext-install zip \
    # imagick
    && pecl install imagick \
    && docker-php-ext-enable imagick \
    # mbstring
    && docker-php-ext-install mbstring \
    # opcache
    && docker-php-ext-install opcache \
    # Apache & clean
    && a2enmod rewrite \
    && apt-get clean \
    && rm -rf /var/lib/apt/lists/*

# composer
RUN curl -sS https://getcomposer.org/installer | php -- --install-dir=/usr/local/bin --filename=composer
/usr/src/php/ext/mbstring/oniguruma/src/regparse.c: In function 'onig_scan_unsigned_number':
/usr/src/php/ext/mbstring/oniguruma/src/regparse.c:403:29: warning: assignment discards 'const' qualifier from pointer target type [-Wdiscarded-qualifiers]
   if(UNEXPECTED(p > end)) p = end; \
                             ^
/usr/src/php/ext/mbstring/oniguruma/src/regparse.c:3332:5: note: in expansion of macro 'PFETCH'
     PFETCH(c);
warning: mbstring (mbstring.so) is already loaded!

iconv already loaded!みたいなのもあったとおもいます・・・(消えた

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

0

ごめんなさい。以下はphpの実行時の物なので完全に間違いです。


php.inierror_reportingの値を変更してください。

値は以下を参考にしてください。

(php.net)error_reporting
(Qiita)PHPのエラー表示設定について

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/09/27 23:49

    回答ありがとうございます!
    お気になさらないでください。確かに紛らわしい質問なので・・

    キャンセル

  • 2019/09/27 23:55

    > xxxx already loaded!
    に関しては、php.iniに複数行ありませんか?

    キャンセル

  • 2019/09/28 00:20

    iniやconfのような設定ファイルはとりあえず抜いたまま試験的にコンテナ作っているのでわからないですが、インストールコマンド実行で自動でなにかされてる可能性が高いです。。
    && docker-php-ext-install mbstring \
    の行を抜いてコンテナを作ればインストールもされませんが警告もでないのです。。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.97%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる