質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
87.20%
Ruby

Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

Ruby on Rails

Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

ImageMagick

ImageMagickとは、画像の表示や操作を行うオープンソースのソフトウェアです。プログラムはCで書かれており、GIFやJPEG、PDFなど画像ファイルフォーマット100種類以上に対応しています。

解決済

rails sをやるとRMagick2.soでエラーを吐く

削除済ユーザー
削除済ユーザー

総合スコア0

Ruby

Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

Ruby on Rails

Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

ImageMagick

ImageMagickとは、画像の表示や操作を行うオープンソースのソフトウェアです。プログラムはCで書かれており、GIFやJPEG、PDFなど画像ファイルフォーマット100種類以上に対応しています。

1回答

0評価

0クリップ

1269閲覧

投稿2019/08/19 07:06

rails sをやると以下のエラーを吐きます

imagemagickのバージョンは 6.9.2-7 Q16 x64
rmagickのバージョンは 2.16.0
rubyのバージョンは ruby 2.6.3です

私の予想ではRMagick2.so というファイルに問題があると思ったのですがファイル自体は存在しました。どのようにすれば解決できるのかわかりません。分かる方がいましたら、よろしくお願いいたします。


Traceback (most recent call last):
29: from bin/rails:4:in <main>' 28: from bin/rails:4:in require'
27: from C:/Program Files/Ruby26-x64/lib/ruby/gems/2.6.0/gems/railties-5.2.2/lib/rails/commands.rb:18:in <top (required)>' 26: from C:/Program Files/Ruby26-x64/lib/ruby/gems/2.6.0/gems/railties-5.2.2/lib/rails/command.rb:46:in invoke'
25: from C:/Program Files/Ruby26-x64/lib/ruby/gems/2.6.0/gems/railties-5.2.2/lib/rails/command/base.rb:65:in perform' 24: from C:/Program Files/Ruby26-x64/lib/ruby/gems/2.6.0/gems/thor-0.20.3/lib/thor.rb:387:in dispatch'
23: from C:/Program Files/Ruby26-x64/lib/ruby/gems/2.6.0/gems/thor-0.20.3/lib/thor/invocation.rb:126:in invoke_command' 22: from C:/Program Files/Ruby26-x64/lib/ruby/gems/2.6.0/gems/thor-0.20.3/lib/thor/command.rb:27:in run'
21: from C:/Program Files/Ruby26-x64/lib/ruby/gems/2.6.0/gems/railties-5.2.2/lib/rails/commands/server/server_command.rb:142:in perform' 20: from C:/Program Files/Ruby26-x64/lib/ruby/gems/2.6.0/gems/railties-5.2.2/lib/rails/commands/server/server_command.rb:142:in tap'
19: from C:/Program Files/Ruby26-x64/lib/ruby/gems/2.6.0/gems/railties-5.2.2/lib/rails/commands/server/server_command.rb:145:in block in perform' 18: from C:/Program Files/Ruby26-x64/lib/ruby/gems/2.6.0/gems/railties-5.2.2/lib/rails/commands/server/server_command.rb:145:in require'
17: from C:/waaq_project/first/assistant/config/application.rb:19:in <top (required)>' 16: from C:/Program Files/Ruby26-x64/lib/ruby/2.6.0/bundler.rb:114:in require'
15: from C:/Program Files/Ruby26-x64/lib/ruby/2.6.0/bundler/runtime.rb:65:in require' 14: from C:/Program Files/Ruby26-x64/lib/ruby/2.6.0/bundler/runtime.rb:65:in each'
13: from C:/Program Files/Ruby26-x64/lib/ruby/2.6.0/bundler/runtime.rb:76:in block in require' 12: from C:/Program Files/Ruby26-x64/lib/ruby/2.6.0/bundler/runtime.rb:76:in each'
11: from C:/Program Files/Ruby26-x64/lib/ruby/2.6.0/bundler/runtime.rb:81:in block (2 levels) in require' 10: from C:/Program Files/Ruby26-x64/lib/ruby/2.6.0/bundler/runtime.rb:81:in require'
9: from C:/Program Files/Ruby26-x64/lib/ruby/gems/2.6.0/gems/rmagick-2.16.0/lib/rmagick.rb:1:in <top (required)>' 8: from C:/Program Files/Ruby26-x64/lib/ruby/gems/2.6.0/gems/activesupport-5.2.2/lib/active_support/dependencies.rb:291:in require'
7: from C:/Program Files/Ruby26-x64/lib/ruby/gems/2.6.0/gems/activesupport-5.2.2/lib/active_support/dependencies.rb:257:in load_dependency' 6: from C:/Program Files/Ruby26-x64/lib/ruby/gems/2.6.0/gems/activesupport-5.2.2/lib/active_support/dependencies.rb:291:in block in require'
5: from C:/Program Files/Ruby26-x64/lib/ruby/gems/2.6.0/gems/activesupport-5.2.2/lib/active_support/dependencies.rb:291:in require' 4: from C:/Program Files/Ruby26-x64/lib/ruby/gems/2.6.0/gems/rmagick-2.16.0/lib/rmagick_internal.rb:12:in <top (required)>'
3: from C:/Program Files/Ruby26-x64/lib/ruby/gems/2.6.0/gems/activesupport-5.2.2/lib/active_support/dependencies.rb:291:in require' 2: from C:/Program Files/Ruby26-x64/lib/ruby/gems/2.6.0/gems/activesupport-5.2.2/lib/active_support/dependencies.rb:257:in load_dependency'
1: from C:/Program Files/Ruby26-x64/lib/ruby/gems/2.6.0/gems/activesupport-5.2.2/lib/active_support/dependencies.rb:291:in block in require' C:/Program Files/Ruby26-x64/lib/ruby/gems/2.6.0/gems/activesupport-5.2.2/lib/active_support/dependencies.rb:291:in require': 126: 指定されたモジュールが見つ かりません。 - C:/Program Files/Ruby26-x64/lib/ruby/gems/2.6.0/gems/rmagick-2.16.0/lib/RMagick2.so (LoadError)


良い質問の評価を上げる

以下のような質問は評価を上げましょう

  • 質問内容が明確
  • 自分も答えを知りたい
  • 質問者以外のユーザにも役立つ

評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

気になる質問をクリップする

クリップした質問は、後からいつでもマイページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

  • プログラミングに関係のない質問
  • やってほしいことだけを記載した丸投げの質問
  • 問題・課題が含まれていない質問
  • 意図的に内容が抹消された質問
  • 過去に投稿した質問と同じ内容の質問
  • 広告と受け取られるような投稿

評価を下げると、トップページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

まだ回答がついていません

会員登録して回答してみよう

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
87.20%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問

同じタグがついた質問を見る

Ruby

Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

Ruby on Rails

Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

ImageMagick

ImageMagickとは、画像の表示や操作を行うオープンソースのソフトウェアです。プログラムはCで書かれており、GIFやJPEG、PDFなど画像ファイルフォーマット100種類以上に対応しています。