質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.92%

Error("The bootstrap modal plugin does not appear to be loaded.")を解消したい。

解決済

回答 3

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 1,173

score 11

前提・実現したいこと

gem 'data-confirm-modal'を用いてダイアログのデザインが反映されません。
デバッグすると、以下エラーが発生しています。

発生している問題・エラーメッセージ

Uncaught Error: The bootstrap modal plugin does not appear to be loaded.

エラーとなっているjqueryのソースコード

2箇所あります。

(1)at data-confirm-modal.self-(省略).js?body=1:96

// Detect bootstrap version, or bail out.//
  if ($.fn.modal == undefined) {
    throw new Error("The bootstrap modal plugin does not appear to be loaded.");
  }

(2)at data-confirm-modal.self-(省略).js?body=1:96

})(jQuery);

ソースコードについて

使用したgem

gem 'bootstrap-sass'
gem 'jquery-rails'
gem 'data-confirm-modal'


bundle後のgemlistを表示
対象と思われるファイルを抜粋

bootsnap (1.4.4, 1.4.3, 1.4.1, 1.3.2)
bootstrap (4.3.1, 4.1.3)
bootstrap-sass (3.4.1)

data-confirm-modal (1.6.2)
jquery-rails (4.3.5, 4.3.3)
jquery-turbolinks (2.1.0)
jquery-ui-rails (6.0.1)

rails側の設定

記述内容を全て抜粋
app/assets/stylesheets/application.scss

@import "bootstrap-sprockets";
@import "bootstrap";
@import 'font-awesome';
@import 'setting/reset';
@import "rouge/highlight";
@import "toppage/footer";
@import "toppage/header";
@import "toppage/main";
@import "toppage/footer";
@import "from/from";
@import "setting/flash";
@import "item-show/show";
@import "item-show/comment-list";
@import "mypage/users"; 
@import "flag/flags"

記述内容を全て抜粋
app/assets/javascripts/application.js

//= require activestorage
//= require jquery
//= require rails-ujs
//= require data-confirm-modal
//= require_tree .

記述内容を全て抜粋
app/views/layouts/application.html.haml

%html
  %head
    %meta{:content => "text/html; charset=UTF-8", "http-equiv" => "Content-Type"}/
    %title RubyLike
    = csrf_meta_tags
    = csp_meta_tag
    = stylesheet_link_tag    'application', media: 'all'
    = javascript_include_tag 'application', 'data-turbolinks-track': 'reload'
  %body
    = render './layouts/header'
    = yield
    = render './layouts/footer'

現状の動作

デザイン変更できていない。デバッグすると表題のエラーが表示されている。

https://i.gyazo.com/f2de0a2d486e6760b2ae247df7741732.gif
Image from Gyazo

バージョンと環境

環境 開発環境
バージョン Rails 5.2.3

試した事

(1)bootstrapをうまく読み込めているかどうか?

bootstrapを使用しているクラス名にcssが反映されているか確認した。
反映されている。

/* line 30, /Users/ユーザー名/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/bootstrap-sass-3.4.1/assets/stylesheets/bootstrap/_grid.scss */
.container-fluid {
  padding-right: 15px;
  padding-left: 15px;
  margin-right: auto;
  margin-left: auto;

(2)jqueryが使えるかどうか?

簡単なコードを記入して試してみた。

以下コードを記述。色の変化を確認。
app/view/layouts/application.html.haml

%h1 Ajax#index
%p#hoge 赤色になるよ
:javascript
  $("#hoge").css("color","red")

(3)rails s の再起動

変化なし

以上、エラーに対しての対応策がわかりません。ご教授頂ければと思います。よろしくお願いいたいます。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 3

checkベストアンサー

+1

エラーが発生しているのは下記の部分という事だと思います。

  if ($.fn.modal == undefined) {
    throw new Error("The bootstrap modal plugin does not appear to be loaded.");
  }

このメッセージが起きた直接の原因は、$.fn.modal == undefined というIF文の条件が成り立った事ですから、$.fn.modal が undefinedのまま放置されたまま、問題のコードに迄達したのかを追っていくのがデバッグの手段として適切だと思われます。

質問には、$.fn.modal が何なのかを推測できるだけのコードも説明もありませんので、アドバイスできる方は少ないと思います。

エラーが起きた箇所周辺のコードを質問に追加することをお勧めします。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

0

解決しました。 
うまく読み込めていない事にシンプルに気づきました。

結論

requireされていなかった。

app/aseets/javascripts/application.js

//= require bootstrap-sprockets

実施した事

(1)bootstrapのバージョンが古いので、変更した

変更前
gem bootstrap-sass
変更後
gem 'bootstrap'

(2)読み込んでいないデーターを読み込ませた。

app/aseets/javascripts/application.js

//= require bootstrap-sprockets

変更した箇所の記載

app/aseets/javascripts/application.js

//= require activestorage
//= require jquery
//= require bootstrap-sprockets #追加
//= require rails-ujs
//= require data-confirm-modal
//= require_tree .

参考にした記事

https://qiita.com/NaokiIshimura/items/c8db09daefff5c11dadf

https://qiita.com/kamishun/items/b529a14cab39291b5910

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

0

自己解決しました。ご回答ありがとうございました!

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.92%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る