質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.12%

Node Sass がサポートしている環境を知りたい

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 1,592

AkihiroIshii

score 63

質問内容

背景

yarn で package.json に記載した script を実行したらエラーがでました。エラーには、「node sass がお使いの環境(Mac OS X)でサポートされていない」とあります。github(※1)を参照するように書いてありました。

(※1)参照するgithubのページ
https://github.com/sass/node-sass/releases/tag/v4.10.0

わからないこと

上記のgithubのページを見たのですが、サポート対象か否かがわかりませんでした(github に不慣れです)。
具体的には、参照先の表「Supported Environments」の内容が、実行環境に適しているのかを知りたいです。

環境
  • Mac OS High Sierra 10.13.6
  • yarn 1.16.0
  • node-sass 4.12.0(Wrapper)[JavaScript]
  • libsass 3.5.4(Sass Compiler)[C/C++]

補足情報

ターミナルで実行したコマンド
$yarn run build-css
エラーメッセージ
Error: Node Sass does not yet support your current environment: OS X 64-bit with Unsupported runtime (72)
For more information on which environments are supported please see:
https://github.com/sass/node-sass/releases/tag/v4.10.0
package.json の内容

実行したいのは、下記の build-css です。

{
  "name": "html_advance",
  "version": "1.0.0",
  "description": "",
  "main": "index.js",
  "scripts": {
    "build-css": "node-sass --include-path scss scss/style.scss css/style.css",
    "watch-css": "nodemon -e scss -x \"npm run build-css\""
  },
  "author": "",
  "license": "ISC",
  "devDependencies": {
    "node-sass": "^4.9.4",
    "nodemon": "^1.18.4"
  }
}
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • CHERRY

    2019/06/05 23:08

    Node.js のバージョンはいくつですか?

    キャンセル

  • AkihiroIshii

    2019/06/05 23:14

    v12.4.0だと思います($node --version で確認しました)。

    キャンセル

  • AkihiroIshii

    2019/06/07 09:11

    再試行したらエラーがでなくなりました。治ったタイミングが不明ですが、PC再起動などでしょうか。。
    直面していた問題は解決しましたが、Githubの表「Supported Environments」の味方については、後学のために知りたいです。
    ご教示いただける方がいらっしゃいましたら、よろしくお願いします。

    キャンセル

回答 1

checkベストアンサー

+1

参照先の表「Supported Environments」の内容が、実行環境に適しているのかを知りたい

質問文にあるv4.10.0のページにおいては、MacOS(OSX)の行を見ると対応しているNodeのバージョンが「0.10, 0.12, 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11」と書いてあるので、v12は対応していません。

再試行したらエラーがでなくなりました

おそらくnpm installyarn installを再度実行し、package.jsonで"node-sass": "^4.9.4"と指定しているので、4.xの中で一番新しい4.12.0がインストールされたからではないでしょうか。4.12.0はnode.js 12をサポートしているようです。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/06/07 15:07

    node-sassのバージョンだけ気にしていたため、表の「Node」を Node.js 自体のバージョンと捉えることができておりませんでした。表の見方について理解できました。
    package.jsonも自分で用意せず勉強不足でした。バージョンの指定方法(キャレット表記)についても調べて理解しました。ありがとうございます。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.12%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる