Maven springboot pom.xmlエラー

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 1,321

Inukai.1192

score 10

エクリプス
ファイル→新規→Springスタータプロジェクト→下記のライブラリを追加して新規プロジェクトを立ち上げると
必ず、pom.xmlがエラーになります。
pom.xmlの概要を見ると不明なエラーと書いてあり解決方法がわかりません。

追加しているライブラリは、 Devtool,LombookH2,JDBC,Thymeleaf,Webです。
pom.xmlの内容がこちらになります。
よろしくお願いいたします。

<?xml version="1.0" encoding="UTF-8"?>
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
<groupId>org.springframework.boot</groupId>
<artifactId>spring-boot-starter-parent</artifactId>
<version>2.1.5.RELEASE</version>
<relativePath/> <!-- lookup parent from repository -->
</parent>
<groupId>com.example</groupId>
<artifactId>SpringSample</artifactId>
<version>0.0.1-SNAPSHOT</version>
<name>SpringSample</name>
<description>Demo project for Spring Boot</description>

<properties>
<java.version>1.8</java.version>
</properties>

<dependencies>
<dependency>
<groupId>org.springframework.boot</groupId>
<artifactId>spring-boot-starter-jdbc</artifactId>
</dependency>
<dependency>
<groupId>org.springframework.boot</groupId>
<artifactId>spring-boot-starter-thymeleaf</artifactId>
</dependency>
<dependency>
<groupId>org.springframework.boot</groupId>
<artifactId>spring-boot-starter-web</artifactId>
</dependency>

<dependency>
<groupId>org.springframework.boot</groupId>
<artifactId>spring-boot-devtools</artifactId>
<scope>runtime</scope>
</dependency>
<dependency>
<groupId>com.h2database</groupId>
<artifactId>h2</artifactId>
<scope>runtime</scope>
</dependency>
<dependency>
<groupId>org.projectlombok</groupId>
<artifactId>lombok</artifactId>
<optional>true</optional>
</dependency>
<dependency>
<groupId>org.springframework.boot</groupId>
<artifactId>spring-boot-starter-test</artifactId>
<scope>test</scope>
</dependency>
</dependencies>

<build>
<plugins>
<plugin>
<groupId>org.springframework.boot</groupId>
<artifactId>spring-boot-maven-plugin</artifactId>
</plugin>
</plugins>
</build>

</project>

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • rubytomato

    2019/05/25 21:53

    Alt + F5キーを押して「Update Maven Project」画面を開き、当該のプロジェクトを選択してOKボタンを押してエラーが解消するか確認してみてください。

    キャンセル

  • Inukai.1192

    2019/05/26 10:45

    回答ありがとございます。
    Alt + F5ではエラー解決されませんせんでした。

    キャンセル

回答 1

checkベストアンサー

+1

pom.xml の1行目にエラーが表示されていますでしょうか。
だとすれば、おそらくこちらのバグに該当しているのではないかと思われます。
https://bugs.eclipse.org/bugs/show_bug.cgi?id=547340#c9

Eclipse のメニューから Help -> Check for Updates と進み、最新の m2e connector をインストールすることで解消するようです。

私の環境でも試してみたところ、同じく1行目で不明なエラーが表示されていましたが、プラグインをアップデートすることで解消しました。

参考)
https://stackoverflow.com/questions/56142369/why-am-i-getting-unknown-error-in-line-1-of-pom-xml

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/05/26 15:33

    回答ありがとうございます。
    上記のとうりにやってみた所、今度は別のエラーが発生しました。
    エラーが下記の内容になります。


    サイトがいくつか見つかりませんでした。 詳細については、エラー・ログを参照してください。
    http://www.pramati.com/downloads/eclipse/updates/ のリポジトリーが見つかりません。
    http://public.dhe.ibm.com/ibmdl/export/pub/software/websphere/wasdev/updates/bluemixAdapter/oxygen/ のリポジトリーが見つかりません。
    jar:file:/C:/Users/user/Downloads/net.sf.eclipse.tomcat.updatesite-2018-03-08.zip!/ のリポジトリーが見つかりません。

    キャンセル

  • 2019/05/26 20:11

    おそらく問題としては別件だと思いますので、新しく質問を立てるのがよいかと思います。
    私も何かわかれば回答します。

    キャンセル

  • 2019/05/27 00:05

    アドバイスありがとうございます。
    どうにもならなさそうなので、新しく質問たてました。

    キャンセル

  • 2019/06/03 00:17

    Check for Updates と進み、最新の m2e connector をインストールすることで解消できました。ありがとうございます。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.21%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る