質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.81%

ruby on rails : bundle installでエラー

受付中

回答 0

投稿

  • 評価
  • クリップ 1
  • VIEW 730

dxo

score 15

bundle installでエラーが貼ってしてしまいます。

バージョン
Ruby on Rails 5
ruby 2.2.5

エラー内容

Installing ffi 1.9.23 with native extensions
Gem::Ext::BuildError: ERROR: Failed to build gem native extension.

    /Users/*********/.rbenv/versions/2.2.5/bin/ruby -r ./siteconf20190511-19792-10sjohh.rb extconf.rb --use-system-libraries
checking for ffi.h... no
checking for ffi.h in /usr/local/include,/usr/include/ffi... yes
checking for ffi_call() in -lffi... yes
checking for ffi_closure_alloc()... no
checking for ffi_raw_call()... no
checking for shlwapi.h... no
checking for rb_thread_blocking_region()... no
checking for rb_thread_call_with_gvl()... yes
checking for rb_thread_call_without_gvl()... yes
creating extconf.h
creating Makefile

make "DESTDIR=" clean

make "DESTDIR="
/bin/sh: -c: line 0: unexpected EOF while looking for matching `"' /bin/sh: -c: line 1: syntax error: unexpected end of file make: * ["/Users/***********/Box] Error 2

make failed, exit code 2

Gem files will remain installed in /Users/*********/Box Sync/*********/vendor/bundle/ruby/2.2.0/gems/ffi-1.9.23 for inspection. Results logged to /Users/*********/Box Sync/*********/vendor/bundle/ruby/2.2.0/extensions/x86_64-darwin-16/2.2.0-static/ffi-1.9.23/gem_make.out

An error occurred while installing ffi (1.9.23), and Bundler cannot continue. Make sure that gem install ffi -v '1.9.23' succeeds before bundling.

In Gemfile:   bootstrap-sass was resolved to 3.3.7, which depends on     sass was resolved to 3.5.6, which depends on       sass-listen was resolved to 4.0.0, which depends on         rb-inotify was resolved to 0.9.10, which depends on           ffi admin:hoge admin$ 

試したこと

gem install ffi -v '1.9.23'bundle install

https://qiita.com/motty93/items/29e22c6bf811f8dd00ab

大変詰まっている状況です。何をすれば解決するのかご教授お願い致します!!

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正の依頼

  • sola-msr

    2019/05/11 21:48

    開発環境などの詳細な情報も載せたほうが回答されやすいかなと
    例えばOSだとかも回答者にとって重要な情報です

    キャンセル

  • ryochin

    2019/05/12 11:23

    Box Sync という文字列が見えますが、なにかクラウドと同期するようなディレクトリで実行されているのでしょうか。環境について詳述願います。

    キャンセル

まだ回答がついていません

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.81%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る