質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.58%

PostgresとApacheの連携ができない

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 1
  • VIEW 2,409

score 13

前提・実現したいこと

PHPでPostgresを使えるようにしたい

発生している問題・エラーメッセージ

PHPでPostgresを使いたいと思い、php.iniファイルの970行目辺りの
;extension=php_pgsql.dll
のコメントアウトを外し、xampp-control.exeを起動し、いつものようにStartボタンを押したところ、
一瞬「Runnning」になり、すぐに終了してしまいます。
以下のようなLogが出ているのですが、エラーは見受けられません。

[apache]     Starting apache service...
[apache]     Status change detected: running
[apache]     Status change detected: stopped

Logファイルも参照しましたが、

[warn] pid file C:/softs/pleiades/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[notice] Digest: generating secret for digest authentication ...
[notice] Digest: done

となり、解決に直結するエラーは見受けられませんでした。

試したこと

・Skypeの使用ポート確認
Skypeをインストールしていません。

・ポート変更
httpd.confのListenとServerNameをともに8080にしたが変化なし。

・環境変数
環境変数もPathの編集からC:\softs\pleiades\xampp\phpを入力してあります。

補足情報(FW/ツールのバージョンなど)

PHP Version 5.3.8
Apache/2.2.21 (Win32)
XAMPP 1.7.7

です。
よろしくおねがいします。

追記情報

会社で使用しています

・Postgresについて
PostgresはCentOSにてインストールされているそうです。
DBはすでに構築してあり、他の社員は接続できています。
私も、SQL開発ツールのA5SQLでDB(Postgres)へ接続し、中身の閲覧はできています。

・今までについて
PHPとDB(Postgres)を使用した仕事に参加することになったので、環境構築を行っております。
それまでPHPは遊び程度で、DBとの接続はしておりませんでした。

・php_pgsql.dllについて
php_pgsql.dllの所在はC:\softs\pleiades\xampp\php\extにあることが確認できています。
そこで必要になるであろう、libpq.dllの所在もC:\softs\pleiades\xampp\php にて確認できています。

・Eclipseについて
(バージョンが古いのは)仕事の環境に合わせるためです。
Eclipse 3.7 Indigo をダウンロードし、そこに同梱されている、XAMPPを使用しています。

・よくわからない
xampp_start.exeを実行すると、localhostに接続することができるようになりました。
Postgresの関数も使用でき、アクセスできるようになりました。
もちろんこのexeを閉じると、接続できなくなります。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • yuba99

    2019/01/25 16:32

    閲覧ありがとうございます。
    質問に追記いたしました。

    キャンセル

  • m.ts10806

    2019/01/25 17:37

    サーバー実行中じゃないとphp実行できないのは当たり前と言えば当たり前ですが、そもそもXAMPPはEclipse同梱のものを使われているということですか?

    キャンセル

  • yuba99

    2019/01/25 17:41

    そうですね、Eclipseに同梱されていたXAMPPを使用しました。
    同梱されていたものがだめだった可能性を考えて、同じバージョンのXAMPPをダウンロードしましたが、同じ結果でした。

    キャンセル

回答 1

checkベストアンサー

+1

apacheのhttpd-xampp.confで

LoadFile "C:/xampp71/php/libpq.dll"


みたいなのは書いてあるかな?

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/01/28 09:55

    ご回答ありがとうございます!
    こちらの方法で解決いたしました!

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.58%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る