質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.87%

HerokuでのApplication Errorについて

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 514

penguin123

score 9

HerokuでのApplication Errorについて

cloud9を使用してherokuにgitからpushでデプロイしたところ以下のエラーが出ました。
cloud9上では正常に作動するのですが、Heroku上ではApplication Errorが発生します。

Herokuのrestartなども試したのですが、原因がわからないです。

heroku logで出たエラーコードは下のとおりです。

at=error code=H10 desc="App crashed" method=GET path="/" dyno= connect= service= status=503 bytes= protocol=https

一応、logを貼っておきます。

app[web.1]: /app/config.ru:4:in `block in <main>'
app[web.1]: /app/vendor/bundle/ruby/2.4.0/gems/rack-2.0.5/lib/rack/builder.rb:55:in `instance_eval'
app[web.1]: /app/vendor/bundle/ruby/2.4.0/gems/rack-2.0.5/lib/rack/builder.rb:55:in `initialize'
app[web.1]: /app/config.ru:in `new'
app[web.1]: /app/config.ru:in `<main>'
app[web.1]: /app/vendor/bundle/ruby/2.4.0/gems/rack-2.0.5/lib/rack/builder.rb:49:in `eval'
app[web.1]: /app/vendor/bundle/ruby/2.4.0/gems/rack-2.0.5/lib/rack/builder.rb:49:in `new_from_string'
app[web.1]: /app/vendor/bundle/ruby/2.4.0/gems/rack-2.0.5/lib/rack/builder.rb:40:in `parse_file'
app[web.1]: /app/vendor/bundle/ruby/2.4.0/gems/rack-2.0.5/lib/rack/server.rb:319:in `build_app_and_options_from_config'
app[web.1]: /app/vendor/bundle/ruby/2.4.0/gems/rack-2.0.5/lib/rack/server.rb:219:in `app'
app[web.1]: /app/vendor/bundle/ruby/2.4.0/gems/rack-2.0.5/lib/rack/server.rb:354:in `wrapped_app'
app[web.1]: /app/vendor/bundle/ruby/2.4.0/gems/rack-2.0.5/lib/rack/server.rb:283:in `start'
app[web.1]: /app/vendor/bundle/ruby/2.4.0/gems/rack-2.0.5/lib/rack/server.rb:148:in `start'
app[web.1]: /app/vendor/bundle/ruby/2.4.0/gems/rack-2.0.5/bin/rackup:4:in `<top (required)>'
app[web.1]: /app/vendor/bundle/ruby/2.4.0/bin/rackup:23:in `load'
app[web.1]: /app/vendor/bundle/ruby/2.4.0/bin/rackup:23:in `<top (required)>'
heroku[web.1]: Starting process with command `bundle exec rackup config.ru -p 21185`
heroku[web.1]: State changed from starting to crashed
heroku[web.1]: Process exited with status 1
app[web.1]: bundler: failed to load command: rackup (/app/vendor/bundle/ruby/2.4.0/bin/rackup)
app[web.1]: LoadError: cannot load such file -- sqlite3
app[web.1]: /app/vendor/bundle/ruby/2.4.0/gems/activesupport-5.2.1/lib/active_support/dependencies.rb:287:in `require'
app[web.1]: /app/vendor/bundle/ruby/2.4.0/gems/activesupport-5.2.1/lib/active_support/dependencies.rb:287:in `block in require'
app[web.1]: /app/vendor/bundle/ruby/2.4.0/gems/activesupport-5.2.1/lib/active_support/dependencies.rb:253:in `load_dependency'
app[web.1]: /app/vendor/bundle/ruby/2.4.0/gems/activesupport-5.2.1/lib/active_support/dependencies.rb:287:in `require'
app[web.1]: /app/app.rb:5:in `<top (required)>'
app[web.1]: /app/vendor/bundle/ruby/2.4.0/gems/activesupport-5.2.1/lib/active_support/dependencies.rb:287:in `require'
app[web.1]: /app/vendor/bundle/ruby/2.4.0/gems/activesupport-5.2.1/lib/active_support/dependencies.rb:287:in `block in require'
app[web.1]: /app/vendor/bundle/ruby/2.4.0/gems/activesupport-5.2.1/lib/active_support/dependencies.rb:253:in `load_dependency'
app[web.1]: /app/vendor/bundle/ruby/2.4.0/gems/activesupport-5.2.1/lib/active_support/dependencies.rb:287:in `require'
app[web.1]: /app/config.ru:4:in `block in <main>'
app[web.1]: /app/vendor/bundle/ruby/2.4.0/gems/rack-2.0.5/lib/rack/builder.rb:55:in `instance_eval'
app[web.1]: /app/vendor/bundle/ruby/2.4.0/gems/rack-2.0.5/lib/rack/builder.rb:55:in `initialize'
app[web.1]: /app/config.ru:in `new'
app[web.1]: /app/config.ru:in `<main>'
app[web.1]: /app/vendor/bundle/ruby/2.4.0/gems/rack-2.0.5/lib/rack/builder.rb:49:in `eval'
app[web.1]: /app/vendor/bundle/ruby/2.4.0/gems/rack-2.0.5/lib/rack/builder.rb:49:in `new_from_string'
app[web.1]: /app/vendor/bundle/ruby/2.4.0/gems/rack-2.0.5/lib/rack/builder.rb:40:in `parse_file'
app[web.1]: /app/vendor/bundle/ruby/2.4.0/gems/rack-2.0.5/lib/rack/server.rb:319:in `build_app_and_options_from_config'
app[web.1]: /app/vendor/bundle/ruby/2.4.0/gems/rack-2.0.5/lib/rack/server.rb:219:in `app'
app[web.1]: /app/vendor/bundle/ruby/2.4.0/gems/rack-2.0.5/lib/rack/server.rb:354:in `wrapped_app'
app[web.1]: /app/vendor/bundle/ruby/2.4.0/gems/rack-2.0.5/lib/rack/server.rb:283:in `start'
app[web.1]: /app/vendor/bundle/ruby/2.4.0/gems/rack-2.0.5/lib/rack/server.rb:148:in `start'
app[web.1]: /app/vendor/bundle/ruby/2.4.0/gems/rack-2.0.5/bin/rackup:4:in `<top (required)>'
app[web.1]: /app/vendor/bundle/ruby/2.4.0/bin/rackup:23:in `load'
app[web.1]: /app/vendor/bundle/ruby/2.4.0/bin/rackup:23:in `<top (required)>'
app[api]: Starting process with command `bundle exec rake db:migrate` by user win2do8se1@outlook.jp
2018-12-25T10:42:34.793125+00:00 heroku[run.3200]: Awaiting client
2018-12-25T10:42:34.814935+00:00 heroku[run.3200]: Starting process with command `bundle exec rake db:migrate`
heroku[run.3200]: State changed from starting to up
heroku[run.3200]: State changed from up to complete
heroku[run.3200]: Process exited with status 0
heroku[router]: at=error code=H10 desc="App crashed" method=GET path="/" host=cryptic-caverns-64134.herokuapp.com request_id=7af92fc9-48ec-4d33-b457-82a3a3272e62 fwd="121.86.132.138" dyno= connect= service= status=503 bytes= protocol=https

よろしくお願いします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

下記サイトを参照してみてはいかがでしょうか?
https://qiita.com/masarusan24/items/77d064147a32169b5449

僕も同じエラーに遭遇しましたが、こちらで解決しました。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/12/26 13:52

    回答ありがとうございます。

    bundler: failed to load command: rackup (/app/vendor/bundle/ruby/2.4.0/bin/rackup)

    LoadError: cannot load such file -- sqlite3
    が発生していて解決方法を教えていただければありがたいです

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.87%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる