質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.34%

Rails内の、bundle installしたGemへの参照先PATHのありかを探しています

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 231

nimbus1978

score 14

rails 4.1.4 ruby 2.2.0の環境において、vendor/bundle内にあるgem群を整理したいと思い、直接 rm -rf し消した後に bundle install し直しました。

元々は、 vendor/bundle/ruby/2.1.0 と vendor/bundle/ruby/2.2.0 がありましたが、再インストール後は 2.2.0のみになりました。

その後HPのindexを表示できなくなりましたので ログを調べたところ

18n::InvalidLocaleData (can not load translations from /hoge/vendor/bundle/ruby/2.1.0/gems/activesupport4.1.4/lib/active_support/locale/en.yml: 
Errno::ENOENT: そのようなファイルやディレクトリはありません @ rb_sysopen - /hoge/vendor/bundle/ruby/2.1.0/gems/activesupport-4.1.4/lib/active_support/locale/en.yml>):
app/controllers/application_controller.rb:46:in `set_locale'

というエラーがあり、 rails が vendor/bundle/ruby/2.1.0 内を参照していることがわかりました。 GEM_HOMEは存在せず、 GEM_PATHにvendor/bundle/ruby/2.1.0の記述はありませんでした。 
springを再起動もしましたが、効果がありませんでした。

.bundle/config 
BUNDLE_PATH: vendor/bundle/
BUNDLE_DISABLE_SHARED_GEMS: '1'
となっています。

bundle install したgemへのpathが railsのどこに記述されているかご存知の方がいらっしゃいましたら、ご教授お願い致します。

よろしくお願いします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • hichon

    2018/11/24 07:51

    which rubyとwhich bundleの結果を貼って下さい。

    キャンセル

  • nimbus1978

    2018/11/24 14:09

    $ which ruby ~/.rbenv/shims/ruby

    キャンセル

  • nimbus1978

    2018/11/24 14:09

    which bundle ~/.rbenv/shims/bundle

    キャンセル

  • nimbus1978

    2018/11/24 14:09

    になります。

    キャンセル

回答 1

check解決した方法

0

bundlerを一度完全にuninstallし、 またgem installしました。 bundler version 1.17.1です。
console上で bundle env を叩くと、 正しいgemのpathが表示されるのですが、 ブラウザに表示されるエラー画面の web application could no be started の中では

(Bundler::GemNotFound)
Environment variables
GEM_HOME = /hoge/vendor/bundle/ruby/2.1.0

と古い情報が表示されます。 なぜconsoleで表示されたbundle envの内容と違うのかわかりませんでした。
お分かりの方いらっしゃいましたら、 お助けください。 よろしくお願いします。

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/11/25 19:52

    /etc/httpd/conf.d/passenger.conf の設定が古いのが原因でした。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.34%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る