質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.92%

GemfileのRubyのヴァージョンの書き方が分かりません

解決済

回答 3

投稿

  • 評価
  • クリップ 0
  • VIEW 967

DrqYuto

score 316

イメージ説明
環境 cmd Chocolatey ruby2.5
rumix2 ruby 2.3.1

cmdではruby2.5ですが先に2.3をインストールしてます。アップデートしたいのですがgemfileを2.5.3と書いたほうがいいですか?
イメージ説明

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 3

checkベストアンサー

+1

bundlerはディレクトリごとにRubyのGemパッケージの種類やバージョンを管理するためのgemです。
Ruby自体のバージョンを管理するためにはrbenv等を使います。
bundlerはRubyのバージョンごとにディレクトリを作って、そこにgemのインストールしてくれます。

Gemfileにruby '2.3.1'等と書く場合、そのアプリで必要とされるRubyのバージョンを指定することが出来ます。
参考リンク
Ruby自体をbundlerでインストールする訳ではないので、
アップデートの必要はないですよ。

コマンドプロンプトの出力を見る限り、
DrqYutoさんの環境にはRuby2.5.3がインストールされているようなので、
gemパッケージはそのRubyエンジンに紐づけてインストールしてくれると思います。
なのでGemfileからruby '2.3.1'の記載を削除してもいいかと…。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/11/09 18:49

    でしたら ruby 2.5.3と書いたほうがいいですか?そしてbundle install ですか?

    キャンセル

  • 2018/11/09 18:55

    ruby ~~~ は書かなくてもいいと思います。
    rubyのバージョンを指定しておきたい、という何かしらの理由があるのであれば、書いていいと思いますが…
    bundle install は新しくgemをインストールするのであれば実行してください。

    キャンセル

  • 2018/11/09 19:00

    なるほどです。

    キャンセル

-1

イメージ説明
bundle install したらmakeは認識されてませんとでました。これは関係ありますか?

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/11/10 13:49

    分かりました。Dockerとかだと競合しないですか?

    キャンセル

  • 2018/11/11 16:35

    申し訳ありません、Dockerは使ったことがないので…
    Dockerについて正しい回答が欲しいのであれば別途質問を立てて
    他の方に聞かれた方が宜しいと思います;

    キャンセル

  • 2018/11/11 16:43

    分かりました。有難う御座います。

    キャンセル

-1

イメージ説明
git push heroku masterしたらruby2.3.1を使ってますと出ました。2.5をインストールしてあるのですがどうしたらいいですか?

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/11/09 19:16

    でしたらGemfileにRubyのバージョン(2.5.3)を指定して、
    改めてpushしてみてください。
    (というか、それでバージョンを指定したかったのですね…。失礼しました。)
    参考リンク;https://devcenter.heroku.com/articles/ruby-versions

    キャンセル

  • 2018/11/09 19:18

    あと、エラー画面のキャプチャ等、追加情報がある場合は、DrqYutoさんの質問欄に記載してくださるとわかりやすくて助かります。
    回答欄に記載されてたので、他の方が回答されてるのかと思ってしまいました…;

    キャンセル

  • 2018/11/10 11:00

    了解しました。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.92%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る