質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.03%

bundle installでエラー発生

受付中

回答 0

投稿

  • 評価
  • クリップ 0
  • VIEW 579

score 58

bundle installでエラーが出ております
上3行のwarnignはパーミッションは変更すればいいと思うのですが、

in `require': cannot load such file -- arel (LoadError) このエラーがどう解決してよいかわかりません

わかる方いましたらお願い致します

$ bundle exec rails s
/home/****/.rbenv/versions/2.2.5/lib/ruby/gems/2.2.0/gems/bundler-1.10.6/lib/bundler/shared_helpers.rb:78: warning: Insecure world writable dir /home/****/workspace in PATH, mode 040777
/home/*****/.rbenv/versions/2.2.5/lib/ruby/gems/2.2.0/gems/bundler-1.10.6/lib/bundler/shared_helpers.rb:78: warning: Insecure world writable dir /home/****/workspace in PATH, mode 040777
/home/****/workspace/adc/vendor/bundler/ruby/2.2.0/gems/activesupport-3.2.14/lib/active_support/values/time_zone.rb:270: warning: circular argument reference - now
/home/****/workspace/adc/vendor/bundler/ruby/2.2.0/gems/activerecord-3.2.14/lib/active_record.rb:27:i
    from /home/****/workspace/adc/vendor/bundler/ruby/2.2.0/gems/activerecord-3.2.14/lib/active_record.rb:27:in `<top (required)>'
    from /home/****/workspace/adc/vendor/bundler/ruby/2.2.0/gems/yaml_db-0.7.0/lib/yaml_db.rb:3:in `require'
    from /home/****/workspace/adc/vendor/bundler/ruby/2.2.0/gems/yaml_db-0.7.0/lib/yaml_db.rb:3:in `<top (required)>'
    from /home/****/.rbenv/versions/2.2.5/lib/ruby/gems/2.2.0/gems/bundler-1.10.6/lib/bundler/runtime.rb:76:in `require'
    from /home/****/.rbenv/versions/2.2.5/lib/ruby/gems/2.2.0/gems/bundler-1.10.6/lib/bundler/runtime.rb:76:in `block (2 levels) in require'
    from /home/****/lib/ruby/gems/2.2.0/gems/bundler-1.10.6/lib/bundler/runtime.rb:72:in `each'
    from /home/****/.rbenv/versions/2.2.5/lib/ruby/gems/2.2.0/gems/bundler-1.10.6/lib/bundler/runtime.rb:72:in `block in require'
    from /home/****/.rbenv/versions/2.2.5/lib/ruby/gems/2.2.0/gems/bundler-1.10.6/lib/bundler/runtime.rb:61:in `each'
    from /home/****/.rbenv/versions/2.2.5/lib/ruby/gems/2.2.0/gems/bundler-1.10.6/lib/bundler/runtime.rb:61:in `require'
    from /home/****/.rbenv/versions/2.2.5/lib/ruby/gems/2.2.0/gems/bundler-1.10.6/lib/bundler.rb:134:in `require'
    from /home/****/workspace/adc/config/application.rb:7:in `<top (required)>'
    from /home/****/workspace/adc/vendor/bundler/ruby/2.2.0/gems/railties-3.2.14/lib/rails/commands.rb:53:in `require'
    from /home/****/workspace/adc/vendor/bundler/ruby/2.2.0/gems/railties-3.2.14/lib/rails/commands.rb:53:in `block in <top (required)>'
    from /home/****/workspace/adc/vendor/bundler/ruby/2.2.0/gems/railties-3.2.14/lib/rails/commands.rb:50:in `tap'
    from /home/****/workspace/adc/vendor/bundler/ruby/2.2.0/gems/railties-3.2.14/lib/rails/commands.rb:50:in `<top (required)>'
    from script/rails:6:in `require'
    from script/rails:6:in `<main>'
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正の依頼

  • kazto

    2018/10/05 15:50

    bundle installでのエラーではなくbundle execでのエラーで間違いないないでしょうか。また、LoadErrorがエラー文に見当たりません。内容の確認をお願いします。

    キャンセル

まだ回答がついていません

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.03%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る