質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.23%

rake db:createで rake abortedと出る

受付中

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 2,077

on_off_on

score 18

少し前にRailsで環境構築をしようとして、その時は無事にできたんですが、

少し時間が空いたのでなんとなく復習したくなり、ユーザーを新しく作り、環境構築をしようと思い、またやってるんですが、どうもうまくいきません。

そもそもMacで新しいユーザーを作った時、普段使っているユーザーの影響ってうけるものなんでしょうか?

まぁそれは置いておいて、本題に入ります。

rails newでrails プロジェクトを作った後、rake db:createをしようとした時に、以下のようなエラーが出ました。

rake aborted!
LoadError: dlopen(/Users/名前/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/mysql2-0.3.18/lib/mysql2/mysql2.bundle, 9): Library not loaded: /usr/local/opt/mysql@5.7/lib/libmysqlclient.20.dylib
  Referenced from: /Users/名前/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/mysql2-0.3.18/lib/mysql2/mysql2.bundle
  Reason: image not found - /Users/名前/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/mysql2-0.3.18/lib/mysql2/mysql2.bundle
/Users/名前/projects/pictweet/config/application.rb:7:in `<top (required)>'
/Users/名前/projects/pictweet/Rakefile:4:in `<top (required)>'
(See full trace by running task with --trace)

which mysqlを打つと、
/usr/local/opt/mysql@5.6/bin/mysql

です。

ちなみに、Cellarの中身をのぞいた時、なぜかmysql@5.7もあり、似たようなエラーが出たんですが、それはuninstallすることで解決しました。

解決方法を教えていただけると嬉しいですが、ヒントだけでも助かります。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

+2

homebrewを使われているんですね。
mysql2がインストールされた時に、要求するダイナミックリンクライブラリが、mysql@5.7 のものにリンクされてしまったとかなんでしょうか…

mysql@5.7はすでにアンインストールされたということのようですので、
ruby側で、mysql2を再インストールしてみるのはどうでしょうか。

Railsであればbundler前提だと思うので、

bundle exec gem uninstall mysql2
bundle install


とかでしょうか。

それでもだめなら、
brew link mysql@5.6 --force

を行ってから、上記手順を行ってみるなど。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/10/04 16:48

    すみません、解決しました!ありがとうございます!

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.23%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る