質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.93%

bundle installでエラー発生する。

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 7,249

score 10

 前提・実現したいこと

Centos7環境で、Bitnami Redmine-3.4.6-1(2018/9/7時点最新版)をインストールし、プラグインをインストールしようとすると、エラー発生でプラグインをインストールできない。

 発生している問題・エラーメッセージ

bundle installすると、
以下のメッセージが表示されてしまう。
※bundle install --no-deploymentを指定しても同じ結果になってしまいます。

「Don't run Bundler as root. Bundler can ask for sudo if it is needed, and
installing your bundle as root will break this application for all non-root
users on this machine.」


↓ここからは実際のコマンドです。

[root@localhost ~]# cd /opt/redmine-3.4.6-1/
[root@localhost redmine-3.4.6-1]# ./use_redmine
bash-4.2# echo $PATH
/opt/redmine-3.4.6-1/perl/bin:/opt/redmine-3.4.6-1/git/bin:/opt/redmine-3.4.6-1/sqlite/bin:/opt/redmine-3.4.6-1/ruby/bin:/opt/redmine-3.4.6-1/subversion/bin:/opt/redmine-3.4.6-1/postgresql/bin:/opt/redmine-3.4.6-1/php/bin:/opt/redmine-3.4.6-1/mysql/bin:/opt/redmine-3.4.6-1/apache2/bin:/opt/redmine-3.4.6-1/common/bin:/root/.rbenv/shims:/root/.rbenv/bin:/usr/lib64/qt-3.3/bin:/usr/local/bin:/usr/local/sbin:/usr/bin:/usr/sbin:/bin:/sbin:/root/bin
bash-4.2# cd /opt/redmine-3.4.6-1/apps/redmine/htdocs/plugins/
bash-4.2# bundle install
Don't run Bundler as root. Bundler can ask for sudo if it is needed, and
installing your bundle as root will break this application for all non-root
users on this machine.
Fetching gem metadata from https://rubygems.org/..........
Fetching version metadata from https://rubygems.org/..
Fetching dependency metadata from https://rubygems.org/.
Using rake 12.3.1
Using i18n 0.7.0
Using minitest 5.11.3
Using thread_safe 0.3.6
Using builder 3.2.3
Using erubis 2.7.0
Using mini_portile2 2.3.0
Using crass 1.0.4
Using rack 1.6.10
Using mime-types-data 3.2016.0521
Using arel 6.0.4
Using public_suffix 3.0.2
Using coderay 1.1.2
Using concurrent-ruby 1.0.5
Using htmlentities 4.3.4
Using thor 0.20.0
Using mimemagic 0.3.2
Using mysql2 0.4.10
Using net-ldap 0.12.1
Using ruby-openid 2.3.0
Using bundler 1.14.6
Using rbpdf-font 1.19.1
Using redcarpet 3.4.0
Using request_store 1.0.5
Using rmagick 2.16.0
Using tzinfo 1.2.5
Using nokogiri 1.8.2
Using rack-test 0.6.3
Using mime-types 3.1
Using addressable 2.5.2
Using sprockets 3.7.1
Using rack-openid 1.4.2
Using rbpdf 1.19.3
Using activesupport 4.2.8
Using loofah 2.2.2
Using mail 2.6.6
Using css_parser 1.6.0
Using rails-deprecated_sanitizer 1.0.3
Using globalid 0.4.1
Using activemodel 4.2.8
Using fiscali 2.4.3
Using rails-html-sanitizer 1.0.4
Using roadie 3.2.2
Using rails-dom-testing 1.0.9
Using activejob 4.2.8
Using activerecord 4.2.8
Using protected_attributes 1.1.4
Using actionview 4.2.8
Using actionpack 4.2.8
Using actionmailer 4.2.8
Using actionpack-xml_parser 1.0.2
Using railties 4.2.8
Using sprockets-rails 3.2.1
Using jquery-rails 3.1.5
Using roadie-rails 1.1.1
Using rails 4.2.8
Bundle complete! 32 Gemfile dependencies, 56 gems now installed.
Gems in the groups development, test and sqlite were not installed.
Use bundle show [gemname] to see where a bundled gem is installed.
bash-4.2# 


 該当のソースコード

ソースコード

 試したこと

ここに問題に対して試したことを記載してください。

 補足情報(FW/ツールのバージョンなど)

ここにより詳細な情報を記載してください。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • mather

    2018/09/07 11:04

    プラグイン、というタグは不適切です。Rubyなどのほうがまだ良いと思います。

    キャンセル

  • kumasan616

    2018/09/07 11:10

    ご指摘ありがとうございます。当方LinuxやRedmineについては経験浅い為誤認識していました。Rubyに変更しました。

    キャンセル

回答 1

checkベストアンサー

+1

エラーメッセージではなく、警告です。実際にインストールは実行されてますよね。

Don't run Bundler as root.
(Bundlerをrootユーザーで実行しないでください。)

基本はプロジェクト単位で Gemfile を管理すれば良いので、 root 権限は必要ないはずです。一旦 root ユーザーで実行してしまうと今後も root ユーザーの権限でないと実行できなくなってしまうケースがあります。

root は権限が強すぎるため、間違うとシステムを破壊しかねません。どうしても必要な場合を除き、使うべきではありません。
Linuxのユーザー管理をちゃんと勉強してくださいね。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/09/07 11:13

    ご回答ありがとうございます。
    当方LinuxやRedmineについては経験浅い為に、もう少しお聞きしたく。
    rootではなく、別ユーザーでログインし、bundle installを実行でよいのでしょうか。

    キャンセル

  • 2018/09/07 14:01

    インストールは実行されていました。
    ありがとうございました。

    キャンセル

  • 2018/09/07 14:30

    はい。ファイルの置き場所の問題もあると思います。
    例えば、 redmine ユーザーというのを作っておいて、 redmineユーザーでインストールとRedmineプロセスの起動を管理し、そこにApache, nginxを繋ぐ部分だけrootユーザーで管理するなどの方法が代表的かと思います。
    なぜ一般のユーザーではなくredmineユーザーをわざわざ作るのかと言うと、Redmineのプロセスからは特定のディレクトリ以外へのアクセスを許可しないなどの個別のコントロールがやりやすいからです。

    キャンセル

  • 2018/09/07 17:24

    ありがとうございます。
    プラグインがインストールされました。
    本当に助かりました。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.93%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る