質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.92%

EC2でphp-gdをインストールしたいが、インストールできない

受付中

回答 1

投稿

  • 評価
  • クリップ 1
  • VIEW 1,152

score 22

php7.1を入れています。php-gdをインストールしようとすると以下のエラーが出ます。よろしくお願いします。

[ec2-user@ip-xxx-xx-xx-xx ~]$ sudo yum --enablerepo=remi-php71 --disablerepo=amzn-main install php-gd
Loaded plugins: priorities, update-motd, upgrade-helper
8 packages excluded due to repository priority protections
Resolving Dependencies
--> Running transaction check
---> Package php-gd.x86_64 0:7.1.20-1.el6.remi will be installed
--> Processing Dependency: php-common(x86-64) = 7.1.20-1.el6.remi for package: php-gd-7.1.20-1.el6.remi.x86_64
--> Processing Dependency: gd-last(x86-64) >= 2.1.1 for package: php-gd-7.1.20-1.el6.remi.x86_64
--> Processing Dependency: libgd.so.3()(64bit) for package: php-gd-7.1.20-1.el6.remi.x86_64
--> Running transaction check
---> Package gd-last.x86_64 0:2.2.5-2.el6.remi will be installed
---> Package php-common.x86_64 0:7.1.20-1.el6.remi will be installed
--> Processing Dependency: php-json(x86-64) = 7.1.20-1.el6.remi for package: php-common-7.1.20-1.el6.remi.x86_64
--> Running transaction check
---> Package php-json.x86_64 0:7.1.20-1.el6.remi will be installed
--> Finished Dependency Resolution

Dependencies Resolved

==============================================================================================================================================================================================================================================
 Package                                                  Arch                                                 Version                                                         Repository                                                Size
==============================================================================================================================================================================================================================================
Installing:
 php-gd                                                   x86_64                                               7.1.20-1.el6.remi                                               remi-php71                                                71 k
Installing for dependencies:
 gd-last                                                  x86_64                                               2.2.5-2.el6.remi                                                remi-safe                                                128 k
 php-common                                               x86_64                                               7.1.20-1.el6.remi                                               remi-php71                                               1.0 M
 php-json                                                 x86_64                                               7.1.20-1.el6.remi                                               remi-php71                                                57 k

Transaction Summary
==============================================================================================================================================================================================================================================
Install  1 Package (+3 Dependent packages)

Total size: 1.2 M
Installed size: 8.5 M
Is this ok [y/d/N]: y
Downloading packages:
Running transaction check
Running transaction test


Transaction check error:
  file /etc/php.d/20-json.ini from install of php-json-7.1.20-1.el6.remi.x86_64 conflicts with file from package php71-json-7.1.17-1.32.amzn1.x86_64
  file /etc/php-zts.d/20-json.ini from install of php-json-7.1.20-1.el6.remi.x86_64 conflicts with file from package php71-json-7.1.17-1.32.amzn1.x86_64
  file /etc/php.d/20-bz2.ini from install of php-common-7.1.20-1.el6.remi.x86_64 conflicts with file from package php71-common-7.1.17-1.32.amzn1.x86_64
  file /etc/php-zts.d/20-bz2.ini from install of php-common-7.1.20-1.el6.remi.x86_64 conflicts with file from package php71-common-7.1.17-1.32.amzn1.x86_64
  file /etc/php.d/20-calendar.ini from install of php-common-7.1.20-1.el6.remi.x86_64 conflicts with file from package php71-common-7.1.17-1.32.amzn1.x86_64
  file /etc/php-zts.d/20-calendar.ini from install of php-common-7.1.20-1.el6.remi.x86_64 conflicts with file from package php71-common-7.1.17-1.32.amzn1.x86_64
  file /etc/php.d/20-ctype.ini from install of php-common-7.1.20-1.el6.remi.x86_64 conflicts with file from package php71-common-7.1.17-1.32.amzn1.x86_64
  file /etc/php-zts.d/20-ctype.ini from install of php-common-7.1.20-1.el6.remi.x86_64 conflicts with file from package php71-common-7.1.17-1.32.amzn1.x86_64
  file /etc/php.d/20-curl.ini from install of php-common-7.1.20-1.el6.remi.x86_64 conflicts with file from package php71-common-7.1.17-1.32.amzn1.x86_64
  file /etc/php-zts.d/20-curl.ini from install of php-common-7.1.20-1.el6.remi.x86_64 conflicts with file from package php71-common-7.1.17-1.32.amzn1.x86_64
  file /etc/php.d/20-exif.ini from install of php-common-7.1.20-1.el6.remi.x86_64 conflicts with file from package php71-common-7.1.17-1.32.amzn1.x86_64
  file /etc/php-zts.d/20-exif.ini from install of php-common-7.1.20-1.el6.remi.x86_64 conflicts with file from package php71-common-7.1.17-1.32.amzn1.x86_64
  file /etc/php.d/20-fileinfo.ini from install of php-common-7.1.20-1.el6.remi.x86_64 conflicts with file from package php71-common-7.1.17-1.32.amzn1.x86_64
  file /etc/php-zts.d/20-fileinfo.ini from install of php-common-7.1.20-1.el6.remi.x86_64 conflicts with file from package php71-common-7.1.17-1.32.amzn1.x86_64
  file /etc/php.d/20-ftp.ini from install of php-common-7.1.20-1.el6.remi.x86_64 conflicts with file from package php71-common-7.1.17-1.32.amzn1.x86_64
  file /etc/php-zts.d/20-ftp.ini from install of php-common-7.1.20-1.el6.remi.x86_64 conflicts with file from package php71-common-7.1.17-1.32.amzn1.x86_64
  file /etc/php.d/20-gettext.ini from install of php-common-7.1.20-1.el6.remi.x86_64 conflicts with file from package php71-common-7.1.17-1.32.amzn1.x86_64
  file /etc/php-zts.d/20-gettext.ini from install of php-common-7.1.20-1.el6.remi.x86_64 conflicts with file from package php71-common-7.1.17-1.32.amzn1.x86_64
  file /etc/php.d/20-iconv.ini from install of php-common-7.1.20-1.el6.remi.x86_64 conflicts with file from package php71-common-7.1.17-1.32.amzn1.x86_64
  file /etc/php-zts.d/20-iconv.ini from install of php-common-7.1.20-1.el6.remi.x86_64 conflicts with file from package php71-common-7.1.17-1.32.amzn1.x86_64
  file /etc/php.d/20-phar.ini from install of php-common-7.1.20-1.el6.remi.x86_64 conflicts with file from package php71-common-7.1.17-1.32.amzn1.x86_64
  file /etc/php-zts.d/20-phar.ini from install of php-common-7.1.20-1.el6.remi.x86_64 conflicts with file from package php71-common-7.1.17-1.32.amzn1.x86_64
  file /etc/php.d/20-sockets.ini from install of php-common-7.1.20-1.el6.remi.x86_64 conflicts with file from package php71-common-7.1.17-1.32.amzn1.x86_64
  file /etc/php-zts.d/20-sockets.ini from install of php-common-7.1.20-1.el6.remi.x86_64 conflicts with file from package php71-common-7.1.17-1.32.amzn1.x86_64
  file /etc/php.d/20-tokenizer.ini from install of php-common-7.1.20-1.el6.remi.x86_64 conflicts with file from package php71-common-7.1.17-1.32.amzn1.x86_64
  file /etc/php-zts.d/20-tokenizer.ini from install of php-common-7.1.20-1.el6.remi.x86_64 conflicts with file from package php71-common-7.1.17-1.32.amzn1.x86_64

Error Summary
-------------
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

0

すでにインストールされているものが amzn1 レポジトリからインストールしているんだから、

$ sudo yum --enablerepo=amzn1 --disablerepo=amzn-main install php-gd

でインストールできるのでは?

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.92%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る