質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.34%

  • Ruby

    8183questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • CentOS

    2827questions

    CentOSは、主にRed Hat Enterprise Linux(RHEL)をベースにした、フリーのソフトウェアオペレーティングシステムです。

  • Redmine

    205questions

    Redmineは、プロジェクトのタスク管理、進捗管理、情報共有が可能な、 オープンソースプロジェクト管理ソフトウェアです。

CentOSでRedmineのE-R図出力のため、railroadyのインストールをしようとするとエラーが出力されてしまいます。

受付中

回答 0

投稿

  • 評価
  • クリップ 0
  • VIEW 149

asyahana

score 3

railroadyでRedmineのE-R図を出力しようとしましたが、
下記エラーが出現して出力できません。
(事前にGraphviz、railroadyを)
Googleで検索すると似たようなエラーとその対処法が報告されているページが
散見されましたが、如何せんRubyやLinux初心者(触って1週間程度)ですので、
具体的な対処法が思い浮かばず途方に暮れてしまいました。

どなたかアドバイスを頂ければと存じます。

[root@localhost htdocs]# yum install git

[root@localhost htdocs]# yum install graphviz

[root@localhost htdocs]# yum install rubygems

[root@localhost htdocs]# gem install railroady

[root@localhost htdocs]# railroady -o controller.dot -C
Error loading application environment.
  (Are you running railroady on the application's root directory?)
Traceback (most recent call last):
    15: from /root/.rbenv/versions/2.5.0/bin/railroady:23:in `<main>'
    14: from /root/.rbenv/versions/2.5.0/bin/railroady:23:in `load'
    13: from /root/.rbenv/versions/2.5.0/lib/ruby/gems/2.5.0/gems/railroady-1.5.3/bin/railroady:53:in `<top (required)>'
    12: from /root/.rbenv/versions/2.5.0/lib/ruby/gems/2.5.0/gems/railroady-1.5.3/lib/railroady/app_diagram.rb:42:in `process'
    11: from /root/.rbenv/versions/2.5.0/lib/ruby/gems/2.5.0/gems/railroady-1.5.3/lib/railroady/app_diagram.rb:68:in `load_environment'
    10: from /root/.rbenv/versions/2.5.0/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in `require'
     9: from /root/.rbenv/versions/2.5.0/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in `require'
     8: from /opt/redmine-3.4.6-0/apps/redmine/htdocs/config/environment.rb:2:in `<top (required)>'
     7: from /root/.rbenv/versions/2.5.0/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in `require'
     6: from /root/.rbenv/versions/2.5.0/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in `require'
     5: from /opt/redmine-3.4.6-0/apps/redmine/htdocs/config/application.rb:1:in `<top (required)>'
     4: from /root/.rbenv/versions/2.5.0/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in `require'
     3: from /root/.rbenv/versions/2.5.0/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in `require'
     2: from /opt/redmine-3.4.6-0/apps/redmine/htdocs/config/boot.rb:4:in `<top (required)>'
     1: from /root/.rbenv/versions/2.5.0/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in `require'
/root/.rbenv/versions/2.5.0/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in `require': cannot load such file -- bundler/setup (LoadError)
[root@localhost htdocs]# 

【環境】
OS:CentOS 7
Redmine:3.4.6-0(Bitnamiでインストール)

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

まだ回答がついていません

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.34%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る

  • Ruby

    8183questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • CentOS

    2827questions

    CentOSは、主にRed Hat Enterprise Linux(RHEL)をベースにした、フリーのソフトウェアオペレーティングシステムです。

  • Redmine

    205questions

    Redmineは、プロジェクトのタスク管理、進捗管理、情報共有が可能な、 オープンソースプロジェクト管理ソフトウェアです。

  • トップ
  • Rubyに関する質問
  • CentOSでRedmineのE-R図出力のため、railroadyのインストールをしようとするとエラーが出力されてしまいます。