質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.32%

  • OpenSSL

    114questions

    OpenSSLはSSL/TLSのプロトコルと一般的な暗号のライブラリを導入するオープンソースのソフトウェアのツールキットです。

0.9.8から1.0.2へのバージョンアップについて

受付中

回答 0

投稿

  • 評価
  • クリップ 2
  • VIEW 527

T-Imai

score 0

 前提・実現したいこと

当方のLinuxサーバから、HTTPSで先方のサーバと通信を行っています。
先方のサーバがTLS1.2以上しか受け付けなくなり、当方のサーバから繋がらなくなってしまいました。
現在の当方のサーバ環境は以下の通りです。
・OS:RHEL 5
・PHP:5.2.8
・OpenSSL:0.9.8b

対処として、OpenSSLのバージョンを1.0.2にする事を考えています。
ただ、PHPのバージョンまで上げると影響範囲が大きくなるので、PHPは5.2.8のままとしたい考えです。

そこで、OpenSSL 1.0.2oをコンパイル(config -> make -> make install)し、PHP5.2.8を再コンパイルしたのですが、
configure の後のmake でエラーとなってしまいました。

 PHPの再コンパイル

make clean

./configure --enable-mbstring --enable-sigchild --enable-zend-multibyte --with-mcrypt --enable-shmop --enable-sysvsem --enable-sysvmsg --enable-sysvshm --with-openssl=/usr/local/ssl

make

 発生している問題・エラーメッセージ

/usr/local/src/php-5.2.8/ext/openssl/openssl.c:230: error: expected specifier-qualifier-list before 'LHASH'
/usr/local/src/php-5.2.8/ext/openssl/openssl.c:411: error: expected declaration specifiers or '...' before 'LHASH'
/usr/local/src/php-5.2.8/ext/openssl/openssl.c: In function 'php_openssl_config_check_syntax':
/usr/local/src/php-5.2.8/ext/openssl/openssl.c:417: error: 'config' undeclared (first use in this function)
(以下省略)

 試したこと

・上記のとおり、OpenSSL 1.0.2oのコンパイルと、PHP5.2.8の再コンパイル。
・phpize によるモジュール追加(同様のエラーとなってしまいました)。

 質問事項

(1) OpenSSL を1.0.2に上げるには、PHP5.2.8のままではダメでしょうか?
(2) TLS1.2未満を受け付けないサーバと通信する為の当方の対処として、OpenSSLをバージョンアップする以外に策はありますでしょうか?

記載内容に不備、不足がありましたらご指摘いただけると助かります。

よろしくお願いします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

まだ回答がついていません

同じタグがついた質問を見る

  • OpenSSL

    114questions

    OpenSSLはSSL/TLSのプロトコルと一般的な暗号のライブラリを導入するオープンソースのソフトウェアのツールキットです。