質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
86.02%
Nim

Nimは、静的型付けプログラミング言語。Pythonの生産性でありながら、C言語のような高いパフォーマンスも持ち併せます。さらに自由度の高い言語で拡張性も重視されています。

Q&A

受付中

「packages.json」のダウンロードに失敗します

serona
serona

総合スコア25

Nim

Nimは、静的型付けプログラミング言語。Pythonの生産性でありながら、C言語のような高いパフォーマンスも持ち併せます。さらに自由度の高い言語で拡張性も重視されています。

0回答

0グッド

0クリップ

323閲覧

投稿2018/06/21 07:14

Nim言語を始めてみようと思った者です。
もとは、JavaScript、Java、VBなどを使用していました。
使用環境はMac、開発環境はVScodeです。

https://enomotodev.hatenablog.com/entry/2017/10/07/131118

NimでRESTful APIの作成をしたかったので、上記ページ参考に、

$ brew install nim … $ nim -v Nim Compiler Version 0.18.0 [MacOSX: amd64] Copyright (c) 2006-2018 by Andreas Rumpf active boot switches: -d:release -d:useLinenoise $ mkdir sample_nim $ cd sample_nim $ nimble init sample_app

ここまで、問題なく完了しました。
しかし、「jester」をインストールしようとすると、

$ nimble install jester Prompt: No local packages.json found, download it from internet? [y/N] Answer: y Downloading Official package list Tip: 8 messages have been suppressed, use --verbose to show them. Error: Refresh failed ... Could not download: Please upgrade your OpenSSL library, it does not support the necessary protocols. OpenSSL error is: error:14077410:SSL routines:SSL23_GET_SERVER_HELLO:sslv3 alert handshake failure

このようなエラーが出てしまい、パッケージのインストールができません。
検索しても解決方法が見当たらず、困っています…><

$ openssl version OpenSSL 1.0.2o 27 Mar 2018 $ which openssl /usr/local/opt/openssl/bin/openssl

上記の通り、ooenSSLは最新のはずなのですが…
何かわかる方いらっしゃいましたら、ご協力お願いします!

以下のような質問にはグッドを送りましょう

  • 質問内容が明確
  • 自分も答えを知りたい
  • 質問者以外のユーザにも役立つ

グッドが多くついた質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

気になる質問をクリップする

クリップした質問は、後からいつでもマイページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

下記のような質問は推奨されていません。

  • 間違っている
  • 質問になっていない投稿
  • スパムや攻撃的な表現を用いた投稿

適切な質問に修正を依頼しましょう。

まだ回答がついていません

会員登録して回答してみよう

アカウントをお持ちの方は

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
86.02%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問

同じタグがついた質問を見る

Nim

Nimは、静的型付けプログラミング言語。Pythonの生産性でありながら、C言語のような高いパフォーマンスも持ち併せます。さらに自由度の高い言語で拡張性も重視されています。