質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.87%

  • Apache

    1652questions

    Apacheは、Apache HTTP Serverの略で、最も人気の高いWebサーバソフトウェアの一つです。安定性が高いオープンソースソフトウェアとして商用サイトから自宅サーバまで、多くのプラットフォーム向けに開発・配布されています。サーバーソフトウェアの不具合(NCSA httpd)を修正するパッチ(a patch)を集積、一つ独立したソフトウェアとして開発されました。

  • XAMPP

    452questions

    XAMPP(ザンプ)は、ウェブアプリケーションの実行に必要なフリーソフトウェアをパッケージングしたApacheディストリビューションです。 XAMPPひとつインストールするだけで、Apache、MySQL、PHP、Perlなどのソフトウェアと、 phpMyAdminなどの管理ツール、SQLiteなどのソフトウェアやライブラリモジュールなどを利用することが可能です。

  • OpenSSL

    97questions

    OpenSSLはSSL/TLSのプロトコルと一般的な暗号のライブラリを導入するオープンソースのソフトウェアのツールキットです。

XAMPPのapacheが使うopenssl「だけ」をアップグレードしたい

受付中

回答 0

投稿

  • 評価
  • クリップ 0
  • VIEW 124

y_omori

score 2

 前提・実現したいこと:XAMPPのapacheが使うopenssl「だけ」をアップグレードしたい

XAMPPのapacheが使うopensslが1.1.0gのようなので、この部分をアップグレードしたい。

 発生している問題・エラーメッセージ

phpinfo.phpの [Apache Version] の欄に

Apache/2.4.33 (Win32) OpenSSL/1.1.0g PHP/7.2.4


と表示されている

 該当のソースコード

「XAMPPの」ソースコード等が何処にあるのか不明
入手方法も不明
tar ballで入手できるかどうかも不明

たぶんPHPとapacheで、参照しているソースファイルが異なるものと思われるけれども、どういう処理が自動化されて行われているか不明

 試したこと

仮説として

  • openssl.exe
  • libcrypto-1_1.dll
  • libssl-1_1.dll

をすり替えれば直るかも知れないとみて

これでphpinfoの情報によれば1.1.0hに変わったけれども、正しいといえるかどうか不明。

 補足情報(FW/ツールのバージョンなど)

Windows8.1Pro(64bit)
XAMPP for Windows 7.2.4

 さいごに

このサイトを使うのは初めてなので、不適切な点があれば
御指摘いただけると幸いです。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正の依頼

  • y_omori

    2018/05/11 14:46

    なお、あくまで「自宅での試用環境」であり、商用利用は一切なく、また、少なくともスマートフォンのブラウザ経由でapacheへアクセスできないことは確認しています。必要があれば、しかるべき設定ファイルのしかるべき部分、あるいは全部を提示いたします。

    キャンセル

  • maisumakun

    2018/05/11 14:52

    すみません、提示された状況では自分であれば「アップデートしない」という結論になりますので、回答は差し控えさせていただきます。

    キャンセル

  • y_omori

    2018/05/11 20:52

    ”提示された状況では自分であれば「アップデートしない」という結論になります”という見解の論理的帰結が、なぜ”回答は差し控えさせていただきます”となるのかは分かりませんでしたが、回答する意思が無いことは把握いたしました。貴重なお時間ありがとうございました。

    キャンセル

まだ回答がついていません

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.87%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • Apache

    1652questions

    Apacheは、Apache HTTP Serverの略で、最も人気の高いWebサーバソフトウェアの一つです。安定性が高いオープンソースソフトウェアとして商用サイトから自宅サーバまで、多くのプラットフォーム向けに開発・配布されています。サーバーソフトウェアの不具合(NCSA httpd)を修正するパッチ(a patch)を集積、一つ独立したソフトウェアとして開発されました。

  • XAMPP

    452questions

    XAMPP(ザンプ)は、ウェブアプリケーションの実行に必要なフリーソフトウェアをパッケージングしたApacheディストリビューションです。 XAMPPひとつインストールするだけで、Apache、MySQL、PHP、Perlなどのソフトウェアと、 phpMyAdminなどの管理ツール、SQLiteなどのソフトウェアやライブラリモジュールなどを利用することが可能です。

  • OpenSSL

    97questions

    OpenSSLはSSL/TLSのプロトコルと一般的な暗号のライブラリを導入するオープンソースのソフトウェアのツールキットです。