質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.02%

imagickがインストールできません。

受付中

回答 2

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 1,800

 前提・実現したいこと

CentOS7で環境を構築しているのですが、imagickがインストールできません。

wgetコマンドでImageMagick6.9.9-40をインストールしました。
ImageMagickは間違いなくインストールされているようです。

パスは、/usr/local/src/ImageMagick6.9.9-40です。

 やったこと

pecl install imagick
peardev install pecl/imagick


上記のコマンドでは、エラーも何も出ずコマンド入力待機状態に戻るだけです。

何故インストールができないか、ご教授いただけませんでしょうか?

ちなみに

yum install php-devel
yum install php-pear


も行っております。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

0

こちらのパッケージ利用の方法を試してみてください。
ttps://qiita.com/satthi/items/d8fb39ad4d01a9e63173

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/04/19 23:52

    こちらの方法も試したのですが、どうもうまくいきませんでした。。

    キャンセル

0

pecl はもうメンテナンスされていないので、使うことはできません。パッケージはyumで入れましょう。

yum list | grep imagick

でパッケージ名を確認

yum install パッケージ名

でインストールできます。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/04/19 23:31

    すいません、こちらの方法では解決できませんでした。。

    php72-php-pecl-imagick.x86_64 3.4.3-8.el7.remi @remi-safe
    php72-php-pecl-imagick-devel.x86_64 3.4.3-8.el7.remi @remi-safe
    php-pecl-imagick.x86_64 3.1.0-0.6.RC2.el7 epel
    php54-php-pecl-imagick.x86_64 3.4.3-5.el7.remi remi-safe
    php54-php-pecl-imagick-devel.x86_64 3.4.3-5.el7.remi remi-safe
    php55-php-pecl-imagick.x86_64 3.4.3-5.el7.remi remi-safe
    php55-php-pecl-imagick-devel.x86_64 3.4.3-5.el7.remi remi-safe
    php56-php-pecl-imagick.x86_64 3.4.3-5.el7.remi remi-safe
    php56-php-pecl-imagick-devel.x86_64 3.4.3-5.el7.remi remi-safe
    php70-php-pecl-imagick.x86_64 3.4.3-8.el7.remi remi-safe
    php70-php-pecl-imagick-devel.x86_64 3.4.3-8.el7.remi remi-safe
    php71-php-pecl-imagick.x86_64 3.4.3-8.el7.remi remi-safe
    php71-php-pecl-imagick-devel.x86_64 3.4.3-8.el7.remi remi-safe

    と出て、php71-php-pecl-imagick-devel.x86_64をインストールしてみたのですが、全部インストールすべきでしょうか?

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.02%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる