質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.64%

railsを始めようと思うのですが、新しいコントローラーを作成できません、どうしたらいいですか??

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 3,575

KatoAtushi

score 14

 前提・実現したいこと

Railsを始めようと思うのですが、新しいコントローラーを作成できません、どうしたら良いでしょうか???
教えて頂けたら嬉しいです。

Railsの環境設定でつまずいてます。

Railsの環境設定実装中に以下のエラーメッセージが発生しました。

 発生している問題・エラーメッセージ

Could not find gem 'sqlite3' in any of the gem sources listed in your Gemfile.
Run `bundle install` to install missing gems.

 該当のソースコード

$ rails g controller helo

 試したこと

$ sudo gem install rdoc
$  brew install gcc49
$ sudo gem install sqlite3 


と打ったら

ERROR:  While executing gem ... (Gem::CommandLineError)
    Unknown command sqlite3


とエラーが出てしまいました。

bundle install


を試してみたところ

-bash: /Users/katoatsushi/.rbenv/shims/bundle: No such file or directory


とエラーが出てしまいました。
```

 補足情報(FW/ツールのバージョンなど)

Ruby version 2.2.5です。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • rinren

    2018/02/23 21:28

    OS自体にsqlite3はインストールされていますか?os情報も示してください。

    キャンセル

  • ryochin

    2018/02/24 11:01

    まず bundler とはなにかについて勉強されるのがよろしいかと思います。

    キャンセル

回答 1

checkベストアンサー

+1

Rails 以前の問題ですね。順を追って問題点を探りたいところです。

まず,

$ sudo gem install sqlite3 

とやったら,

ERROR:  While executing gem ... (Gem::CommandLineError)
    Unknown command sqlite3

が出た,とのことですが,これは違うのではないかと思います。

このエラーメッセージは gem コマンドの第一引数(つまり gem コマンドのコマンド)として sqlite3 を与えたときに出るもののはずです。

なのでうっかり install を抜かした,ということはありませんか?

コマンドラインに打ったものを teratail にコピペしましたか? 打ち直すとよく間違うので,コピペするといいですよ。

それから,

$ sudo gem install rdoc

を試した,とのことですが,これは成功したのですね?
すると gem コマンドはまあ正常ぽいですね。

次に,sqlite3 gem のインストールに成功しているのかいないのかが重要なので,

$ gem list sqlite3

をやって,インストールされているか否かを確認してください。

インストールされている場合,念のため,

$ ruby -r sqlite3 -e "p SQLite3::VERSION"

とやってこの gem が動作することを確認してみましょう。
正しくインストールできていれば,gem list sqlite3 で見たのと同じバージョン番号が表示されます。

次に

$ gem list bundler

とやって,bundler という gem がインストールされているかを確かめます。

まずはここまでをやってみてください。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/02/27 18:36

    ありがとうございました。
    環境設定までは上手く行けました!!

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.64%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • トップ
  • Rubyに関する質問
  • railsを始めようと思うのですが、新しいコントローラーを作成できません、どうしたらいいですか??