質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.51%

  • Ruby on Rails 5

    3166questions

  • npm

    368questions

    npmは、Node Packaged Modulesの略。Node.jsのライブラリ・パッケージを管理できるツールです。様々なモジュールを簡単にインストールでき、自分でモジュールを作成し公開する際にも使用できます。

Rails5でサーバーを起動すると出るyarnのエラーが解消しない

受付中

回答 0

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 598

Statham

score 67

cloud9でrailsアプリケーションを作成しています。

Runしようとすると

=> Booting Puma
=> Rails 5.1.5 application starting in development 
=> Run `rails server -h` for more startup options


========================================
  Your Yarn packages are out of date!
  Please run `yarn install` to update.
========================================


To disable this check, please add `config.webpacker.check_yarn_integrity = false`
to your Rails development config file (config/environments/development.rb).


sh: 1: yarn: not found


Exiting


の表示が出て、止まってしまいます。

そこで、yarn installを試みると

yarn install v1.3.2
[1/4] Resolving packages...
success Already up-to-date.
Done in 1.11s.


のように、すべて最新だよと返してきます。しかし、Runしようとすると再び同様のエラーが出てきます。

もちろん、書いてあるように

config.webpacker.check_yarn_integrity = false


と設定を変更すればよいのですが、それはあまりしたくありません。

このエラーを解消する方法をご存知のかた、教えてください。。
というか、パッケージがすべて最新なのにも関わらずこの表示が出てくることが謎ですので、理由だけでもわかるかた、お願いします。。

一応、以下が自分の環境です。
Ruby 2.4.3 
Rails 5.1 
Node.js 8.9.4
yarn 1.3.2
webpackerとreact(rails newのオプションで入れた

ちなみに、yarn -vでバージョンの確認はできるため、インストールはできていると思われます。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

まだ回答がついていません

同じタグがついた質問を見る

  • Ruby on Rails 5

    3166questions

  • npm

    368questions

    npmは、Node Packaged Modulesの略。Node.jsのライブラリ・パッケージを管理できるツールです。様々なモジュールを簡単にインストールでき、自分でモジュールを作成し公開する際にも使用できます。