質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
87.20%
Linux

Linuxは、Unixをベースにして開発されたオペレーティングシステムです。日本では「リナックス」と呼ばれています。 主にWebサーバやDNSサーバ、イントラネットなどのサーバ用OSとして利用されています。 上位500のスーパーコンピュータの90%以上はLinuxを使用しています。 携帯端末用のプラットフォームAndroidは、Linuxカーネル上に構築されています。

Ubuntu

Ubuntuは、Debian GNU/Linuxを基盤としたフリーのオペレーティングシステムです。

受付中

sudo apt upgrade ができない

takechikenkyu
gfdhrtjfdjtdj

総合スコア10

Linux

Linuxは、Unixをベースにして開発されたオペレーティングシステムです。日本では「リナックス」と呼ばれています。 主にWebサーバやDNSサーバ、イントラネットなどのサーバ用OSとして利用されています。 上位500のスーパーコンピュータの90%以上はLinuxを使用しています。 携帯端末用のプラットフォームAndroidは、Linuxカーネル上に構築されています。

Ubuntu

Ubuntuは、Debian GNU/Linuxを基盤としたフリーのオペレーティングシステムです。

0回答

-2評価

0クリップ

298閲覧

投稿2022/07/19 10:02

前提

ubuntu18.04上で”sudo apt upgrade”を実行したところエラーが発生してうまくいかない。

発生している問題・エラーメッセージ

Reading package lists... Done Building dependency tree Reading state information... Done You might want to run 'apt --fix-broken install' to correct these. The following packages have unmet dependencies: libc6-dev : Depends: libc6 (= 2.27-3ubuntu1.6) but 2.27-3ubuntu1 is installed E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

試したこと①/その結果

https://qiita.com/mizuhof/items/35f5f9b7892d78c406b6
サイトを参考に
$sudo apt --fix-broken installすると、

Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
fonts-freefont-ttf libpython-all-dev python-all python-all-dev
python-asn1crypto python-cffi-backend python-crypto python-cryptography
python-dbus python-enum34 python-gi python-idna python-ipaddress
python-keyring python-keyrings.alt python-pkg-resources python-secretstorage
python-setuptools python-six python-wheel python-xdg
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
libc6
Suggested packages:
glibc-doc
The following packages will be upgraded:
libc6
1 upgraded, 0 newly installed, 0 to remove and 411 not upgraded.
8 not fully installed or removed.
Need to get 2,211 kB of archives.
After this operation, 5,120 B of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://ports.ubuntu.com bionic-updates/main armhf libc6 armhf 2.27-3ubuntu1.6 [2,211 kB]
Fetched 2,211 kB in 3s (806 kB/s)
Preconfiguring packages ...
(Reading database ... 71382 files and directories currently installed.)
Preparing to unpack .../libc6_2.27-3ubuntu1.6_armhf.deb ...
readlink: invalid option -- 'm'
BusyBox v1.24.1 (2019-07-08 03:39:14 UTC) multi-call binary.

Usage: readlink [-fnv] FILE

Display the value of a symlink

-f Canonicalize by following all symlinks -n Don't add newline -v Verbose

dpkg: error processing archive /var/cache/apt/archives/libc6_2.27-3ubuntu1.6_armhf.deb (--unpack):
new libc6:armhf package pre-installation script subprocess returned error exit status 1
Errors were encountered while processing:
/var/cache/apt/archives/libc6_2.27-3ubuntu1.6_armhf.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

試したこと②/その結果

先ほどと同様のサイトを参考に、.debファイルを強制的にインストールしようと試みるも、
$sudo dpkg -i --force-overwrite /var/cache/apt/archives/libc6_2.27-3ubuntu1.6_armhf.deb

tu1.6_armhf.deb
dpkg: error: cannot access archive '/var/cache/apt/archives/libc6_2.27-3ubuntu1.6_armhf.deb': No such file or directory

とエラーで返されてしまう。

補足情報(FW/ツールのバージョンなど)

zyboz7-20にubuntu18.04をインストールしたsdcardを差し込み、windows10のPCとteratermにてUSBで接続された環境で行っています。
勉強を始めたばかりで至らない点もあると思いますがよろしくお願いします。

良い質問の評価を上げる

以下のような質問は評価を上げましょう

  • 質問内容が明確
  • 自分も答えを知りたい
  • 質問者以外のユーザにも役立つ

評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

気になる質問をクリップする

クリップした質問は、後からいつでもマイページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

  • プログラミングに関係のない質問
  • やってほしいことだけを記載した丸投げの質問
  • 問題・課題が含まれていない質問
  • 意図的に内容が抹消された質問
  • 過去に投稿した質問と同じ内容の質問
  • 広告と受け取られるような投稿

評価を下げると、トップページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

fourteenlength

2022/07/19 13:59

sudo dpkg -i --force-overwrite libc6_2.27-3ubuntu1.6_armhf.deb 問題のパスに問題のファイルがないので、上記のようにパスを省いだらDLして良く対応してくれそうな気がします。いかがでしょう。あとはダウングレードするのも手かと…
takechikenkyu

2022/07/20 03:12

fourteenlength 様 ありがとうございます。 $apt-cache policy libc-bin libc-bin: Installed: 2.27-3ubuntu1 Candidate: 2.27-3ubuntu1.6 Version table: 2.27-3ubuntu1.6 500 500 http://ports.ubuntu.com bionic-updates/main armhf Packages 2.27-3ubuntu1.5 500 500 http://ports.ubuntu.com bionic-security/main armhf Packages *** 2.27-3ubuntu1 500 500 http://ports.ubuntu.com bionic/main armhf Packages 100 /var/lib/dpkg/status W: Target Packages (main/binary-armhf/Packages) is configured multiple times in /etc/apt/sources.list:1 and /etc/apt/sources.list:18 W: Target Packages (main/binary-all/Packages) is configured multiple times in /etc/apt/sources.list:1 and /etc/apt/sources.list:18 W: Target Packages (main/binary-armhf/Packages) is configured multiple times in /etc/apt/sources.list:4 and /etc/apt/sources.list:19 W: Target Packages (main/binary-all/Packages) is configured multiple times in /etc/apt/sources.list:4 and /etc/apt/sources.list:19 となっているので、2.27-3ubuntu1を2.27-3ubuntu1.6にダウングレードすべきなのでしょうか? もしそうなのであれば、どのようにやればいいでしょうか? よろしくお願いいたします。
fourteenlength

2022/07/20 09:41 編集

うまくいく保証がないので引き続きコメント欄で回答します。 https://red-souls.jp/ichounoki/rnote/memo/20201011_152705220651.htm こちらの方法でダウングレードできます。正確には、「バージョンを指定してインストール」するので結果としてダウングレードもできる、という感じです。 ※ダウングレードするときは、経験上少し古いバージョンにするより、ガツンと古いバージョンをインストールする方がうまくいく例が多いです。 万が一に備えて、今使っているライブラリとそのバージョンもどこかにメモしておいて、何かあった時にロールバックできるようにしておいてください。
takechikenkyu

2022/07/21 01:04

fourteenlength 様 ありがとうございます sudo apt upgrade時に以下のエラーが発生していたため、 libc6-dev : Depends: libc6 (= 2.27-3ubuntu1.6) but 2.27-3ubuntu1 is installed $sudo apt-get install libc6=2.27-3ubuntu1.6 を実行し、libc6のバージョンを指定してのインストールを試みたところ、エラーで返されてしまいました。 dpkg: error processing archive /var/cache/apt/archives/libc6_2.27-3ubuntu1.6_armhf.deb (--unpack): new libc6:armhf package pre-installation script subprocess returned error exit status 1 Errors were encountered while processing: /var/cache/apt/archives/libc6_2.27-3ubuntu1.6_armhf.deb E: Sub-process /usr/bin/dpkg returned an error code (1) 色々調べてみてはいるのですが上手くいきません。。 よろしくお願いいたします。
fourteenlength

2022/07/21 21:54

sudo apt-get install build-essential でlibc6もインストールされるようです。これで正しいバージョンに上書きできるかもしれません。 うだうだ言われたら、 sudo apt-get --reinstall install build-essential で強制再インストールに踏み切ればなおせるかもしれません。 ※OSが起動できなくなると困るので、大事なファイルは別のストレージに保存しておいてください

まだ回答がついていません

会員登録して回答してみよう

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
87.20%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問

同じタグがついた質問を見る

Linux

Linuxは、Unixをベースにして開発されたオペレーティングシステムです。日本では「リナックス」と呼ばれています。 主にWebサーバやDNSサーバ、イントラネットなどのサーバ用OSとして利用されています。 上位500のスーパーコンピュータの90%以上はLinuxを使用しています。 携帯端末用のプラットフォームAndroidは、Linuxカーネル上に構築されています。

Ubuntu

Ubuntuは、Debian GNU/Linuxを基盤としたフリーのオペレーティングシステムです。