質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
86.12%
RStudio

RStudioは、Rのプログラミングを効率化する統合開発環境です。統計計算とグラフィックスができるプログラミング言語であるRのIDEでOSSで公開されています。ソースコードやコンソールなどが一つの画面に見やすく配置されている点が特徴。コマンド名以外に、関数名やパッケージ名も補完できます。

解決済

R をupgrade(v4.2)したら、Seurat が動かない

akira5555
akira5555

総合スコア1

RStudio

RStudioは、Rのプログラミングを効率化する統合開発環境です。統計計算とグラフィックスができるプログラミング言語であるRのIDEでOSSで公開されています。ソースコードやコンソールなどが一つの画面に見やすく配置されている点が特徴。コマンド名以外に、関数名やパッケージ名も補完できます。

1回答

0リアクション

0クリップ

215閲覧

投稿2022/09/25 09:51

前提

もともと "R version 4.1.1 (2021-08-10)でSeuratを動かしていました.
しかし、the package "glmGamPoi" [which requires R (version "4.2") ],を動かすため "R-4.2.1.pkg (notarized and signed)"[https://cran.r-project.org/bin/macosx/]をインストール。すると、 Seuratが動かなくなりました。
versionにより動かなくなることがwebsiteに記載ありました。

実現したいこと

ここに実現したいことを箇条書きで書いてください。

  • Seurat  を  rstudioで動かせるように戻したい

発生している問題・エラーメッセージ

Warning: package ‘Seurat’ was built under R version 4.1.2Error: package or namespace load failed for ‘Seurat’ in loadNamespace(j <- i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]): namespace ‘Matrix’ 1.3-4 is being loaded, but >= 1.5.0 is required

該当のソースコード

library(Seurat)

試したこと

R v4.2.1アンインストール、もともと動いていたR version 4.1.1 (2021-08-10) を再度インストールしました。しかし、下記のエラーの通り、R4.1.1でも動かなくなってしまいました。

補足情報(FW/ツールのバージョンなど)

もともとSeuratを動かせているときは
R version 4.1.1 (2021-08-10)
Platform: aarch64-apple-darwin20 (64-bit)
Running under: macOS Monterey 12.5
rstudioapi_0.13
を使用していました

以下のような質問にはリアクションをつけましょう

  • 質問内容が明確
  • 自分も答えを知りたい
  • 質問者以外のユーザにも役立つ

リアクションが多い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

気になる質問をクリップする

クリップした質問は、後からいつでもマイページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

下記のような質問は推奨されていません。

  • 間違っている
  • 質問になっていない投稿
  • スパムや攻撃的な表現を用いた投稿

適切な質問に修正を依頼しましょう。

KojiDoi

2022/09/25 14:07

「下記のエラー」とは?
akira5555

2022/09/25 22:46

Library(Seurat) Warning: package ‘Seurat’ was built under R version 4.1.2Error: package or namespace load failed for ‘Seurat’ in loadNamespace(j <- i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]): namespace ‘Matrix’ 1.3-4 is being loaded, but >= 1.5.0 is required というエラーです

まだ回答がついていません

会員登録して回答してみよう

アカウントをお持ちの方は

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
86.12%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問

同じタグがついた質問を見る

RStudio

RStudioは、Rのプログラミングを効率化する統合開発環境です。統計計算とグラフィックスができるプログラミング言語であるRのIDEでOSSで公開されています。ソースコードやコンソールなどが一つの画面に見やすく配置されている点が特徴。コマンド名以外に、関数名やパッケージ名も補完できます。