質問編集履歴

1 修正

退会済みユーザー

退会済みユーザー

2016/07/20 00:15  投稿

railsのbundle installをするとmysqlのところでエラーが出てしまいます。
railsのbundle installをするとmysqlのところで下記のようなエラーが出たので、Gemfileのmysqlは下記のように変更しましたが、エラーが取れませんでした。
mysqlのversionの指定が間違えているのでしょうか?
 
 
ちなみにrubyとrailsのversionは下記になります。  
ruby 2.2.5  
Rails 4.2.6  
```
// エラー内容
An error occurred while installing mysql2 (0.3.21), and Bundler cannot continue.
Make sure that `gem install mysql2 -v '0.3.21'` succeeds before bundling.
```
```
// Gemfile
gem 'mysql2', '~>0.3.18'
```
  • Ruby on Rails

    17528 questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

思考するエンジニアのためのQ&Aサイト「teratail」について詳しく知る