質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
87.20%
Ruby

Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

解決済

rbenv で ruby2.4.2 をインストールしたが cgi で実行すると ruby1.8.7 で実行される

kimurayu
kimurayu

総合スコア0

Ruby

Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

1回答

0評価

0クリップ

1347閲覧

投稿2017/10/20 13:43

編集2022/01/12 10:58

rbenv で ruby2.4.2 をインストールしました。
以下のように切り替わっています。

$ which ruby ~/.rbenv/shims/ruby $ ruby -v ruby 2.4.2p198 (2017-09-14 revision 59899) [x86_64-linux]

index.rb をコマンドラインから実行すると ruby2.4.2 で実行されます。

ruby

index.rb #!/usr/bin/env ruby puts "Content-type: text/html\n\n" # ヘッダ(データの情報)を出力 puts # 仕切りとして、空行を出力 puts RUBY_VERSION # ruby のバージョンを表示

しかし ブラウザでcgiで実行すると、ruby1.8.7 で実行されます。

コマンドで実行 $ ruby index.rb -> 2.4.2 cgiで実行 http://hogehoge/index.rb -> 1.8.7

どこを変更すれば直るのでしょうか。

ruby 1.8.7 -> /usr/bin/ruby に元から入っていた
ruby 2.4.2 -> /home/ec2-user/.rbenv にインストールした

一行目を

ruby

#!/home/ec2-user/.rbenv/shims/ruby

にすると 500 internal server error になる

良い質問の評価を上げる

以下のような質問は評価を上げましょう

  • 質問内容が明確
  • 自分も答えを知りたい
  • 質問者以外のユーザにも役立つ

評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

気になる質問をクリップする

クリップした質問は、後からいつでもマイページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

  • プログラミングに関係のない質問
  • やってほしいことだけを記載した丸投げの質問
  • 問題・課題が含まれていない質問
  • 意図的に内容が抹消された質問
  • 過去に投稿した質問と同じ内容の質問
  • 広告と受け取られるような投稿

評価を下げると、トップページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

gouf
gouf

2017/10/21 09:07

システムのRuby のバージョンをアップグレードする方法は考えられませんか? なにか制限事項があるのですか?
kimurayu
kimurayu

2017/10/21 09:42

すみません、解決しました。/usr/bin/ruby にある1.8.7とは別に/usr/local/bin/rbenv にインストールし、/usr/local/bin/rbenv/shims/ruby にすることでできました。

まだ回答がついていません

会員登録して回答してみよう

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
87.20%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問

同じタグがついた質問を見る

Ruby

Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。